1. 1C / Говнокод #27037

    0

    1. 1
    2. 2
    3. 3
    4. 4
    Если Число(Сред(Строка(НачПериода),4,2)) <> Число(Сред(Строка(КонПериода),4,2)) Тогда
    	Предупреждение("Нельзя брать период с разными месяцами!!!");
    	Возврат;
    КонецЕсли;

    Мне так не дано писать код :-)

    Asinto, 17 Октября 2020

    Комментарии (4)
  2. 1C / Говнокод #27024

    0

    1. 1
    2. 2
    3. 3
    Если Ложь Тогда
    	Объ = Документы.ПоступлениеТоваровУслуг.СоздатьДокумент();	
    КонецЕсли;

    Умиляет

    sandvich, 13 Октября 2020

    Комментарии (20)
  3. 1C / Говнокод #26998

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    ДанныеКальлулятора = ПолучитьДанныеКалькулятораПоЗаявке(Заявка);
    	Расчет = ДанныеКальлулятора["ТЧ.Расчет"].Скопировать();
    	
    	ОстаточнаяПроцент = ДанныеКальлулятора["впОстаточнаяСтоимость"];
    	ПроцентнаяСтавка = ПолучитьДанныеКалькулятораПоЗаявке(Заявка)["рпСтоимостьКапитала"];
    	СрокЛизингаСтарыйИзКалькулятора = ПолучитьДанныеКалькулятораПоЗаявке(Заявка)["впСрокЛизинга"];
    	
    	ГибридСтавкаФинансированияКапитальнаяЧасть = ПолучитьДанныеКалькулятораПоЗаявке(Заявка)["ГибридСтавкаФинансированияКапитальнаяЧасть"];
    	ГибридСтавкаФинансированияОстаточнаяЧасть = ПолучитьДанныеКалькулятораПоЗаявке(Заявка)["ГибридСтавкаФинансированияОстаточнаяЧасть"];
    	ГибридФианансоваяМаржаКапитальнаяЧасть = ПолучитьДанныеКалькулятораПоЗаявке(Заявка)["ГибридФианансоваяМаржаКапитальнаяЧасть"];
    	ГибридФианансоваяМаржаОстаточнаяЧасть = ПолучитьДанныеКалькулятораПоЗаявке(Заявка)["ГибридФианансоваяМаржаОстаточнаяЧасть"];

    Как ж бомбит. Отраслёвка лизинговая

    sandvich, 02 Октября 2020

    Комментарии (24)
  4. 1C / Говнокод #26997

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    ЗапросШК.Текст = "ВЫБРАТЬ
    		|	НоменклатураКонтрагентов.Артикул КАК Артикул,
    		|	НоменклатураКонтрагентов.Штрихкод КАК Штрихкод,
    		|	НоменклатураКонтрагентов.Наименование КАК Наименование,
    		|	НоменклатураКонтрагентов.СтавкаНДС КАК ШК_короб,
    		|	НоменклатураКонтрагентов.ЕдиницаИзмеренияКод КАК ПечататьЕАНнаБатон
    		|ИЗ
    		|	РегистрСведений.НоменклатураКонтрагентовБЭД КАК НоменклатураКонтрагентов
    		|ГДЕ
    		|	НоменклатураКонтрагентов.Номенклатура = &Номенклатура
    		|	И НоменклатураКонтрагентов.Владелец = &Владелец";

    PoKoleno, 02 Октября 2020

    Комментарии (5)
  5. 1C / Говнокод #26995

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
    	
    	Если Данные.Свойство("Ссылка") И ЗначениеЗаполнено(Данные.Ссылка) Тогда
    		СтандартнаяОбработка = Ложь;
    		Представление = Данные.Ссылка.Наименование;
    	КонецЕсли; 
    	
    КонецПроцедуры

    У ребят не заладилось с этой процедурой. Смысла в этих действиях 0. Объект справочник.

    NioGoth, 01 Октября 2020

    Комментарии (24)
  6. 1C / Говнокод #26994

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
    	СтандартнаяОбработка=Ложь;
    	Представление="";
    	Для Каждого Стр Из Данные.Ссылка.Состав Цикл
    		Представление=Представление+?(Представление="","",", ")+Стр.Автомобиль;
    		Если СтрДлина(Представление)>50 Тогда 
    			Представление=Представление+"...";
    			Прервать
    		КонецЕсли;
    	КонецЦикла;
    	//Представление=""+Данные.Ссылка.Клиент+" ("+Представление+")";
    КонецПроцедуры

    А чё это списки у нас вдруг тормозить стали?

    NioGoth, 01 Октября 2020

    Комментарии (1)
  7. 1C / Говнокод #26831

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    Запрос = Новый Запрос;
    	Запрос.Текст = "ВЫБРАТЬ
    	|	БИТ_Отель_ДоговорыЭквайринга.Ссылка
    	|ИЗ
    	|	Справочник.БИТ_Отель_ДоговорыЭквайринга КАК БИТ_Отель_ДоговорыЭквайринга
    	|ГДЕ
    	|	БИТ_Отель_ДоговорыЭквайринга.ДоговорВзаиморасчетов = &ДоговорВзаиморасчетов";
    	
    	Запрос.УстановитьПараметр("ДоговорВзаиморасчетов", СтруктураПарам.БИТ_Отель_ДоговорЭквайринга.ДоговорВзаиморасчетов);
    	
    	Результат = Запрос.Выполнить().Выгрузить();
    	
    	Струк = Новый Структура;
    	Струк.Вставить("ВидОплаты", ВидОплаты);
    	
    	Если Результат.Количество() Тогда
    		РезОтбора =	Результат[0].Ссылка.ТарифыЗаРасчетноеОбслуживание.НайтиСтроки(Струк);
    		Если РезОтбора.Количество() Тогда
    			ПроцентТорговойУступки = РезОтбора[0].ПроцентТорговойУступки;
    		Иначе
    			ПроцентТорговойУступки = 0;
    			Предупреждение("Не указан процент торговой уступки!");
    			ЭлементыФормы.ПанельДокумента.ТекущаяСтраница = ЭлементыФормы.ПанельДокумента.Страницы.Эквайринг;
    			ЭлементыФормы.ПроцентТорговойУступки.ОтметкаНезаполненного = Истина;
    			ЭлементыФормы.СуммаТорговойУступки.ОтметкаНезаполненного = Истина;
    			ТекущийЭлемент = ЭлементыФормы.ПроцентТорговойУступки;
    		КонецЕсли;
    	Иначе
    		ПроцентТорговойУступки = 0;
    		Предупреждение("Не указан процент торговой уступки!");
    		ЭлементыФормы.ПанельДокумента.ТекущаяСтраница = ЭлементыФормы.ПанельДокумента.Страницы.Эквайринг;
    		ЭлементыФормы.ПроцентТорговойУступки.ОтметкаНезаполненного = Истина;
    		ЭлементыФормы.СуммаТорговойУступки.ОтметкаНезаполненного = Истина;
    		ТекущийЭлемент = ЭлементыФормы.ПроцентТорговойУступки;
    	КонецЕсли;

    уже шестой год я работаю с этой "конфой", жаль что ее целиком нельзя сюда выложить, там, не считая исходной бух части, сплошной креатив каких то ДЦП на обеденной перемене классе во втором.

    jah, 31 Июля 2020

    Комментарии (50)
  8. 1C / Говнокод #26813

    +3

    1. 1
    2. 2
    3. 3
    4. 4
    ГрИнвС = ?(ГрИнвЧ=1, "Первая", ?(ГрИнвЧ=2, "Вторая", ?(ГрИнвЧ=3, "Третья", 
             ?(ГрИнвЧ=4, "Четвертая", ?(ГрИнвЧ=5, "Пятая", ?(ГрИнвЧ=6, "Шестая",
    	 ?(ГрИнвЧ=7, "Седьмая", ?(ГрИнвЧ=8, "Восьмая", ?(ГрИнвЧ=9, "Девятая", 
    	   Строка(ГрИнвЧ))))))))));

    Определение группы инвалидности из числового значения. Возможно, код писал обладатель неизвестной медицине 9-й группы инвалидности.

    maalssy, 23 Июля 2020

    Комментарии (43)
  9. 1C / Говнокод #26806

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    ПапкаПоставщика = СокрЛП(Поставщик);
    Попытка Excel.ActiveWorkbook.Close(); Исключение КонецПопытки;
    Попытка Excel.Quit(); Исключение КонецПопытки;
    Попытка Excel = 0; Исключение КонецПопытки;
    Попытка Предупреждение("ПАУЗА", 1); Исключение КонецПопытки;
    Попытка СоздатьКаталог(Файл.Путь + "\отклонено\" + ПапкаПоставщика); Исключение КонецПопытки;
    Попытка
    	ПереместитьФайл(Файл.ПолноеИмя, Файл.Путь + "\отклонено\" + ПапкаПоставщика + "\" + Файл.Имя);
    Исключение
    	Попытка
    		ПереместитьФайл(Файл.ПолноеИмя, Файл.Путь + "\отклонено\" + Файл.Имя);
    	Исключение
    	КонецПопытки;
    КонецПопытки;
    Попытка
    	ФайлЛог = Новый ЗаписьТекста(Файл.Путь + "\отклонено\" + ПапкаПоставщика + "\" + Файл.Имя + ".txt");
    	ФайлЛог.ЗаписатьСтроку(Сообщение);
    Исключение
    	Попытка
    		ФайлЛог = Новый ЗаписьТекста(Файл.Путь + "\отклонено\" + Файл.Имя + ".txt");
    		ФайлЛог.ЗаписатьСтроку(Сообщение);
    	Исключение
    	КонецПопытки;
    КонецПопытки;

    Больше попыток Богу попыток!

    pgenav, 15 Июля 2020

    Комментарии (18)
  10. 1C / Говнокод #26734

    +1

    1. 1
    2. 2
    https://infostart.ru/public/72175/
    1C.Net:Предприятие + DirectX = 3D-графика на формах 1С:Предприятие

    Зачем? Зачем?

    j123123, 04 Июня 2020

    Комментарии (15)