1. Куча / Говнокод #28122

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    Бесконечный оффтоп имени kcalbа #1
    K C A L B K C A L B
    C C               C C
    A   +             A   +
    L     +           L     +
    B       K C A L B K C A L B
    K       C         K       C
    C       A         C       A
    A       L         A       L
    L       B         L       B
    K C A L K K C A L B       K
      C     C           C     C
        +   A             +   A
          + L               + L
            K C A L B K C A L B

    kcalbCube, 18 Апреля 2022

    Комментарии (135)
  2. Куча / Говнокод #28121

    +1

    1. 1
    2. 2
    3. 3
    https://hr.cetera.ru/tests-developers/
    
    Какой мяуздец )))

    Внимание, кандидаты в стажёры!

    Тестовое задание (поле анкеты «Ссылку на выполненное тестовое задание (ТОЛЬКО ДЛЯ СТАЖЁРОВ).») требуется выполнять сразу. Анкеты без тестового задания не рассматриваем, отказываем сразу. Этот тест — первое, на что смотрит проверяющий анкеты. Если поле пустое или там написано что-то вроде «сделаю потом» — «потом» не будет.

    KoWe4Ka_l7porpaMMep, 17 Апреля 2022

    Комментарии (30)
  3. 1C / Говнокод #28120

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    47. 47
    48. 48
    49. 49
    50. 50
    51. 51
    52. 52
    53. 53
    54. 54
    55. 55
    56. 56
    57. 57
    58. 58
    59. 59
    60. 60
    61. 61
    62. 62
    63. 63
    64. 64
    65. 65
    66. 66
    67. 67
    68. 68
    69. 69
    70. 70
    71. 71
    72. 72
    73. 73
    74. 74
    75. 75
    76. 76
    77. 77
    78. 78
    79. 79
    80. 80
    81. 81
    82. 82
    83. 83
    84. 84
    85. 85
    86. 86
    87. 87
    88. 88
    89. 89
    90. 90
    ЗапросБезСЛ = Новый Запрос;
    	ЗапросБезСЛ.Текст = "ВЫБРАТЬ
    	|	КарточкаСделкиТовары.Ссылка.Ссылка КАК СсылкаКС
    	|ИЗ
    	|	Документ.КарточкаСделки.Товары КАК КарточкаСделкиТовары
    	|ГДЕ
    	|	КарточкаСделкиТовары.Ссылка.Завершена = ЛОЖЬ
    	|	И КарточкаСделкиТовары.Ссылка.ПометкаУдаления = ЛОЖЬ
    	|	И (КарточкаСделкиТовары.СтатусСтроки = &СтатусСтрокиПлан
    	|			ИЛИ КарточкаСделкиТовары.СтатусСтроки = &СтатусСтрокиПланХочуВЗаказано
    	|			ИЛИ КарточкаСделкиТовары.Ссылка.Клиент = &Электросистем
    	|				И КарточкаСделкиТовары.СтатусСтроки <> &СтатусСтрокиЗавершено)
    	|	И КарточкаСделкиТовары.КонтрактнаяДата < НАЧАЛОПЕРИОДА(&ТекДата, ДЕНЬ)
    	|	И КарточкаСделкиТовары.Ссылка.Подразделение В ИЕРАРХИИ(&ДРП)
    	|	И КарточкаСделкиТовары.Ссылка.ДляПланаПроизводства = ЛОЖЬ
    	|	И КарточкаСделкиТовары.Ссылка.Дата > &ПрошлыйГод
    	|	И КарточкаСделкиТовары.Ссылка.Статус <> ЗНАЧЕНИЕ(Справочник.СтатусыКарточекСделки.Завершена)
    	//|	И КарточкаСделкиТовары.Ссылка.Номер = ""180010002""
    	|
    	|СГРУППИРОВАТЬ ПО
    	|	КарточкаСделкиТовары.Ссылка.Ссылка
    	|
    	|УПОРЯДОЧИТЬ ПО
    	|	КарточкаСделкиТовары.Ссылка.Дата УБЫВ";
    	ЗапросБезСЛ.УстановитьПараметр("СтатусСтрокиПлан", Справочники.СтатусыСтрокКарточкиСделки.Запланировано);
    	ЗапросБезСЛ.УстановитьПараметр("СтатусСтрокиПланХочуВЗаказано", Справочники.СтатусыСтрокКарточкиСделки.Заказано);
    	ЗапросБезСЛ.УстановитьПараметр("ТекДата", ТекущаяДата());
    	ЗапросБезСЛ.УстановитьПараметр("ДРП",Справочники.ФункциональныеОтделыПродаж.НайтиПоКоду("d16"));
    	ЗапросБезСЛ.УстановитьПараметр("Электросистем", Справочники.Контрагенты.НайтиПоКоду("140755"));
    	ЗапросБезСЛ.УстановитьПараметр("СтатусСтрокиЗавершено", Справочники.СтатусыСтрокКарточкиСделки.Завершено);
    	ЗапросБезСЛ.УстановитьПараметр("ПрошлыйГод", НачалоГода(НачалоГода(ТекущаяДата())-3 * 86400)); 	
    	
    	Выборка = ЗапросБезСЛ.Выполнить().Выбрать();
    	
    	сПользователь = Справочники.Пользователи.НайтиПоКоду("17 644").Руководитель;
    	НоваяКонтрДата = ОбщиеПроцедурыИФункции.ОпределитьДатуЗавершения(сПользователь,  ТекущаяДата(), 3600*8*1); 
    	
    	Пока Выборка.Следующий() Цикл
    		
    		КС = Выборка.СсылкаКС.ПолучитьОбъект();		
    		НеобходимоЗаписать = Ложь; 
    		
    		Если ЗначениеЗаполнено(Выборка.СсылкаКС.КодSL) Тогда
    			Для каждого Изделие из КС.Товары Цикл
    				
    				СтатусСтроки = ПолучитьСтатусСтрокиВSL(Выборка.СсылкаКС.КодSL,Изделие.НомерСтроки,Выборка.СсылкаКС.Склад);					
    				
    				Если СтатусСтроки <> Неопределено И СтатусСтроки <> "F" //выполн.
    					и  СтатусСтроки <> "C" //завершено
    					Тогда
    					
    					Если  Изделие.КонтрактнаяДата  < НачалоДня(ТекущаяДата()) Тогда
    						Если (Изделие.СтатусСтроки = Справочники.СтатусыСтрокКарточкиСделки.Запланировано 
    							или Изделие.СтатусСтроки = Справочники.СтатусыСтрокКарточкиСделки.Заказано) ИЛИ (Изделие.СтатусСтроки <> Справочники.СтатусыСтрокКарточкиСделки.Завершено И Выборка.СсылкаКС.Клиент = Справочники.Контрагенты.НайтиПоКоду("140755")) Тогда 
    							Изделие.КонтрактнаяДата = НоваяКонтрДата;
    							НеобходимоЗаписать = Истина;
    						КонецЕсли;
    					КонецЕсли;
    				КонецЕсли; 
    			КонецЦикла;	
    			
    			Если НеобходимоЗаписать Тогда
    				КС.Записать();
    				Документы.КарточкаСделки.ОбновитьПараметрыКарточкиСделкиВSL(КС);
    				rs = Неопределено;
    			КонецЕсли;
    			
    		Иначе
    			Для каждого Изделие из КС.Товары Цикл
    				
    				Если  Изделие.КонтрактнаяДата  < НачалоДня(ТекущаяДата()) Тогда
    					Если (Изделие.СтатусСтроки = Справочники.СтатусыСтрокКарточкиСделки.Запланировано 
    						или Изделие.СтатусСтроки = Справочники.СтатусыСтрокКарточкиСделки.Заказано) ИЛИ (Изделие.СтатусСтроки <> Справочники.СтатусыСтрокКарточкиСделки.Завершено И Выборка.СсылкаКС.Клиент = Справочники.Контрагенты.НайтиПоКоду("140755")) Тогда 
    						Изделие.КонтрактнаяДата = НоваяКонтрДата;
    						НеобходимоЗаписать = Истина;
    					КонецЕсли;
    				КонецЕсли;
    				
    			КонецЦикла; 
    			
    			Если НеобходимоЗаписать Тогда
    				КС.Записать(); 
    				
    				rs = Неопределено;  
    				
    			КонецЕсли;
    			
    		КонецЕсли; 	
    		
    	КонецЦикла;

    testtest69, 16 Апреля 2022

    Комментарии (20)
  4. C++ / Говнокод #28119

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    // https://github.com/gcc-mirror/gcc/blob/ec03862f809e544a9b7d28067e51597dc92a0244/libstdc%2B%2B-v3/include/bits/forward_list.tcc#L391-L411
    
      template<typename _Tp, typename _Alloc>
        bool
        operator==(const forward_list<_Tp, _Alloc>& __lx,
    	       const forward_list<_Tp, _Alloc>& __ly)
        {
          //  We don't have size() so we need to walk through both lists
          //  making sure both iterators are valid.
          auto __ix = __lx.cbegin();
          auto __iy = __ly.cbegin();
          while (__ix != __lx.cend() && __iy != __ly.cend())
    	{
    	  if (!(*__ix == *__iy))
    	    return false;
    	  ++__ix;
    	  ++__iy;
    	}
          if (__ix == __lx.cend() && __iy == __ly.cend())
    	return true;
          else
    	return false;
        }

    из стандартной библиотеки крестоговна от GCC

    j123123, 13 Апреля 2022

    Комментарии (54)
  5. Java / Говнокод #28118

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    public class Spot {
        private Piece piece;
        private int x;
        private int y;
      
        public Spot(int x, int y, Piece piece)
        {
            this.setPiece(piece);
            this.setX(x);
            this.setY(y);
        }
      
    
        public Piece getPiece() // метод возвращает объект фигуру
        {
            return this.piece;
        }
      
        public void setPiece(Piece p)
        {
            this.piece = p;
        }
      
        public int getX()
        {
            return this.x;
        }
      
        public void setX(int x)
        {
            this.x = x;
        }
      
        public int getY()
        {
            return this.y;
        }
      
        public void setY(int y)
        {
            this.y = y;
        }
    }

    Дизайн шахматной игры
    Эти виды вопросов задаются на интервью, чтобы судить о навыке объектно ориентированного дизайна кандидата. Итак, прежде всего, мы должны подумать о классах.
    https://habr.com/ru/post/660003/

    ISO, 10 Апреля 2022

    Комментарии (75)
  6. Assembler / Говнокод #28114

    0

    1. 001
    2. 002
    3. 003
    4. 004
    5. 005
    6. 006
    7. 007
    8. 008
    9. 009
    10. 010
    11. 011
    12. 012
    13. 013
    14. 014
    15. 015
    16. 016
    17. 017
    18. 018
    19. 019
    20. 020
    21. 021
    22. 022
    23. 023
    24. 024
    25. 025
    26. 026
    27. 027
    28. 028
    29. 029
    30. 030
    31. 031
    32. 032
    33. 033
    34. 034
    35. 035
    36. 036
    37. 037
    38. 038
    39. 039
    40. 040
    41. 041
    42. 042
    43. 043
    44. 044
    45. 045
    46. 046
    47. 047
    48. 048
    49. 049
    50. 050
    51. 051
    52. 052
    53. 053
    54. 054
    55. 055
    56. 056
    57. 057
    58. 058
    59. 059
    60. 060
    61. 061
    62. 062
    63. 063
    64. 064
    65. 065
    66. 066
    67. 067
    68. 068
    69. 069
    70. 070
    71. 071
    72. 072
    73. 073
    74. 074
    75. 075
    76. 076
    77. 077
    78. 078
    79. 079
    80. 080
    81. 081
    82. 082
    83. 083
    84. 084
    85. 085
    86. 086
    87. 087
    88. 088
    89. 089
    90. 090
    91. 091
    92. 092
    93. 093
    94. 094
    95. 095
    96. 096
    97. 097
    98. 098
    99. 099
    100. 100
    .set XSIZE 96h
    .set YSIZE 68h
    .org {11h * 2h}
    dw @vbi
    .org 80h
    .include "stdvideo.inc"
    process:
    	mov %cl YSIZE
    	.loopy:
    		mov %ch XSIZE
    		.loopx:
    			call @processCell
    			loop %ch @.loopx 
    		loop %cl @.loopy
    	ret
    processCell:
    	mov %d 0h
    	mov %bl 3h
    	.loopy:
    		mov %bh 3h
    		.loopx:
    			mov %e %c
    			add %e %b 
    			sub %e 0202h
    			cmp %e %c
    			ce jmp @.xskip
    			push %e
    			mov %bp %sp
    			call @index2rel
    			pop %e
    			cmpb [%e + @data] 0h
    			cg inc %d
    			.xskip:
    			loop %bh @.loopx
    		loop %bl @.loopy
    	push %c
    	mov %bp %sp
    	call @index2rel
    	pop %e
    	mov %al [%e + @data]
    	movb [%e + @ndata] 0h
    	cmp %al 0h
    	cz jmp @.dead
    		cmp %d 2h
    		cl ret
    		cmp %d 3h
    		cg ret
    		movb [%e + @ndata] 1h
    	ret
    	.dead:
    		cmp %d 3h
    		ce movb [%e + @ndata] 1h
    	ret
    fill:
    	mov %c {XSIZE * YSIZE}
    	.loop:
    		mov %b %c
    		mod %b 100h
    		div %b 8h
    		add %b 80h
    		mov %al [%b]
    		mov %b %c
    		mod %b 8h
    		mov %e 1h
    		shl %e %b
    		and %al %el
    		cnz movb [%c + @data] 1h
    		loop %c @.loop
    	ret
    render:
     	call @clsm1
    	mov %cl YSIZE 
    	.loopy:
    		mov %ch XSIZE
    		.loopx:
    			push %c
    			mov %bp %sp
    			call @index2rel
    			pop %e
    			cmpb [%e + @data] 1h
    			cge push %c
    			cge call @setpixelm1
    			cge pop
    			loop %ch @.loopx
    		loop %cl @.loopy
    	ret
    vbi:
    	cli
    	call @render
    	call @process
    	mov %c {XSIZE * YSIZE}
    	.loop:
    		movb [%c + @data] [%c + @ndata]
    		loop %c @.loop
    	rei
    T1:
    .org {3AAAh + @T1}
    data:
    .org {XSIZE * YSIZE + @data}
    ndata:

    https://pastebin.com/6gm30JWR
    https://imgur.com/a/uSzbrgZ

    игра конвея теперь и на pvc-16!

    kcalbCube, 09 Апреля 2022

    Комментарии (27)
  7. PHP / Говнокод #28113

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    47. 47
    48. 48
    49. 49
    50. 50
    51. 51
    52. 52
    53. 53
    54. 54
    55. 55
    56. 56
    57. 57
    58. 58
    59. 59
    60. 60
    61. 61
    62. 62
    63. 63
    // Проверка активных ip-адресов
    $is_active = false;
    if ($dir = opendir($path_active)) {
        while (false !== ($filename = readdir($dir))) {
            // Выбирается ip + время активации этого ip
            if (preg_match('#^(\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3})_(\d+)$#', $filename, $matches)) {
                if ($matches[2] >= time() - self::intervalSeconds) {
                    if ($matches[1] == $ip_address) {
                        $times = intval(trim(file_get_contents($path_active . $filename)));
                        if ($times >= self::intervalTimes - 1) {
                            touch($path_block . $filename);
                            unlink($path_active . $filename);
                        } else {
                            file_put_contents($path_active . $filename, $times + 1);
                        }
                        $is_active = true;
                    }
                } else {
                    unlink($path_active . $filename);
                }
            }
        }
        closedir($dir);
    }
    
    // Проверка заблокированных ip-адресов
    $is_block = false;
    if ($dir = opendir($path_block)) {
        while (false !== ($filename = readdir($dir))) {
            // Выбирается ip + время блокировки этого ip
            if (preg_match('#^(\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3})_(\d+)$#', $filename, $matches)) {
                if ($matches[2] >= time() - self::blockSeconds) {
                    if ($matches[1] == $ip_address) {
                        $is_block = true;
                        $time_block = $matches[2] - (time() - self::blockSeconds) + 1;
                    }
                } else {
                    unlink($path_block . $filename);
                }
            }
        }
        closedir($dir);
    }
    
    // ip-адрес заблокирован
    if ($is_block) {
        header('HTTP/1.0 502 Bad Gateway');
        echo '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">';
        echo '<html xmlns="http://www.w3.org/1999/xhtml">';
        echo '<head>';
        echo '<title>502 Bad Gateway</title>';
        echo '<meta http-equiv="content-type" content="text/html; charset=utf-8" />';
        echo '</head>';
        echo '<body>';
        echo '<h1 style="text-align:center">502 Bad Gateway</h1>';
        echo '<p style="background:#ccc;border:solid 1px #aaa;margin:30px au-to;padding:20px;text-align:center;width:700px">';
        echo 'К сожалению, Вы временно заблокированы, из-за частого запроса страниц сайта.<br />';
        echo 'Вам придется подождать. Через ' . $time_block . ' секунд(ы) Вы будете автоматически разблокированы.';
        echo '</p>';
        echo '</body>';
        echo '</html>';
        exit;
    }

    PHP-скрипт для защиты от DDOS, парсинга и ботов
    https://habr.com/ru/post/659811/

    ISO, 08 Апреля 2022

    Комментарии (19)
  8. Python / Говнокод #28112

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    > cat antilol.py
    #!/usr/bin/env python
    
    import evdev
    
    device = evdev.InputDevice('/dev/input/event2')
    
    three = [0, 0, 0]
    
    for event in device.read_loop():
        if event.type == evdev.ecodes.EV_KEY and event.value == 1:
            # print(event.code, evdev.ecodes.KEY[event.code])
            three = three[1:] + [event.code]
            if three == [
                            evdev.ecodes.KEY_L,
                            evdev.ecodes.KEY_O,
                            evdev.ecodes.KEY_L
                        ] or three == [
                            evdev.ecodes.KEY_K,
                            evdev.ecodes.KEY_J,
                            evdev.ecodes.KEY_K
                        ]:
                for i in range(0, 3):
                    device.write(evdev.ecodes.EV_KEY, evdev.ecodes.KEY_BACKSPACE, 1)
                    device.write(evdev.ecodes.EV_KEY, evdev.ecodes.KEY_BACKSPACE, 0)

    Отучаемся от вредных привычек.

    vistefan, 06 Апреля 2022

    Комментарии (100)
  9. Куча / Говнокод #28111

    +1

    1. 1
    Ёбаный openconnect

    openconnect -- это свободная реализация протоколоа CISCO AnyConnect VPN.

    В первом комменте опишу проблему.

    vistefan, 06 Апреля 2022

    Комментарии (64)
  10. Go / Говнокод #28110

    +1

    1. 1
    2. 2
    math.Min(float64, float64) float64
    math.Max(float64, float64) float64

    В goвне нету math.Min для integer. Даже в анскильном "Си" это есть.

    https://www.pixelstech.net/article/1559993656-Why-no-max-min-function-for-integer-in-GoLang

    3_dar, 05 Апреля 2022

    Комментарии (29)