1. JavaScript / Говнокод #28127

    +3

    1. 1
    2. 2
    // remove "s" ending: minute/hour/day/week/month/year don't have "s" in the body
    const period = periodName.split("s").join(""); // days -> day

    И тут решили добавить секунды...

    dhilt, 19 Апреля 2022

    Комментарии (13)
  2. PHP / Говнокод #28126

    0

    1. 1
    2. 2
    3. 3
    $path = str_replace("\\", "/", __FILE__);
    $path = substr($path, 0, strlen($path) - strlen("/index.php"));
    include($path."/version.php");

    официальный гайд битрикса по установке модулей))
    https://dev.1c-bitrix.ru/learning/course/index.php?COURSE_ID=101&LESSON_ID=2902
    мне литерали плохо уже

    x3x3n0m0rph, 19 Апреля 2022

    Комментарии (0)
  3. C++ / Говнокод #28125

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    void remove_spaces(string data)
    { int i=0,j=0;
        while(i<data.length())
        {
            if (isalpha(data[i]))
            {
            data[i]=data[i];
            i++;
            }
            else
                {
                data.erase(i,1);}
        }
        cout<<data;
    }

    kcalbCube, 19 Апреля 2022

    Комментарии (4)
  4. C++ / Говнокод #28124

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    auto&& rv = elements | std::ranges::views::values | std::ranges::views::transform([](auto&& a) -> auto 
    		{
    			StatisticsElementMultiple n = std::move(a);
    			n.nanosec /= n.count;
    			return n;
    		});
    		std::vector<StatisticsElementMultiple> el(std::begin(rv), std::end(rv));
    		std::ranges::sort(el, [](auto&& a, auto&& b) -> bool {return a.nanosec > b.nanosec; });
    		for(auto&& [nanosec, name, prefixes, count] : el)
    		{
    			printf("%-10d %04X %12s %6d\n", count, prefixes, name.c_str(), nanosec);
    		}

    kcalbCube, 18 Апреля 2022

    Комментарии (13)
  5. Куча / Говнокод #28122

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    Бесконечный оффтоп имени kcalbа #1
    K C A L B K C A L B
    C C               C C
    A   +             A   +
    L     +           L     +
    B       K C A L B K C A L B
    K       C         K       C
    C       A         C       A
    A       L         A       L
    L       B         L       B
    K C A L K K C A L B       K
      C     C           C     C
        +   A             +   A
          + L               + L
            K C A L B K C A L B

    kcalbCube, 18 Апреля 2022

    Комментарии (131)
  6. Куча / Говнокод #28121

    +1

    1. 1
    2. 2
    3. 3
    https://hr.cetera.ru/tests-developers/
    
    Какой мяуздец )))

    Внимание, кандидаты в стажёры!

    Тестовое задание (поле анкеты «Ссылку на выполненное тестовое задание (ТОЛЬКО ДЛЯ СТАЖЁРОВ).») требуется выполнять сразу. Анкеты без тестового задания не рассматриваем, отказываем сразу. Этот тест — первое, на что смотрит проверяющий анкеты. Если поле пустое или там написано что-то вроде «сделаю потом» — «потом» не будет.

    KoWe4Ka_l7porpaMMep, 17 Апреля 2022

    Комментарии (29)
  7. 1C / Говнокод #28120

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    47. 47
    48. 48
    49. 49
    50. 50
    51. 51
    52. 52
    53. 53
    54. 54
    55. 55
    56. 56
    57. 57
    58. 58
    59. 59
    60. 60
    61. 61
    62. 62
    63. 63
    64. 64
    65. 65
    66. 66
    67. 67
    68. 68
    69. 69
    70. 70
    71. 71
    72. 72
    73. 73
    74. 74
    75. 75
    76. 76
    77. 77
    78. 78
    79. 79
    80. 80
    81. 81
    82. 82
    83. 83
    84. 84
    85. 85
    86. 86
    87. 87
    88. 88
    89. 89
    90. 90
    ЗапросБезСЛ = Новый Запрос;
    	ЗапросБезСЛ.Текст = "ВЫБРАТЬ
    	|	КарточкаСделкиТовары.Ссылка.Ссылка КАК СсылкаКС
    	|ИЗ
    	|	Документ.КарточкаСделки.Товары КАК КарточкаСделкиТовары
    	|ГДЕ
    	|	КарточкаСделкиТовары.Ссылка.Завершена = ЛОЖЬ
    	|	И КарточкаСделкиТовары.Ссылка.ПометкаУдаления = ЛОЖЬ
    	|	И (КарточкаСделкиТовары.СтатусСтроки = &СтатусСтрокиПлан
    	|			ИЛИ КарточкаСделкиТовары.СтатусСтроки = &СтатусСтрокиПланХочуВЗаказано
    	|			ИЛИ КарточкаСделкиТовары.Ссылка.Клиент = &Электросистем
    	|				И КарточкаСделкиТовары.СтатусСтроки <> &СтатусСтрокиЗавершено)
    	|	И КарточкаСделкиТовары.КонтрактнаяДата < НАЧАЛОПЕРИОДА(&ТекДата, ДЕНЬ)
    	|	И КарточкаСделкиТовары.Ссылка.Подразделение В ИЕРАРХИИ(&ДРП)
    	|	И КарточкаСделкиТовары.Ссылка.ДляПланаПроизводства = ЛОЖЬ
    	|	И КарточкаСделкиТовары.Ссылка.Дата > &ПрошлыйГод
    	|	И КарточкаСделкиТовары.Ссылка.Статус <> ЗНАЧЕНИЕ(Справочник.СтатусыКарточекСделки.Завершена)
    	//|	И КарточкаСделкиТовары.Ссылка.Номер = ""180010002""
    	|
    	|СГРУППИРОВАТЬ ПО
    	|	КарточкаСделкиТовары.Ссылка.Ссылка
    	|
    	|УПОРЯДОЧИТЬ ПО
    	|	КарточкаСделкиТовары.Ссылка.Дата УБЫВ";
    	ЗапросБезСЛ.УстановитьПараметр("СтатусСтрокиПлан", Справочники.СтатусыСтрокКарточкиСделки.Запланировано);
    	ЗапросБезСЛ.УстановитьПараметр("СтатусСтрокиПланХочуВЗаказано", Справочники.СтатусыСтрокКарточкиСделки.Заказано);
    	ЗапросБезСЛ.УстановитьПараметр("ТекДата", ТекущаяДата());
    	ЗапросБезСЛ.УстановитьПараметр("ДРП",Справочники.ФункциональныеОтделыПродаж.НайтиПоКоду("d16"));
    	ЗапросБезСЛ.УстановитьПараметр("Электросистем", Справочники.Контрагенты.НайтиПоКоду("140755"));
    	ЗапросБезСЛ.УстановитьПараметр("СтатусСтрокиЗавершено", Справочники.СтатусыСтрокКарточкиСделки.Завершено);
    	ЗапросБезСЛ.УстановитьПараметр("ПрошлыйГод", НачалоГода(НачалоГода(ТекущаяДата())-3 * 86400)); 	
    	
    	Выборка = ЗапросБезСЛ.Выполнить().Выбрать();
    	
    	сПользователь = Справочники.Пользователи.НайтиПоКоду("17 644").Руководитель;
    	НоваяКонтрДата = ОбщиеПроцедурыИФункции.ОпределитьДатуЗавершения(сПользователь,  ТекущаяДата(), 3600*8*1); 
    	
    	Пока Выборка.Следующий() Цикл
    		
    		КС = Выборка.СсылкаКС.ПолучитьОбъект();		
    		НеобходимоЗаписать = Ложь; 
    		
    		Если ЗначениеЗаполнено(Выборка.СсылкаКС.КодSL) Тогда
    			Для каждого Изделие из КС.Товары Цикл
    				
    				СтатусСтроки = ПолучитьСтатусСтрокиВSL(Выборка.СсылкаКС.КодSL,Изделие.НомерСтроки,Выборка.СсылкаКС.Склад);					
    				
    				Если СтатусСтроки <> Неопределено И СтатусСтроки <> "F" //выполн.
    					и  СтатусСтроки <> "C" //завершено
    					Тогда
    					
    					Если  Изделие.КонтрактнаяДата  < НачалоДня(ТекущаяДата()) Тогда
    						Если (Изделие.СтатусСтроки = Справочники.СтатусыСтрокКарточкиСделки.Запланировано 
    							или Изделие.СтатусСтроки = Справочники.СтатусыСтрокКарточкиСделки.Заказано) ИЛИ (Изделие.СтатусСтроки <> Справочники.СтатусыСтрокКарточкиСделки.Завершено И Выборка.СсылкаКС.Клиент = Справочники.Контрагенты.НайтиПоКоду("140755")) Тогда 
    							Изделие.КонтрактнаяДата = НоваяКонтрДата;
    							НеобходимоЗаписать = Истина;
    						КонецЕсли;
    					КонецЕсли;
    				КонецЕсли; 
    			КонецЦикла;	
    			
    			Если НеобходимоЗаписать Тогда
    				КС.Записать();
    				Документы.КарточкаСделки.ОбновитьПараметрыКарточкиСделкиВSL(КС);
    				rs = Неопределено;
    			КонецЕсли;
    			
    		Иначе
    			Для каждого Изделие из КС.Товары Цикл
    				
    				Если  Изделие.КонтрактнаяДата  < НачалоДня(ТекущаяДата()) Тогда
    					Если (Изделие.СтатусСтроки = Справочники.СтатусыСтрокКарточкиСделки.Запланировано 
    						или Изделие.СтатусСтроки = Справочники.СтатусыСтрокКарточкиСделки.Заказано) ИЛИ (Изделие.СтатусСтроки <> Справочники.СтатусыСтрокКарточкиСделки.Завершено И Выборка.СсылкаКС.Клиент = Справочники.Контрагенты.НайтиПоКоду("140755")) Тогда 
    						Изделие.КонтрактнаяДата = НоваяКонтрДата;
    						НеобходимоЗаписать = Истина;
    					КонецЕсли;
    				КонецЕсли;
    				
    			КонецЦикла; 
    			
    			Если НеобходимоЗаписать Тогда
    				КС.Записать(); 
    				
    				rs = Неопределено;  
    				
    			КонецЕсли;
    			
    		КонецЕсли; 	
    		
    	КонецЦикла;

    testtest69, 16 Апреля 2022

    Комментарии (20)
  8. C++ / Говнокод #28119

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    // https://github.com/gcc-mirror/gcc/blob/ec03862f809e544a9b7d28067e51597dc92a0244/libstdc%2B%2B-v3/include/bits/forward_list.tcc#L391-L411
    
      template<typename _Tp, typename _Alloc>
        bool
        operator==(const forward_list<_Tp, _Alloc>& __lx,
    	       const forward_list<_Tp, _Alloc>& __ly)
        {
          //  We don't have size() so we need to walk through both lists
          //  making sure both iterators are valid.
          auto __ix = __lx.cbegin();
          auto __iy = __ly.cbegin();
          while (__ix != __lx.cend() && __iy != __ly.cend())
    	{
    	  if (!(*__ix == *__iy))
    	    return false;
    	  ++__ix;
    	  ++__iy;
    	}
          if (__ix == __lx.cend() && __iy == __ly.cend())
    	return true;
          else
    	return false;
        }

    из стандартной библиотеки крестоговна от GCC

    j123123, 13 Апреля 2022

    Комментарии (54)
  9. Java / Говнокод #28118

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    public class Spot {
        private Piece piece;
        private int x;
        private int y;
      
        public Spot(int x, int y, Piece piece)
        {
            this.setPiece(piece);
            this.setX(x);
            this.setY(y);
        }
      
    
        public Piece getPiece() // метод возвращает объект фигуру
        {
            return this.piece;
        }
      
        public void setPiece(Piece p)
        {
            this.piece = p;
        }
      
        public int getX()
        {
            return this.x;
        }
      
        public void setX(int x)
        {
            this.x = x;
        }
      
        public int getY()
        {
            return this.y;
        }
      
        public void setY(int y)
        {
            this.y = y;
        }
    }

    Дизайн шахматной игры
    Эти виды вопросов задаются на интервью, чтобы судить о навыке объектно ориентированного дизайна кандидата. Итак, прежде всего, мы должны подумать о классах.
    https://habr.com/ru/post/660003/

    ISO, 10 Апреля 2022

    Комментарии (73)
  10. Куча / Говнокод #28115

    0

    1. 1
    Заебали смузихлёбы.

    Я сейчас не про фронтендеров и дизайнеров, хотя они тоже заебали: ходят, блядь, в помещении в хипстерский зимних шапках, бесят блядь.

    На работе стоят автоматы с бесплатным кофе. Нет, это мы пить не будем, нам нужно в красивых стаканчиках смузи из кофеен и старбаксов. Старбакс закрылся - ГДЕ ТЕПЕРЬ ПОКУПАТЬ СМУЗИ С ИМЕННЫМИ СТАКАНЧИКАМИ ЗА 300р?

    Вчера приготовил смузи из морковки, кстати.

    OCETuHCKuu_nemyx, 09 Апреля 2022

    Комментарии (27)