1. Python / Говнокод #17434

    −124

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    47. 47
    48. 48
    49. 49
    50. 50
    51. 51
    52. 52
    53. 53
    54. 54
    55. 55
    56. 56
    57. 57
    58. 58
    print ("Программа вычисления номера подъезда.\nБудьте внимательны при вводе данных.\n")
    
    n_kvartiry = input("Введите номер квартиры...\n")
    n_kvartiry = int(n_kvartiry)
    
    kol_etazhey = input("Введите количество этажей в доме...\n")
    kol_etazhey = int(kol_etazhey)
    
    kol_kvartir_etazh = input("Введите количество квартир на этаже...\n")
    kol_kvartir_etazh = int(kol_kvartir_etazh)
    
    kol_kvart_pod = kol_kvartir_etazh * kol_etazhey
    result = n_kvartiry / kol_kvart_pod
    
    if result <= 1:
        print ("Номер подъезда 1")
        x=1
    elif result <= 2:
        x=2
        print ("Номер подъезда 2")
    elif result <= 3:
        x=3
        print ("Номер подъезда 3")
    elif result <= 4:
        x=4
        print ("Номер подъезда 4")
    elif result <= 5:
        x=5
        print ("Номер подъезда 5")
    elif result <= 6:
        x=6
        print ("Номер подъезда 6")
    elif result <= 7:
        x=7
        print ("Номер подъезда 7")
    elif result <= 8:
        x=8
        print ("Номер подъезда 8")
    elif result <= 9:
        x=9
        print ("Номер подъезда 9")
    elif result <= 10:
        x=10
        print ("Номер подъезда 10")
    elif result <= 11:
        x=11
        print ("Номер подъезда 11")
    elif result <= 12:
        x=12
        print ("Номер подъезда 12")
    else:
        print("Карлсон живет на крыше!!!")
        
    print ("Все квартиры в этом подъезде:")
           
    for n in range(1, kol_kvart_pod+1 ):
        res = n + kol_kvart_pod*(x-1)
        print (int(res), end=" ")

    python 3
    чисто поржать...

    chooduck, 12 Января 2015

    Комментарии (30)
  2. PHP / Говнокод #17433

    +166

    1. 1
    2. 2
    3. 3
    define("DB_YESTERDAY",date('d/m/Y', time()-172800-86400-86400-86400
    -86400-86400-86400-86400-86400-86400-86400-86400-86400-86400-86400
    -86400-86400-86400-86400-86400-86400-86400-86400-86400-86400)); //если более 2 дней подряд были выходные, валюты не показывались. Дописано "-86400"

    Дописано -86400? Забыли упомянуть, что 24 раза(

    govnokoder2, 12 Января 2015

    Комментарии (5)
  3. PHP / Говнокод #17432

    +158

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    /*...тут много строк...*/
    if($arraySection[$section_id[$j]]=='0'){
    echo '';
    
    }
    else{ 
        echo ' 
            <li><a href="/'.$arraySection[$section_id[$j]].'">'.$arraySection[$section_id[$j]].'</a></li>
    ';}
    /*...тут много строк...*/

    Любитель else

    sms-system, 12 Января 2015

    Комментарии (9)
  4. PHP / Говнокод #17431

    +161

    1. 1
    2. 2
    3. 3
    if (($arrRoleInHold = $this->syncByToken($token)) && (!$arrRoleInHold)) {
        throw new Exception('');
    }

    хорошее условие!

    tempfolder, 12 Января 2015

    Комментарии (4)
  5. 1C / Говнокод #17430

    −126

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    Если ЗаполненАдрес=0 Тогда
    	Если  ПустаяСтрока(Запрос.ЭлПочта)=0 Тогда
    		Продолжить;
    	Иначе
    		ТЗ.НоваяСтрока();
    		ТЗ.Код			= Запрос.Контрагенты.Код;
    		ТЗ.Контрагент 	= Запрос.Контрагенты.Наименование;
    		ТЗ.ЭлАдрес		= Запрос.ЭлПочта;
    	КонецЕсли;
    иначе
    	Если  ПустаяСтрока(Запрос.ЭлПочта)=1 Тогда
    		Продолжить;
    	Иначе
    		ТЗ.НоваяСтрока();
    		ТЗ.Код			= Запрос.Контрагенты.Код;
    		ТЗ.Контрагент 	= Запрос.Контрагенты.Наименование;
    		ТЗ.ЭлАдрес		= Запрос.ЭлПочта;
    	КонецЕсли;
    Конецесли;

    ЗаполненАдрес - это чекбокс.
    Если сократить код, то получится:

    Если ЗаполненАдрес<>ПустаяСтрока(Запрос.ЭлПоч та) Тогда
    ТЗ.НоваяСтрока();
    ТЗ.Код = Запрос.Контрагенты.Код;
    ТЗ.Контрагент = Запрос.Контрагенты.Наименование;
    ТЗ.ЭлАдрес = Запрос.ЭлПочта;
    КонецЕсли;

    noncode, 12 Января 2015

    Комментарии (9)
  6. Pascal / Говнокод #17429

    +86

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    function TSnifferMainForm.GetSetInjected(pID:Cardinal; Get:Boolean=False):Boolean;
    type rParam=record _pID:Cardinal; _Get,_Res:Boolean; end;
    const PE_STR='*RODC_PE ';
    var Params:rParam;
    function ProcCloseEnum(Handle:THandle; _Params:Integer):BOOL; stdcall;
    var TempPID:Cardinal; hCap:string; lCap:integer;
    begin
    Result:=True;
    GetWindowThreadProcessId(Handle,TempPID);
    if TempPID=rParam(Pointer(_Params)^)._pID then begin
    lCap:=SendMessage(Handle,WM_GETTEXTLENGTH,0,0);
    lCap:=lCap+1;
    SetLength(hCap,lCap-1);
    SendMessage(Handle,WM_GETTEXT,lCap,LongInt(@hCap[1]));
    if not rParam(Pointer(_Params)^)._Get then if Pos(PE_STR,hCap)=0 then SetWindowText(Handle,PAnsiChar(PE_STR+hCap)) else SetWindowText(Handle,PAnsiChar(StringReplace(hCap,PE_STR,'',[rfReplaceAll])))
    else if Pos(PE_STR,hCap)<>1 then rParam(Pointer(_Params)^)._Res:=False else rParam(Pointer(_Params)^)._Res:=True;
    Result:=False; end;
    end;
    begin
    Params._pID:=pID; Params._Get:=Get;
    EnumWindows(@ProcCloseEnum,Integer(@Params));
    Result:=Params._Res;
    end;

    Нет, сраный коллбек, я сделаю тебя локальным чего бы мне это не стоило!

    KOTOM, 12 Января 2015

    Комментарии (1)
  7. JavaScript / Говнокод #17428

    +162

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    function loadScript(varStr, codeStr) {
    					var $script = $('<script>').attr('type', 'text/javascript');
    					$script.html('var ' + varStr + ' = ' + codeStr);
    					document.getElementsByTagName("head")[0].appendChild($script[0]);
    			   }

    Как инициализировать переменную, используя любимый поисковик и jQuery

    dan, 12 Января 2015

    Комментарии (2)
  8. C++ / Говнокод #17427

    +55

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    else if(block->o_type == O_else)
        {
          block->o_type = O_else;
        }
      else if(block->o_type == O_endif)
        {
          block->o_type = O_endif;
        }
      else if(block->o_type == O_break)
        {
          block->o_type = O_break;
        }
      else if(block->o_type == O_continue)
        {
          block->o_type = O_continue;
        }
      else if(block->o_type == O_endwhile)
        {
          block->o_type = O_endwhile;
        }

    Lavir_the_Whiolet, 11 Января 2015

    Комментарии (23)
  9. C# / Говнокод #17426

    +133

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Text;
    
    namespace nonopt
    {
        class Program
        {
            static void Main(string[] args)
            {
                string h = "h";
                string e = "e";
                string l1 = "l";
                string l2 = "l";
                string o1 = "o";
                string he = h + e;
    			string ll = l1 + l2;
                string hell = he + ll;
                string hello = hell + o1;
                string w = "w";
                string o2 = "o";
                string r = "r";
                string l3 = "l";
                string d = "d";
                string wo = w + o2;
                string rl = r + l3;
                string worl = wo + rl;
                string world = worl + d;
                string empty = " ";
                Console.WriteLine(hello + empty + world);
    			Console.ReadKey();
            }
        }
    }

    pewppy, 10 Января 2015

    Комментарии (11)
  10. JavaScript / Говнокод #17425

    +169

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    for (var i = 0; i < result.Results.length; i++) {
        data = result.Results;
        if (i == 0) {
            $calendarPins = jQuery.parseJSON(data[i].Markers);
            GoogleMapsInitialization();
        }
    }

    Аж за душу взяло...

    zloynightmare, 09 Января 2015

    Комментарии (47)