1. Куча / Говнокод #17439

    +129

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    .hidden {
        display: block;
    }
    .visible {
        display: none;
    }

    И это не шутка. Я полдня искал ошибку в логике в JS, пока случайно увидел, почему модалка не выпрыгивает. Эх... верстальщики

    alexscrat, 13 Января 2015

    Комментарии (27)
  2. 1C / Говнокод #17438

    −125

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    9. 9
    ВЫБОР
    	КОГДА &ПоказыватьВсеПотребности
    	ТОГДА ВЫБОР 
    		КОГДА ОсновнаяТаблица.КоличествоПлана <= 0
    			ТОГДА ОсновнаяТаблица.КоличествоПлана
    		ИНАЧЕ ОсновнаяТаблица.КоличествоПлана
    	КОНЕЦ
    ИНАЧЕ ОсновнаяТаблица.КоличествоПлана
    КОНЕЦ КАК КоличествоПлана

    плана было больше количество, это уж точно

    dawgcha, 13 Января 2015

    Комментарии (9)
  3. C++ / Говнокод #17437

    +51

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    class CHECKSTRUCTURE_API GroupOfDocs : public std::unordered_multimap<std::string, std::shared_ptr<Doc> > // структура, которую клиент заполняет и передает в качестве входных и выходных данных для process. Ключом является имя файла 
    	{
    	public:
    #ifdef _DEBUG
    		virtual ~GroupOfDocs() {};
    #endif

    laMer007, 13 Января 2015

    Комментарии (15)
  4. C# / Говнокод #17436

    +132

    1. 001
    2. 002
    3. 003
    4. 004
    5. 005
    6. 006
    7. 007
    8. 008
    9. 009
    10. 010
    11. 011
    12. 012
    13. 013
    14. 014
    15. 015
    16. 016
    17. 017
    18. 018
    19. 019
    20. 020
    21. 021
    22. 022
    23. 023
    24. 024
    25. 025
    26. 026
    27. 027
    28. 028
    29. 029
    30. 030
    31. 031
    32. 032
    33. 033
    34. 034
    35. 035
    36. 036
    37. 037
    38. 038
    39. 039
    40. 040
    41. 041
    42. 042
    43. 043
    44. 044
    45. 045
    46. 046
    47. 047
    48. 048
    49. 049
    50. 050
    51. 051
    52. 052
    53. 053
    54. 054
    55. 055
    56. 056
    57. 057
    58. 058
    59. 059
    60. 060
    61. 061
    62. 062
    63. 063
    64. 064
    65. 065
    66. 066
    67. 067
    68. 068
    69. 069
    70. 070
    71. 071
    72. 072
    73. 073
    74. 074
    75. 075
    76. 076
    77. 077
    78. 078
    79. 079
    80. 080
    81. 081
    82. 082
    83. 083
    84. 084
    85. 085
    86. 086
    87. 087
    88. 088
    89. 089
    90. 090
    91. 091
    92. 092
    93. 093
    94. 094
    95. 095
    96. 096
    97. 097
    98. 098
    99. 099
    100. 100
    private Duplicate CheckForDuplicate(object name, object surname, object patronymic, object birthday, object oldSurname, out List<long> duplicateRowIDs)
            {
                duplicateRowIDs = new List<long>();
                DataTable _idDuplicateRowTable = new DataTable();
    
                //Проверка на полные дубликаты
                _idDuplicateRowTable = SqlWrapper.ExecuteQuery(
                    @"
                        SELECT id
                        FROM [Физические лица]
                        WHERE [Физические лица].Фамилия=@param0
                            AND [Физические лица].Имя=@param1
                            AND [Физические лица].Отчество=@param2
                            AND [Физические лица].[Дата рождения]=@param3
                            AND (( @param4 IS NOT NULL AND [Физические лица].[Старая фамилия]=@param4 )
                                OR (@param4 IS NULL AND [Физические лица].[Старая фамилия] IS NULL ))                       
                     ",
                      surname, name, patronymic, birthday, oldSurname
                    ).Tables[0];
                if (_idDuplicateRowTable.Rows.Count == 1)
                {
                    duplicateRowIDs.Add((long)_idDuplicateRowTable.Rows[0]["id"]);
                    return Duplicate.Fully;
                }
                //Несколько полных дубликатов
                if (_idDuplicateRowTable.Rows.Count > 1)
                {
                    foreach (DataRow duplicate in _idDuplicateRowTable.Rows)
                    {
                        duplicateRowIDs.Add((long)duplicate["id"]);
                    }
                    return Duplicate.SomeFullyDuplicates;
                }
                //Проверяем только ФИО+дата рождения
                _idDuplicateRowTable = SqlWrapper.ExecuteQuery(
                    @"
                        SELECT id, [Старая фамилия]
                        FROM [Физические лица]
                        WHERE [Физические лица].Фамилия=@param0
                            AND [Физические лица].Имя=@param1
                            AND [Физические лица].Отчествo=@param2
                            AND [Физические лица].[Дата рождения]=@param3
                     ",
                      surname, name, patronymic, birthday
                    ).Tables[0];
                if (_idDuplicateRowTable.Rows.Count == 1)
                {
                    if (_idDuplicateRowTable.Rows[0]["Старая фамилия"].Equals(DBNull.Value) && oldSurname is String)//Если стар. фамилия в БД == null & в файле != null 
                    {
                        duplicateRowIDs.Add((long)_idDuplicateRowTable.Rows[0]["id"]);
                        return Duplicate.OldSurnameDiff;
                    }
                    duplicateRowIDs.Add((long)_idDuplicateRowTable.Rows[0]["id"]);
                    return Duplicate.ErrOldSurname;
                }
                else if (_idDuplicateRowTable.Rows.Count > 1)
                {
                    foreach (DataRow row in _idDuplicateRowTable.Rows)
                    {
                        duplicateRowIDs.Add((long)row["id"]);
                    }
                    return Duplicate.SomeBaseDuplicates;
                }
                return Duplicate.NonDuplicate;
            }
    
            private bool IsPotentilaDuplicate(object name, object surname, object patronymic, object birthday, object oldSurname)
            {
                bool _isPotentilaDuplicate = false;
                //Проверяем, не станет ли строка дубликатом, после изменения
                //Только по ФИО+дате рождения
                DataTable _ponentialDuplicates1 = SqlWrapper.ExecuteQuery(
                    @"
                        SELECT id
                        FROM [Физические лица]
                        WHERE [Физические лица].Фамилия=@param0
                            AND [Физические лица].Имя=@param1
                            AND [Физические лица].Отчество=@param2
                            AND [Физические лица].[Дата рождения]=@param3
                     ",
                      oldSurname, name, patronymic, birthday
                    ).Tables[0];
                //Полное совпадение
                DataTable _ponentialDuplicates2 = SqlWrapper.ExecuteQuery(
                    @"
                        SELECT id
                        FROM [Физические лица]
                        WHERE [Физические лица].Фамилия=@param0
                            AND [Физические лица].Имя=@param1
                            AND [Физические лица].Отчество=@param2
                            AND [Физические лица].[Дата родения]=@param3
                            AND [Физические лица].[Старая фамилия]=@param4
                     ",
                      oldSurname, name, patronymic, birthday, surname
                    ).Tables[0];
                if (_ponentialDuplicates1.Rows.Count > 0 || _ponentialDuplicates2.Rows.Count > 0)
                {
                    _isPotentilaDuplicate = true;
                }
                return _isPotentilaDuplicate;}

    Ну.... Проверка на дубликаты перед вставкой в БД. Сляпал его я, по методологии "давай-давай-быстрее!!!!а-а-а не успеваем", для показа заказчикам будущей функциональности. Сейчас переделываю с помощью паттерна Декоратор (т.к. нужно опционально проверка по ФИО+Дата рождения или СНИЛС или и то, и другое)+ввел табличку История изменений фамилий вместо столбца Старая фамилия

    govnokoder1, 13 Января 2015

    Комментарии (12)
  5. PHP / Говнокод #17435

    +159

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    9. 9
    function decode_php_abbr($abbr){
    	if(strpos($abbr,'PHP')!==false){
    		$abbr=str_replace('PHP','PHP: Hypertext Preprocessor',$abbr);
    		decode_php_abbr($abbr);
    	}
    	else echo $abbr;
    }
    
    decode_php_abbr('PHP');

    Расшифровываем аббревиатуру PHP или когда на работе немного скучно.

    VokaMut, 13 Января 2015

    Комментарии (69)
  6. Python / Говнокод #17434

    −124

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    47. 47
    48. 48
    49. 49
    50. 50
    51. 51
    52. 52
    53. 53
    54. 54
    55. 55
    56. 56
    57. 57
    58. 58
    print ("Программа вычисления номера подъезда.\nБудьте внимательны при вводе данных.\n")
    
    n_kvartiry = input("Введите номер квартиры...\n")
    n_kvartiry = int(n_kvartiry)
    
    kol_etazhey = input("Введите количество этажей в доме...\n")
    kol_etazhey = int(kol_etazhey)
    
    kol_kvartir_etazh = input("Введите количество квартир на этаже...\n")
    kol_kvartir_etazh = int(kol_kvartir_etazh)
    
    kol_kvart_pod = kol_kvartir_etazh * kol_etazhey
    result = n_kvartiry / kol_kvart_pod
    
    if result <= 1:
        print ("Номер подъезда 1")
        x=1
    elif result <= 2:
        x=2
        print ("Номер подъезда 2")
    elif result <= 3:
        x=3
        print ("Номер подъезда 3")
    elif result <= 4:
        x=4
        print ("Номер подъезда 4")
    elif result <= 5:
        x=5
        print ("Номер подъезда 5")
    elif result <= 6:
        x=6
        print ("Номер подъезда 6")
    elif result <= 7:
        x=7
        print ("Номер подъезда 7")
    elif result <= 8:
        x=8
        print ("Номер подъезда 8")
    elif result <= 9:
        x=9
        print ("Номер подъезда 9")
    elif result <= 10:
        x=10
        print ("Номер подъезда 10")
    elif result <= 11:
        x=11
        print ("Номер подъезда 11")
    elif result <= 12:
        x=12
        print ("Номер подъезда 12")
    else:
        print("Карлсон живет на крыше!!!")
        
    print ("Все квартиры в этом подъезде:")
           
    for n in range(1, kol_kvart_pod+1 ):
        res = n + kol_kvart_pod*(x-1)
        print (int(res), end=" ")

    python 3
    чисто поржать...

    chooduck, 12 Января 2015

    Комментарии (30)
  7. PHP / Говнокод #17433

    +166

    1. 1
    2. 2
    3. 3
    define("DB_YESTERDAY",date('d/m/Y', time()-172800-86400-86400-86400
    -86400-86400-86400-86400-86400-86400-86400-86400-86400-86400-86400
    -86400-86400-86400-86400-86400-86400-86400-86400-86400-86400)); //если более 2 дней подряд были выходные, валюты не показывались. Дописано "-86400"

    Дописано -86400? Забыли упомянуть, что 24 раза(

    govnokoder2, 12 Января 2015

    Комментарии (5)
  8. PHP / Говнокод #17432

    +158

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    /*...тут много строк...*/
    if($arraySection[$section_id[$j]]=='0'){
    echo '';
    
    }
    else{ 
        echo ' 
            <li><a href="/'.$arraySection[$section_id[$j]].'">'.$arraySection[$section_id[$j]].'</a></li>
    ';}
    /*...тут много строк...*/

    Любитель else

    sms-system, 12 Января 2015

    Комментарии (9)
  9. PHP / Говнокод #17431

    +161

    1. 1
    2. 2
    3. 3
    if (($arrRoleInHold = $this->syncByToken($token)) && (!$arrRoleInHold)) {
        throw new Exception('');
    }

    хорошее условие!

    tempfolder, 12 Января 2015

    Комментарии (4)
  10. 1C / Говнокод #17430

    −126

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    Если ЗаполненАдрес=0 Тогда
    	Если  ПустаяСтрока(Запрос.ЭлПочта)=0 Тогда
    		Продолжить;
    	Иначе
    		ТЗ.НоваяСтрока();
    		ТЗ.Код			= Запрос.Контрагенты.Код;
    		ТЗ.Контрагент 	= Запрос.Контрагенты.Наименование;
    		ТЗ.ЭлАдрес		= Запрос.ЭлПочта;
    	КонецЕсли;
    иначе
    	Если  ПустаяСтрока(Запрос.ЭлПочта)=1 Тогда
    		Продолжить;
    	Иначе
    		ТЗ.НоваяСтрока();
    		ТЗ.Код			= Запрос.Контрагенты.Код;
    		ТЗ.Контрагент 	= Запрос.Контрагенты.Наименование;
    		ТЗ.ЭлАдрес		= Запрос.ЭлПочта;
    	КонецЕсли;
    Конецесли;

    ЗаполненАдрес - это чекбокс.
    Если сократить код, то получится:

    Если ЗаполненАдрес<>ПустаяСтрока(Запрос.ЭлПоч та) Тогда
    ТЗ.НоваяСтрока();
    ТЗ.Код = Запрос.Контрагенты.Код;
    ТЗ.Контрагент = Запрос.Контрагенты.Наименование;
    ТЗ.ЭлАдрес = Запрос.ЭлПочта;
    КонецЕсли;

    noncode, 12 Января 2015

    Комментарии (9)