1. 1C / Говнокод #23294

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    &НаКлиенте
    Процедура Заполнить(Команда)
    	
    	КоличествоСтрок = ПроверитьКоличествоСтрок();
    	….	
    
    КонецПроцедуры
    
    &НаСервере
    Функция ПроверитьКоличествоСтрок()
    	ТаблицаТабеля = ЭтотОбъект.ТаблицаЧасов.Выгрузить();
    	Возврат ТаблицаТабеля.Количество();
    КонецФункции

    Шедевр от одного крупного франчайзи.

    SpitfireIX, 23 Августа 2017

    Комментарии (10)
  2. 1C / Говнокод #23261

    +1

    1. 1
    мДата = Дата(Год(Объект.Дата), Месяц(Объект.Дата), 1, 0, 0, 0);

    НачалоМесяца(Объект.Дата)? Нет, это же так скучно и избито!

    NachtLied, 12 Августа 2017

    Комментарии (1)
  3. 1C / Говнокод #23260

    −1

    1. 1
    2. 2
    3. 3
    https://github.com/covrom/gonec
    
    1C:Enterprise-like language interpreter written in Go https://covrom.github.io/gonec/

    ГОВНЕЦ (govnec)
    Интерпретатор и платформа создания микросервисов на 1С-подобном языке

    Цели

    Интерпретатор создан для решения программистами 1С множества задач, связанных с высокопроизводительными распределенными вычислениями, создания вэб-сервисов и вэб-порталов для работы тысяч пользователей, работы с высокоэффективными базами данных с использованием синтаксиса языка, похожего, но не ограниченного возможностями языка 1С.

    Включив такой интерпретатор в свое решение, Вы можете предоставить высокий уровень сервиса для своих клиентов, который обгонит решения не только ваших конкурентов на рынке 1С, но и конкурентных платформ в enterprise.

    Интерпретатор разрабатывается “от простого к сложному”. На начальных этапах будет включена базовая функциональность многопоточных вычислений и сетевых сервисов. В перспективе планируется организация работы с различными базами данных и визуализация управляемых форм, созданных в конфигураторе.

    Еще никогда не были так просто доступны программистам 1С возможности:

    * Создать микросервис с произвольным сетевым протоколом, развернуть его на linux, в docker контейнере или кластере kubernetes
    * Выполнить сложную многопоточную вычислительную задачу для десятков тысяч подключающихся пользователей за миллисекунды
    * Взаимодействовать с пользователем через web-браузер с минимальным трафиком
    * Сохранять и получать данные с максимально доступной скоростью в key-value базах данн

    j123123, 12 Августа 2017

    Комментарии (39)
  4. 1C / Говнокод #23244

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    Если Отладка Тогда
    				ЗаписьXML.ЗаписатьТекст(СокрЛП(КодИнтернетЗаказа));
    			Иначе
    				ЗаписьXML.ЗаписатьТекст(СокрЛП(КодИнтернетЗаказа));
    			КонецЕсли;

    Безысходность. Судьба предрешена. Бедный Йорик.

    M1CE, 08 Августа 2017

    Комментарии (0)
  5. 1C / Говнокод #23234

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    Если ЭтоНовыйОбъект Тогда
    		Если Найти(НРег(ЭтотОбъект.ТекстЗаявки),"принтер") > 0 Тогда
    			ЭтотОбъект.ВидОбращения = Справочники.ИТ_ПричинаОбращения.НайтиПоНаименованию("Принтер");
    		КонецЕсли;
    	КонецЕсли;

    Если в тексте заявки есть "принтер", значит это по принтеру, если в тексте "Замените картридж" - peaceDa рулю.

    M1CE, 02 Августа 2017

    Комментарии (0)
  6. 1C / Говнокод #23173

    +2

    1. 1
    2. 2
    3. 3
    4. 4
    defmodule Utils.String do
      @moduledoc false
      def comma_split(str), do: String.split(str, " ", trim: true)
    end

    AndrewDryga, 10 Июля 2017

    Комментарии (7)
  7. 1C / Говнокод #23081

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    //Модуль основной формы внешней обработки
    
    &НаКлиенте
    Процедура ПродатьСлона(Оферта)
    	
    	Перем Акцепт;
    	
    	Если ПустаяСтрока(Оферта) Тогда
    		
    		Оферта = "Купи слона!";
    		
    	Иначе
    		
    		Оферта = "Все говорят """+Оферта+""" а ты купи слона!";
    		
    	КонецЕсли;	
    		
    	ВвестиСтроку(Акцепт,Оферта,0, Истина); 	
    		
        ПродатьСлона(Акцепт);
    	
    КонецПроцедуры	
    
    &НаКлиенте
    Процедура ПриОткрытии(Отказ)
    	
    	ПродатьСлона("");
    	
    КонецПроцедуры

    Продаём слона!

    informatikmarazmatik, 30 Мая 2017

    Комментарии (9)
  8. 1C / Говнокод #23071

    −1

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    Попытка
               ЗаблокироватьДанныеФормыДляРедактирования();
    Исключение
               ВызватьИсключение КраткоеОписаниеОшибки(ОписаниеОшибки());
    КонецПопытки

    Процедура ЗаблокироватьДанныеФормыДляРедактировани я() при невозможности заблокировать данные сама вызывает исключение

    acula98, 26 Мая 2017

    Комментарии (3)
  9. 1C / Говнокод #23056

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    рсДополнительныеСведения = РегистрыСведений.ДополнительныеСведения.СоздатьНаборЗаписей();
    СвойствоУведомление = рсДополнительныеСведения.Добавить();
    СвойствоУведомление.Объект = ЭтотОбъект.Ссылка;
    СвойствоУведомление.Свойство = ДопСведение;
    СвойствоУведомление.Значение = Истина;
    рсДополнительныеСведения.Записать();

    Код одних франчей.
    причем все ж по ТЗ)) запись записалась? записалась! И побоку, что остальные записи при этом снесли нах)))

    Moonlight, 22 Мая 2017

    Комментарии (1)
  10. 1C / Говнокод #22905

    −263

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    Ответ = Вопрос("Будет запущена процедура создания договоров и печати документов. Продолжить?",
              РежимДиалогаВопрос.ДаНет, 60, КодВозвратаДиалога.Да, ЗаголовокОкнаПредупреждения);
        
    Если НЕ Ответ = КодВозвратаДиалога.Да Тогда
             Возврат;
    КонецЕсли;

    wezug, 05 Мая 2017

    Комментарии (2)