1. 1C / Говнокод #20968

    +1143

    1. 1
    2. 2
    Сёмин рот рабочий
    до хуёв охочий

    Проверка связи

    guesto, 26 Августа 2016

    Комментарии (1)
  2. 1C / Говнокод #20497

    +62

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    9. 9
    Запись = РегистрыСведений.СтатусыОповещенийПредстоящихПлатежей.СоздатьМенеджерЗаписи();
    		Запись.Период = Выборка.Период;
    		Запись.Контрагент = Выборка.Контрагент;
    		Запись.Прочитать();
    		Запись.ДатаПолучения = ТекущаяДата();
    		
    		НачатьТранзакцию();
    		Запись.Записать(Истина);
    		ЗафиксироватьТранзакцию();

    Дополнительная транзакция - лишняя.

    ilya2184, 09 Августа 2016

    Комментарии (13)
  3. 1C / Говнокод #20464

    +18

    1. 1
    2. 2
    3. 3
    4. 4
    Функция ПеревестиДеньги(СчетИсточник, СчетПолучатель, Сумма)
            СнятьСоСчета(СчетИсточник, Сумма);
            ПополнитьСчет(СчетПолучатель, Сумма);
    КонецФункции

    Как написать эту функцию безопасно? Что делать, если ПополнитьСчет упадет с исключением, например?

    LispGovno, 03 Августа 2016

    Комментарии (27)
  4. 1C / Говнокод #20460

    +15

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    Функция ПроверитьРодителя(СчетРодитель,Счет)
    		
    	Запрос = Новый Запрос;
    	Запрос.Текст = 
    		"ВЫБРАТЬ
    		|	&Счет В ИЕРАРХИИ (&СчетРодитель) КАК ПроверкаСч";
    	
    	Запрос.УстановитьПараметр("Счет", Счет);
    	Запрос.УстановитьПараметр("СчетРодитель", СчетРодитель);
    	
    	РезультатЗапроса = Запрос.Выполнить();
    	
    	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    	
    	ВыборкаДетальныеЗаписи.Следующий();
    	Возврат ВыборкаДетальныеЗаписи.ПроверкаСч;	
    КонецФункции

    blMbl, 03 Августа 2016

    Комментарии (5)
  5. 1C / Говнокод #20422

    +13

    1. 1
    2. 2
    Если 
    ЗначениеЗаполнено(СсылкаНаОбъект) И ((Строка(ТипЗнч(СсылкаНаОбъект))="Документ ссылка: Поступление товаров и услуг") или (Строка(ТипЗнч(СсылкаНаОбъект))="Документ ссылка: Установка цен номенклатуры") или (Строка(ТипЗнч(СсылкаНаОбъект))="Документ ссылка: Перемещение товаров")) Тогда

    Проверяется тип документа

    tixis1c, 25 Июля 2016

    Комментарии (15)
  6. 1C / Говнокод #20379

    +14

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    Область.Параметры.месяц 	= МесяцДляГрафика;
    Область.Параметры.первое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("01", ДатаДляПечатиКалендаря));
    Область.Параметры.второе 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("02", ДатаДляПечатиКалендаря));
    Область.Параметры.третье 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("03", ДатаДляПечатиКалендаря));
    Область.Параметры.четвертое = ПеревестиВКалендарПредставл(ОпрДеньНедели("04", ДатаДляПечатиКалендаря));
    Область.Параметры.пятое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("05", ДатаДляПечатиКалендаря));
    Область.Параметры.шестое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("06", ДатаДляПечатиКалендаря));
    Область.Параметры.седьмое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("07", ДатаДляПечатиКалендаря));
    Область.Параметры.восьмое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("08", ДатаДляПечатиКалендаря));
    Область.Параметры.девятое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("09", ДатаДляПечатиКалендаря));
    Область.Параметры.десятое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("10", ДатаДляПечатиКалендаря));
    Область.Параметры.одиннадцатое 		= ПеревестиВКалендарПредставл(ОпрДеньНедели("11", ДатаДляПечатиКалендаря));
    Область.Параметры.двенадцатое 		= ПеревестиВКалендарПредставл(ОпрДеньНедели("12", ДатаДляПечатиКалендаря));
    Область.Параметры.тринадцатое 		= ПеревестиВКалендарПредставл(ОпрДеньНедели("13", ДатаДляПечатиКалендаря));
    Область.Параметры.четырнадцатое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("14", ДатаДляПечатиКалендаря));
    Область.Параметры.пятнадцатое 		= ПеревестиВКалендарПредставл(ОпрДеньНедели("15", ДатаДляПечатиКалендаря));
    Область.Параметры.шестнадцатое 		= ПеревестиВКалендарПредставл(ОпрДеньНедели("16", ДатаДляПечатиКалендаря));
    Область.Параметры.семнадцатое  		= ПеревестиВКалендарПредставл(ОпрДеньНедели("17", ДатаДляПечатиКалендаря));
    Область.Параметры.восемнадцатое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("18", ДатаДляПечатиКалендаря));
    Область.Параметры.девятнадцатое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("19", ДатаДляПечатиКалендаря));
    Область.Параметры.двадцатое		 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("20", ДатаДляПечатиКалендаря));
    Область.Параметры.двадцатьпервое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("21", ДатаДляПечатиКалендаря));
    Область.Параметры.двадцатьвторое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("22", ДатаДляПечатиКалендаря));
    Область.Параметры.двадцатьтретье	= ПеревестиВКалендарПредставл(ОпрДеньНедели("23", ДатаДляПечатиКалендаря));
    Область.Параметры.двадцатьчетвертое = ПеревестиВКалендарПредставл(ОпрДеньНедели("24", ДатаДляПечатиКалендаря));
    Область.Параметры.двадцатьпятое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("25", ДатаДляПечатиКалендаря));
    Область.Параметры.двадцатьшестое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("26", ДатаДляПечатиКалендаря));
    Область.Параметры.двадцатьседьмое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("27", ДатаДляПечатиКалендаря));
    Область.Параметры.двадцатьвосьмое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("28", ДатаДляПечатиКалендаря));
    Попытка
    	Область.Параметры.двадцатьдевятое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("29", ДатаДляПечатиКалендаря));
    	Область.Параметры.тридцатое			= ПеревестиВКалендарПредставл(ОпрДеньНедели("30", ДатаДляПечатиКалендаря));
    	Область.Параметры.тридцатьпервое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("31", ДатаДляПечатиКалендаря));
    Исключение
    КонецПопытки;

    Выводим на печать дни недели для каждого дня месяца

    CMblCL, 14 Июля 2016

    Комментарии (5)
  7. 1C / Говнокод #20374

    +17

    1. 1
    2. 2
    Предложили стажировку, нужно прогать на 1С
    Как думаете, соглашаться?

    guestinho, 13 Июля 2016

    Комментарии (15)
  8. 1C / Говнокод #20276

    +19

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    (defun is-mult-p (n multiple)
      (= (rem n multiple) 0))
    
    (defun fizzbuzz (&optional n)
      (let ((n (or n 1)))
        (if (> n 100)
            nil
            (progn
              (let ((mult-3 (is-mult-p n 3))
                    (mult-5 (is-mult-p n 5)))
                (if mult-3
                    (princ "Fizz"))
                (if mult-5
                    (princ "Buzz"))
                (if (not (or mult-3 mult-5))
                    (princ n))
                (princ #\linefeed)
                (fizzbuzz (+ n 1)))))))

    guestinho, 26 Июня 2016

    Комментарии (34)
  9. 1C / Говнокод #20263

    +11

    1. 1
    http://1c.ru/news/info.jsp?id=21537

    ну не вирус конечно, но первый дропер на 1С

    znsoft, 24 Июня 2016

    Комментарии (8)
  10. 1C / Говнокод #20260

    +14

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    может = "ИвановИИ";
    	текущий = ИмяПользователя();
    	Если Не текущий = может Тогда
    		ЭлементыФормы.ОсновныеДействияФормы.Кнопки.ОсновныеДействияФормыВыполнить.Доступность = РедактироватьУзел;
    		Предупреждение("Запустить обмен может пользователь: " + может );
    	КонецЕсли;

    а если незнающий прог пробел добавит лишний в имя пользователя (или уволится сотрудник)... права лягут, да? ну ок.

    oleganatolievich, 23 Июня 2016

    Комментарии (2)