1. 1C / Говнокод #20422

    0

    1. 1
    2. 2
    Если 
    ЗначениеЗаполнено(СсылкаНаОбъект) И ((Строка(ТипЗнч(СсылкаНаОбъект))="Документ ссылка: Поступление товаров и услуг") или (Строка(ТипЗнч(СсылкаНаОбъект))="Документ ссылка: Установка цен номенклатуры") или (Строка(ТипЗнч(СсылкаНаОбъект))="Документ ссылка: Перемещение товаров")) Тогда

    Проверяется тип документа

    tixis1c, 25 Июля 2016

    Комментарии (5)
  2. 1C / Говнокод #20379

    +3

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    Область.Параметры.месяц 	= МесяцДляГрафика;
    Область.Параметры.первое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("01", ДатаДляПечатиКалендаря));
    Область.Параметры.второе 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("02", ДатаДляПечатиКалендаря));
    Область.Параметры.третье 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("03", ДатаДляПечатиКалендаря));
    Область.Параметры.четвертое = ПеревестиВКалендарПредставл(ОпрДеньНедели("04", ДатаДляПечатиКалендаря));
    Область.Параметры.пятое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("05", ДатаДляПечатиКалендаря));
    Область.Параметры.шестое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("06", ДатаДляПечатиКалендаря));
    Область.Параметры.седьмое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("07", ДатаДляПечатиКалендаря));
    Область.Параметры.восьмое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("08", ДатаДляПечатиКалендаря));
    Область.Параметры.девятое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("09", ДатаДляПечатиКалендаря));
    Область.Параметры.десятое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("10", ДатаДляПечатиКалендаря));
    Область.Параметры.одиннадцатое 		= ПеревестиВКалендарПредставл(ОпрДеньНедели("11", ДатаДляПечатиКалендаря));
    Область.Параметры.двенадцатое 		= ПеревестиВКалендарПредставл(ОпрДеньНедели("12", ДатаДляПечатиКалендаря));
    Область.Параметры.тринадцатое 		= ПеревестиВКалендарПредставл(ОпрДеньНедели("13", ДатаДляПечатиКалендаря));
    Область.Параметры.четырнадцатое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("14", ДатаДляПечатиКалендаря));
    Область.Параметры.пятнадцатое 		= ПеревестиВКалендарПредставл(ОпрДеньНедели("15", ДатаДляПечатиКалендаря));
    Область.Параметры.шестнадцатое 		= ПеревестиВКалендарПредставл(ОпрДеньНедели("16", ДатаДляПечатиКалендаря));
    Область.Параметры.семнадцатое  		= ПеревестиВКалендарПредставл(ОпрДеньНедели("17", ДатаДляПечатиКалендаря));
    Область.Параметры.восемнадцатое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("18", ДатаДляПечатиКалендаря));
    Область.Параметры.девятнадцатое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("19", ДатаДляПечатиКалендаря));
    Область.Параметры.двадцатое		 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("20", ДатаДляПечатиКалендаря));
    Область.Параметры.двадцатьпервое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("21", ДатаДляПечатиКалендаря));
    Область.Параметры.двадцатьвторое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("22", ДатаДляПечатиКалендаря));
    Область.Параметры.двадцатьтретье	= ПеревестиВКалендарПредставл(ОпрДеньНедели("23", ДатаДляПечатиКалендаря));
    Область.Параметры.двадцатьчетвертое = ПеревестиВКалендарПредставл(ОпрДеньНедели("24", ДатаДляПечатиКалендаря));
    Область.Параметры.двадцатьпятое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("25", ДатаДляПечатиКалендаря));
    Область.Параметры.двадцатьшестое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("26", ДатаДляПечатиКалендаря));
    Область.Параметры.двадцатьседьмое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("27", ДатаДляПечатиКалендаря));
    Область.Параметры.двадцатьвосьмое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("28", ДатаДляПечатиКалендаря));
    Попытка
    	Область.Параметры.двадцатьдевятое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("29", ДатаДляПечатиКалендаря));
    	Область.Параметры.тридцатое			= ПеревестиВКалендарПредставл(ОпрДеньНедели("30", ДатаДляПечатиКалендаря));
    	Область.Параметры.тридцатьпервое 	= ПеревестиВКалендарПредставл(ОпрДеньНедели("31", ДатаДляПечатиКалендаря));
    Исключение
    КонецПопытки;

    Выводим на печать дни недели для каждого дня месяца

    CMblCL, 14 Июля 2016

    Комментарии (5)
  3. 1C / Говнокод #20374

    +5

    1. 1
    2. 2
    Предложили стажировку, нужно прогать на 1С
    Как думаете, соглашаться?

    guestinho, 13 Июля 2016

    Комментарии (15)
  4. 1C / Говнокод #20276

    +5

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    (defun is-mult-p (n multiple)
      (= (rem n multiple) 0))
    
    (defun fizzbuzz (&optional n)
      (let ((n (or n 1)))
        (if (> n 100)
            nil
            (progn
              (let ((mult-3 (is-mult-p n 3))
                    (mult-5 (is-mult-p n 5)))
                (if mult-3
                    (princ "Fizz"))
                (if mult-5
                    (princ "Buzz"))
                (if (not (or mult-3 mult-5))
                    (princ n))
                (princ #\linefeed)
                (fizzbuzz (+ n 1)))))))

    guestinho, 26 Июня 2016

    Комментарии (34)
  5. 1C / Говнокод #20263

    0

    1. 1
    http://1c.ru/news/info.jsp?id=21537

    ну не вирус конечно, но первый дропер на 1С

    znsoft, 24 Июня 2016

    Комментарии (7)
  6. 1C / Говнокод #20260

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    может = "ИвановИИ";
    	текущий = ИмяПользователя();
    	Если Не текущий = может Тогда
    		ЭлементыФормы.ОсновныеДействияФормы.Кнопки.ОсновныеДействияФормыВыполнить.Доступность = РедактироватьУзел;
    		Предупреждение("Запустить обмен может пользователь: " + может );
    	КонецЕсли;

    а если незнающий прог пробел добавит лишний в имя пользователя (или уволится сотрудник)... права лягут, да? ну ок.

    oleganatolievich, 23 Июня 2016

    Комментарии (1)
  7. 1C / Говнокод #20256

    0

    1. 1
    Если ВРЕГ(ДанныеСчета.УсловияЗаполнения)<>"ЛОЖЬ" Тогда

    УПП 1.3 (1.3.75.2)
    ОбщиеМодули.СчетаУчетаВДокументах

    Подскажите если изменятся языковые настройки конфигурации как себя поведет данный код?

    znsoft, 23 Июня 2016

    Комментарии (8)
  8. 1C / Говнокод #20254

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    Запрос=Новый Запрос;
    	ТекстЗапроса="ВЫБРАТЬ
    	|	РасходнаяНакладнаяТовары.Товар КАК Товар,
    	|	РасходнаяНакладнаяТовары.Ссылка КАК Ссылка,
    	|	СУММА(РасходнаяНакладнаяТовары.Количество) КАК КоличествоОстаток
    	|ИЗ
    	|	Документ.РасходнаяНакладная.Товары КАК РасходнаяНакладнаяТовары
    	|ГДЕ
    	|	РасходнаяНакладнаяТовары.Ссылка.Проведен = Ложь
    	|	И РасходнаяНакладнаяТовары.Ссылка.ПометкаУдаления = Ложь
    	|";
    	Если ЗначениеЗаполнено(ВыбСклад) Тогда
    		ТекстЗапроса=ТекстЗапроса+"
    		|	И РасходнаяНакладнаяТовары.Ссылка.Склад =&ВыбСклад ";
    	КонецЕсли; 
    	Если ВыбТовар.Количество()>0 Тогда
    		ТекстЗапроса=ТекстЗапроса+"
    		|	И РасходнаяНакладнаяТовары.Товар В ИЕРАРХИИ(&ВыбТовар) ";
    	КонецЕсли; 
    	ТекстЗапроса=ТекстЗапроса+"
    	|СГРУППИРОВАТЬ ПО
    	|	Товар,
    	|	Ссылка
    	|ИТОГИ
    	|	СУММА(КоличествоОстаток)
    	|ПО
    	|	ОБЩИЕ,
    	|	Товар,
    	|	Ссылка
    	|";
    	Запрос.Текст=ТекстЗапроса;			 
    	Запрос.УстановитьПараметр("ВыбСклад",ВыбСклад);
    	Запрос.УстановитьПараметр("ВыбТовар",ВыбТовар);
    	РезультатЗапроса=Запрос.Выполнить();
    	ТабДокумент = Новый ТабличныйДокумент;
    	Макет  = ПолучитьМакет("ОстаткиТоваров");
    	ОбластьМакета = Макет.ПолучитьОбласть("Шапа");

    построитель запроса не существует... шапа... ШАПА, КАРЛ!!!

    oleganatolievich, 23 Июня 2016

    Комментарии (33)
  9. 1C / Говнокод #20252

    0

    1. 001
    2. 002
    3. 003
    4. 004
    5. 005
    6. 006
    7. 007
    8. 008
    9. 009
    10. 010
    11. 011
    12. 012
    13. 013
    14. 014
    15. 015
    16. 016
    17. 017
    18. 018
    19. 019
    20. 020
    21. 021
    22. 022
    23. 023
    24. 024
    25. 025
    26. 026
    27. 027
    28. 028
    29. 029
    30. 030
    31. 031
    32. 032
    33. 033
    34. 034
    35. 035
    36. 036
    37. 037
    38. 038
    39. 039
    40. 040
    41. 041
    42. 042
    43. 043
    44. 044
    45. 045
    46. 046
    47. 047
    48. 048
    49. 049
    50. 050
    51. 051
    52. 052
    53. 053
    54. 054
    55. 055
    56. 056
    57. 057
    58. 058
    59. 059
    60. 060
    61. 061
    62. 062
    63. 063
    64. 064
    65. 065
    66. 066
    67. 067
    68. 068
    69. 069
    70. 070
    71. 071
    72. 072
    73. 073
    74. 074
    75. 075
    76. 076
    77. 077
    78. 078
    79. 079
    80. 080
    81. 081
    82. 082
    83. 083
    84. 084
    85. 085
    86. 086
    87. 087
    88. 088
    89. 089
    90. 090
    91. 091
    92. 092
    93. 093
    94. 094
    95. 095
    96. 096
    97. 097
    98. 098
    99. 099
    100. 100
    з.Текст = 
    	"ВЫБРАТЬ
    	|	СобственныеКонтрагенты.Контрагент
    	|ПОМЕСТИТЬ втСобственныеКонтрагенты
    	|ИЗ
    	|	РегистрСведений.СобственныеКонтрагенты КАК СобственныеКонтрагенты
    	|;
    	|
    	|////////////////////////////////////////////////////////////////////////////////
    	|ВЫБРАТЬ
    	|	РеализацияТоваровУслугТовары.Номенклатура КАК Номенклатура,
    	|	РеализацияТоваровУслугТовары.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
    	|	РеализацияТоваровУслугТовары.Цена КАК Цена,
    	|	РеализацияТоваровУслугТовары.Ссылка.Дата КАК Дата
    	|ПОМЕСТИТЬ втПоступление_Доки
    	|ИЗ
    	|	Документ.ПоступлениеТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
    	|ГДЕ
    	|	РеализацияТоваровУслугТовары.Ссылка.Проведен
    	|	И РеализацияТоваровУслугТовары.Ссылка.Дата <= КОНЕЦПЕРИОДА(&ДатаДок, ДЕНЬ)
    	|	И РеализацияТоваровУслугТовары.Ссылка.Организация = &ОрганизацияПродавец
    	|;
    	|
    	|////////////////////////////////////////////////////////////////////////////////
    	|ВЫБРАТЬ
    	|	втПоступление_Доки.Номенклатура КАК Номенклатура,
    	|	втПоступление_Доки.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
    	|	МАКСИМУМ(втПоступление_Доки.Дата) КАК Дата
    	|ПОМЕСТИТЬ втПоступление_Макс
    	|ИЗ
    	|	втПоступление_Доки КАК втПоступление_Доки
    	|
    	|СГРУППИРОВАТЬ ПО
    	|	втПоступление_Доки.Номенклатура,
    	|	втПоступление_Доки.ХарактеристикаНоменклатуры
    	|;
    	|
    	|////////////////////////////////////////////////////////////////////////////////
    	|ВЫБРАТЬ
    	|	втПоступление_Макс.Номенклатура,
    	|	втПоступление_Макс.ХарактеристикаНоменклатуры,
    	|	МИНИМУМ(втПоступление_Доки.Цена) КАК Цена
    	|ПОМЕСТИТЬ втПоступлениеЦена
    	|ИЗ
    	|	втПоступление_Макс КАК втПоступление_Макс
    	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ втПоступление_Доки КАК втПоступление_Доки
    	|		ПО втПоступление_Макс.Номенклатура = втПоступление_Доки.Номенклатура
    	|			И втПоступление_Макс.ХарактеристикаНоменклатуры = втПоступление_Доки.ХарактеристикаНоменклатуры
    	|			И втПоступление_Макс.Дата = втПоступление_Доки.Дата
    	|
    	|СГРУППИРОВАТЬ ПО
    	|	втПоступление_Макс.Номенклатура,
    	|	втПоступление_Макс.ХарактеристикаНоменклатуры
    	|;
    	|
    	|////////////////////////////////////////////////////////////////////////////////
    	|ВЫБРАТЬ
    	|	РеализацияТоваровУслугТовары.Номенклатура КАК Номенклатура,
    	|	РеализацияТоваровУслугТовары.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
    	|	РеализацияТоваровУслугТовары.Цена КАК Цена,
    	|	РеализацияТоваровУслугТовары.Ссылка.Дата КАК Дата
    	|ПОМЕСТИТЬ втРеализацияПоставщика_Доки
    	|ИЗ
    	|	Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
    	|ГДЕ
    	|	РеализацияТоваровУслугТовары.Ссылка.Проведен
    	|	И РеализацияТоваровУслугТовары.Ссылка.Дата <= КОНЕЦПЕРИОДА(&ДатаДок, ДЕНЬ)
    	|	И РеализацияТоваровУслугТовары.Ссылка.Организация = &ОрганизацияПродавец
    	|;
    	|
    	|////////////////////////////////////////////////////////////////////////////////
    	|ВЫБРАТЬ
    	|	втРеализацияПоставщика_Доки.Номенклатура КАК Номенклатура,
    	|	втРеализацияПоставщика_Доки.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
    	|	МАКСИМУМ(втРеализацияПоставщика_Доки.Дата) КАК Дата
    	|ПОМЕСТИТЬ втРеализацияПоставщика_Макс
    	|ИЗ
    	|	втРеализацияПоставщика_Доки КАК втРеализацияПоставщика_Доки
    	|
    	|СГРУППИРОВАТЬ ПО
    	|	втРеализацияПоставщика_Доки.Номенклатура,
    	|	втРеализацияПоставщика_Доки.ХарактеристикаНоменклатуры
    	|;
    	|
    	|////////////////////////////////////////////////////////////////////////////////
    	|ВЫБРАТЬ
    	|	втРеализацияПоставщика_Макс.Номенклатура,
    	|	втРеализацияПоставщика_Макс.ХарактеристикаНоменклатуры,
    	|	МИНИМУМ(втРеализацияПоставщика_Доки.Цена) КАК Цена
    	|ПОМЕСТИТЬ втРеализацияПоставщикаЦена
    	|ИЗ
    	|	втРеализацияПоставщика_Макс КАК втРеализацияПоставщика_Макс
    	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ втРеализацияПоставщика_Доки КАК втРеализацияПоставщика_Доки
    	|		ПО втРеализацияПоставщика_Макс.Номенклатура = втРеализацияПоставщика_Доки.Номенклатура
    	|			И втРеализацияПоставщика_Макс.ХарактеристикаНоменклатуры = втРеализацияПоставщика_Доки.ХарактеристикаНоменклатуры
    	|			И втРеализацияПоставщика_Макс.Дата = втРеализацияПоставщика_Доки.Дата
    	|
    	|СГРУППИРОВАТЬ ПО
    	|	втРеализацияПоставщика_Макс.Номенклатура,
    	|	втРеализацияПоставщика_Макс.ХарактеристикаНоменклатуры";

    про регистр накопления закупки мы походу не слышали... менеджер временных таблиц висит как глобальная переменная модуля формы, поиск организаций по коду в справочнике и т д

    oleganatolievich, 22 Июня 2016

    Комментарии (17)
  10. 1C / Говнокод #20251

    +2

    1. 1
    https://habrahabr.ru/post/247657/

    перлы:

    Платформа 1С — это лучший, а главное — отечественный продукт!

    В языке программирования нет классов (наследования, инкапсуляции, полиморфизма), нет анонимных функций и прочих современных фич. Но для решения большинства задач — это и не нужно!

    Нет жёсткой типизации переменных. В системе есть типы значений, но для переменных нет строгих правил по типизации. Переменная, хранившая ссылку, может через пару строчек кода уже хранить число или строку

    guestinho, 22 Июня 2016

    Комментарии (11)