1. 1C / Говнокод #25301

    +4

    1. 1
    2. 2
    3. 3
    Если ЭтаФорма.ВладелецФормы.ВладелецФормы.Объект.Заголовок = "Согласование контрагента " Или ЭтаФорма.ВладелецФормы.ВладелецФормы.Объект.Заголовок = "" Тогда
                 ЭтаФорма.ВладелецФормы.ВладелецФормы.Объект.Заголовок = "Согласование контрагента " + КонтрагентДО;
    КонецЕсли;

    Просто оставлю это здесь.
    Когда ж вы все передохните любители ВладельцевФормы через ВладельцаФормы.

    MaxBS, 11 Января 2019

    Комментарии (4)
  2. 1C / Говнокод #25300

    +2

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    Функция ИдентификаторЦепочки(Ссылка) Экспорт
    	
    	Результат = Документы.ЭтапПроизводства2_2.ПустаяСсылка();
    	
    	Запрос = Новый Запрос(
    	"ВЫБРАТЬ
    	|	Таблица.ИдентификаторЦепочки КАК ИдентификаторЦепочки
    	|ИЗ
    	|	Документ.ЭтапПроизводства2_2 КАК Таблица
    	|ГДЕ
    	|	Таблица.Ссылка = &Ссылка");
    	Запрос.УстановитьПараметр("Ссылка", Ссылка);
    	
    	Выборка = Запрос.Выполнить().Выбрать();
    	
    	Если Выборка.Следующий() Тогда
    		
    		Результат = Выборка.ИдентификаторЦепочки;
    		
    	КонецЕсли;
    	
    	Возврат Результат;
    	
    КонецФункции

    Функция из типовой, возвращает реквизит документа через жопу. Можно заменить на
    возврат ?(ЗначениеЗаполнено(Ссылка.Идентификатор Цепочки), Ссылка.ИдентификаторЦепочки, Документы.ЭтапПроизводства2_2.ПустаяСсыл ка()).
    А можно вообще нихуя не делать, потому что если реквизит не заполнен, там и так пустая ссылка.
    Нахуй так жить

    acula98, 11 Января 2019

    Комментарии (5)
  3. 1C / Говнокод #25236

    +1

    1. 1
    Сумма = Цел(Окр(Сумма * 1000, 0, 1)) / 1000;

    Или я мандаринов переел, или от этого портал должен открыться

    valchara, 27 Декабря 2018

    Комментарии (37)
  4. 1C / Говнокод #25211

    +1

    1. 1
    2. 2
    3. 3
    4. 4
    СообщениеСМС = Перечисления.СостоянияСообщенияSMS.Исходящее;
    		Для каждого СообщениеСМС Из СообщениеSMS.Услуги Цикл
    			СообщениеСМС.СостояниеСообщения = Перечисления.СостоянияСообщенияSMS.Исходящее;
    		КонецЦикла;

    1С:Медицина. Поликлинка

    gk-5ccd112a, 21 Декабря 2018

    Комментарии (4)
  5. 1C / Говнокод #25210

    +2

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    ТекЧас = Строка(Час(Дата2));
    ТекЧас = Прав("00" + ТекЧас, 2);
    ТекМин = Строка(Минута(Дата2));
    ТекМин = Прав("00" + ТекМин, 2);
    ТекВремя = ТекЧас + ":" + ТекМин;

    Это способ получить время в формате "чч:мм" из даты и времени (переменная Дата2).
    Заменяется этим:
    ТекВремя = Формат(Дата2, "ДФ=hh:mm");

    VladC, 21 Декабря 2018

    Комментарии (4)
  6. 1C / Говнокод #25178

    −5

    1. 1
    EFG тред иди.

    Тред в котором мы пишим реквесты и пожелания EFG.
    EFG, прикрути живое обновление через вебсокеты, переделай фронт уже с этого древнего говна, на модное SPA, прикрути нейросеточку и блокчейн.

    хуита, 11 Декабря 2018

    Комментарии (24)
  7. 1C / Говнокод #25164

    −1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    	//...
    	Если НЕ Отказ Тогда
    		
    		ЭтотОбъект.ОбменДанными.Загрузка = Истина;
    		ЭтотОбъект.Записать();
    		ЭтотОбъект.ОбменДанными.Загрузка = Ложь;
    		//...
    	КонецЕсли; 	
    	
    КонецПроцедуры // ПередЗаписью

    БУдУ, УТПдУ, УППдУ
    Бля, ну как так можно? Что за идиот это писал?
    Сначала Пактум от школьника, теперь эта херь...

    Asaharu, 07 Декабря 2018

    Комментарии (6)
  8. 1C / Говнокод #25161

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    процедура расш_таблицаприактивациистроки(элемент)
    простодеревозначений = новый деревозначений;
    простодеревозначений.очистить();
    конецпроцедуры
    //впадает в рекурсию и программа умирает
    
    процедура расш_таблицаприактивациистроки_(элемент)
    простодеревозначений = новый таблицазначений;
    простодеревозначений.очистить();
    конецпроцедуры
    //не впадает в рекурсию

    Чо поцоны, изи рекурсия. УТ 11. Насчет других не тестил.
    При активации строки ТЧ, срабатывает эта процедура. Создаю новое дерево значений, и при его очистки вызывается какой-то общий модуль который я не звал и начинает активировать всю форму - охуенно. соответственно вызывается эта процедура пофторно. При ТЗ такой хуйни нет.

    3oJIoTou_xyu, 06 Декабря 2018

    Комментарии (6)
  9. 1C / Говнокод #25096

    −2

    1. 1
    2. 2
    ТекстОшибки = НСтр("ru='Клиенту ""%Партнер%"" запрещена отгрузка.'");
    ТекстОшибки = СтрЗаменить(ТекстОшибки, "%Партнер%", Партнер);

    Когда платят за количество строчек, а не смысл. Ебала жаба гадюку просто.

    ChoaNyan, 19 Ноября 2018

    Комментарии (1)
  10. 1C / Говнокод #25093

    +1

    1. 1
    Выб = выбратьизсписка(элемент.списоквыбора,элемент);

    СИДЕЛ НАД ЭТОЙ ХУЕТОЙ ДЖВА ЧАСА, И НЕ ПОНИМАЛ ПОЧЕМУ ЭТОТ КУСОК НЕОТРАБАТЫВАЛ И ВОЗВРАЩАЛ НЕОПРЕДЕЛЕНО И СРАЗУ ЖЕ ПРОСКАКИВАЛ ДАЛЬШЕ. ХОТЯ ЭЛЕМЕНТ И СПИСОК ЕСТЬ, ПОИДЕИ ДОЛЖЕН БЫЛ ПОВЫСНУТЬ В ОЖИДАНИИ ПОКА ПОЛЬЗОВАТЕЛЬ ВЫБЕРЕТ ИЗ НЕГО ЗНАЧЕНИЕ.

    ОКАЗАЛОСЬ. ОТЛАДЧИК... РЕШИЛ ВЫЗЫВАТЬ САМ СЕБЕ ЭТОТ СПИСОК И САМ ПО СЕБЕ НИХУЯ НЕ ВЫБИРАТЬ.

    TOPT, 19 Ноября 2018

    Комментарии (8)