1. 1C / Говнокод #21782

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    9. 9
    Если Не ЕстьОшибки Тогда
    		
    		СформироватьФайлы(КоличествоФайлов, Объект.ВидВыгрузки, ВыгружатьСведенияОЗданиях, ВыгружатьДоговорыУправления, ВыгружатьСпособыФормированияФондаКР, ВыгружатьЗаявкиНаДобавлениеВременныхАдресов,
    						  Объект.КаталогВыгрузки, МакетЗаявокНаДобВА, МакетСФКР, МакетМКД, МакетЖД, МакетДУ,  МакетЛС, МакетПУ, МакетРасчетыРСО, МакетДОИ, ДополнительныеСоглашенияДУ, ДополнительныеУслугиДУ,
    						  КоммунальныеУслугиДУ, ТаблицаДУ, ТаблицаЖД, ТаблицаЖилыхПомещений, ТаблицаКодовУслуг, ТаблицаКомнатЖД, ТаблицаКомнатМКД, ТаблицаЛицевыхСчетов, ТаблицаМКД, ТаблицаНежилыхПомещений,
    						  ТаблицаПодъездов, КоличествоПартийМКД, КоличествоПартийЖД, СформированныеФайлы, ЭтотОбъект, СтруктураИменТаблицФормы, ТаблицаЗаявокНаДобВА, ТаблицаСФКР, ТаблицаСостоянияРасчетовРСОПериоды, 
    						  ТаблицаСостоянияРасчетовРСОДоговоры, Истина);
    						  
    	КонецЕсли;

    хоть убей, ну зачем так?????

    ya-ya, 05 Декабря 2016

    Комментарии (2)
  2. 1C / Говнокод #21762

    −4

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    //-------------------------------------
    Процедура ПриНачалеРаботыСистемы()    
    
    	//Ограничиваем цикл на пользователей...
    	Если (СокрЛП(ИмяПользователя())="Вася") тогда
    		//Делаем вызов процедуры "Оповещение" раз в 3600 секунд (1 час)...
    		ОбработкаОжидания("Оповещение",3600); 
    	КонецЕсли;
    	
    КонецПроцедуры

    Когда надо сделать циклическое обращение к другой процедуре через определённое кол-во времени...

    Anonizmus, 01 Декабря 2016

    Комментарии (45)
  3. 1C / Говнокод #21711

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    Функция ПроверкаЗаполнения()
    	Если НЕ ЗначениеЗаполнено(Контрагент) Тогда
    		Предупреждение("Не выбран контрагент!");
    		Возврат Ложь;
    	КонецЕсли;
    	Если НЕ ЗначениеЗаполнено(ВалютаДокумента) Тогда
    		Предупреждение("Не выбрана валюта документа!");
    		Возврат Ложь;
    	КонецЕсли;
    	Если НЕ ЗначениеЗаполнено(ДатаОкончания) Тогда
    		Предупреждение("Не выбрана дата окончания периода сверки!");
    		Возврат Ложь;
    	КонецЕсли;
    	Если ДатаОкончания < ДатаНачала Тогда
    	    Предупреждение("Неверно задан период сверки расчетов!");
    		Возврат Ложь;
    	КонецЕсли;	
    	Возврат Истина;
    КонецФункции

    Как нужно дрочить пользаков.

    blMbl, 23 Ноября 2016

    Комментарии (4)
  4. 1C / Говнокод #21707

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    Для каждого зн Из масЗначСтр Цикл
       столбик=столбик+1;
       ЕСЛИ столбик <5 Тогда
        Продолжить;
       ИНАЧЕЕСЛИ столбик =6 ИЛИ столбик =7 ИЛИ  столбик =9 Тогда
        Продолжить;
       ИНАЧЕЕСЛИ (столбик >10) И (столбик <19)  Тогда
        Продолжить;
       ИНАЧЕЕСЛИ (столбик >19) И (столбик <24)  Тогда
        Продолжить;
       ИНАЧЕЕСЛИ (столбик >24) И (столбик <28)  Тогда
        Продолжить;
       ИНАЧЕЕСЛИ  (столбик =29)  Тогда
        Продолжить;
       ИНАЧЕЕСЛИ  (столбик >30)  Тогда
        Продолжить;
       ИНАЧЕ
        номЗнач = номЗнач + 1;
        Если  номЗнач>4  Тогда
         Прервать;
        Иначе
         новСтр[номЗнач] = СтрЗаменить(зн,символОграничения,"""");
         //Запомним сразу дату
         Если  номЗнач=3   Тогда
          Сдата=зн; 
         КонецЕсли;
         А=1;
        КонецЕсли;
       КОНЕЦЕСЛИ;
      КонецЦикла;

    выборка элементов массива, зная позицию этих элементов

    DelHayprO, 22 Ноября 2016

    Комментарии (3)
  5. 1C / Говнокод #21614

    +2

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    	Кавычка = """";
    	ПереносСтроки = Символы.ПС;
    	Строка = "Процедура КнопкаВыполнитьНажатие(Кнопка)	Кавычка = ;	ПереносСтроки = Символы.ПС;	Строка = ;	Сообщить (ПереносСтроки + Лев(Строка, 40) + ПереносСтроки + Сред(Строка, 41, 11) + Кавычка + Кавычка + Кавычка + Кавычка + Сред(Строка, 52, 1) + ПереносСтроки + Сред(Строка, 53, 28) + ПереносСтроки		+ Сред(Строка, 81, 10) + Кавычка + Строка + Кавычка + Сред(Строка, 91, 1) + ПереносСтроки + Сред(Строка, 92, 198) + ПереносСтроки + Сред(Строка, 290, 194) + ПереносСтроки + Сред(Строка, 485)); КонецПроцедуры";
    	Сообщить (ПереносСтроки + Лев(Строка, 40) + ПереносСтроки + Сред(Строка, 41, 11) + Кавычка + Кавычка + Кавычка + Кавычка + Сред(Строка, 52, 1) + ПереносСтроки + Сред(Строка, 53, 28) + ПереносСтроки
    		+ Сред(Строка, 81, 10) + Кавычка + Строка + Кавычка + Сред(Строка, 91, 1) + ПереносСтроки + Сред(Строка, 92, 198) + ПереносСтроки + Сред(Строка, 290, 194) + ПереносСтроки + Сред(Строка, 485));
    КонецПроцедуры

    1С квайн

    mrbus, 31 Октября 2016

    Комментарии (7)
  6. 1C / Говнокод #21608

    +6

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    Для эстетов. Мы за это платим овердохуя, в получаем:
    
    Текст.запроса = Текст.Запроса + Сред(ТекстЗапроса,Врезка8+33,Врезка9-Врезка8+24-33+1) ;
    Мало того - что тут по буквам ТЕКСТ собирают, так еще и ошиблись - не +33 а +33-3 надо! ПИЗДЕЦ!
    Вот эта хуета - Сред(ТекстЗапроса,Врезка8+33,Врезка9-Врезка8+24-33+1)  - возвращает "ОР" - и компилятор орет на ошибку
    А вот эта наша хуета - Сред(ТекстЗапроса,Врезка8+33-3,Врезка9-Врезка8+24-33+1)  - возвращает "ВЫБОР" в все заебись работает.

    Из глубин прикладной 1С

    balabass, 31 Октября 2016

    Комментарии (13)
  7. 1C / Говнокод #21594

    +3

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    Функция ПроставитьНули (ЧислоНулей)
    	
    Если ЧислоНулей = 7 Тогда 	
    СтрокаНулей = "000000";	
    ИначеЕсли ЧислоНулей = 6 Тогда 	
    СтрокаНулей = "00000";		
    ИначеЕсли ЧислоНулей = 5 Тогда 		
    СтрокаНулей = "0000";		
    ИначеЕсли ЧислоНулей = 4 Тогда 		
    СтрокаНулей = "000";		
    ИначеЕсли ЧислоНулей =3 Тогда 		
    СтрокаНулей = "00";		
    ИначеЕсли ЧислоНулей =2 Тогда 		
    СтрокаНулей = "0";	
    ИначеЕсли ЧислоНулей =1 Тогда
    СтрокаНулей = "0";
    КонецЕсли;
    
    Возврат СтрокаНулей;
    		
    КонецФункции

    Разгребал завалы от предшественника. Случайно наткнулся.
    Правильно было бы так:
    Функция ПроставитьНули (ИсходноеЧисло, ЧислоНулей)
    Возврат Формат(ИсходноеЧисло, "ЧЦ="+ЧислоНулей+"; ЧВН=; ЧГ=0");
    КонецФункции

    Vince, 28 Октября 2016

    Комментарии (7)
  8. 1C / Говнокод #21559

    +2

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    	МетаданныеДокумента = Объект.Ссылка.Метаданные();
    	СтруктураПараметров = новый Структура();
    	//Заполним структуру реквизитами документа
    	Для каждого Реквизит из МетаданныеДокумента.Реквизиты Цикл
    		СтруктураПараметров.Вставить(Реквизит.Имя, Объект[Реквизит.Имя]);
    	КонецЦикла;
    	
       Если Не ЗначениеЗаполнено(Объект.Организация) Тогда 
          ЗаполнитьСвойствоЗначениемПоУмолчанию("Организация", "ОсновнаяОрганизация", СтруктураПараметров, Истина);
    	  ЗаполнитьЗначенияСвойств(Объект,СтруктураПараметров);
       КонецЕсли;
    КонецПроцедуры

    В модуле формы документа проверяем заполнение одного (!) реквизита дичайше оптимальным образом

    eternium, 25 Октября 2016

    Комментарии (0)
  9. 1C / Говнокод #21547

    +2

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    Документ = Строка(Расшифровка);
    СтрокаОбработанная = СТРЗаменить(Документ, "Заявка ", "");
    ПозицияОт = Найти(СтрокаОбработанная, " от ");
    Номер = СокрЛП(СтрЗаменить((Лев(СтрокаОбработанная, ПозицияОт)), "№", ""));
    Дата = Дата(СокрЛП(СтрЗаменить(Прав(СтрокаОбработанная, СтрДлина(СтрокаОбработанная)-ПозицияОт), "от", "")));
    
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | Заявка.Ссылка
    |ИЗ
    | Документ.Заявка КАК Заявка
    |ГДЕ
    | Заявка.Дата = &Дата
    | И Заявка.Номер = &Номер";
    
    Запрос.УстановитьПараметр("Дата", Дата);
    Запрос.УстановитьПараметр("Номер", Номер);
    
    РезультатЗапроса = Запрос.Выполнить().Выбрать();
    
    Если РезультатЗапроса.Количество() Тогда
    РезультатЗапроса.Следующий();

    Мы уже даже привыкли к запросам с поиском ссылки по наименованию, полученному из уже имеющейся ссылки... Но парсинг представления ссылки документа с вычлененнием оттуда номера и даты, чтоб найти этот документ - это нельзя придумать даже специально.

    elizir, 24 Октября 2016

    Комментарии (0)
  10. 1C / Говнокод #21546

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    ЗапросПоДате = Новый Запрос;
    ЗапросПоДате.Текст = "ВЫБРАТЬ
    	|	МАКСИМУМ(НачислениеБонусов.Дата) КАК Дата
    	|ИЗ
    	|	Документ.НачислениеБонусов КАК НачислениеБонусов
    	|ГДЕ
    	|	НачислениеБонусов.Контрагент = &Контрагент
    	|	И НачислениеБонусов.Дата < &Дата";
    ЗапросПоДате.Параметры.Вставить("Контрагент",ЭтотОбъект.Контрагент);
    ЗапросПоДате.Параметры.Вставить("Дата",ЭтотОбъект.Дата);
    Результат =	ЗапросПодате.Выполнить().Выбрать();
    Если Результат.Следующий() Тогда
    	ДатаПоследнегоНачисления = Результат.Дата;
    Иначе
    	ДатаПоследнегоНачисления = Дата(2000,01,01);
    КонецЕсли;
    Если ДатаПоследнегоНачисления = Null Тогда
    	ДатаПоследнегоНачисления = Дата(2000,01,01);
    КонецЕсли;

    Функции языка запросов???

    Asaharu, 24 Октября 2016

    Комментарии (2)