1. C++ / Говнокод #18209

    +144

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    ...
    GameItem* new_game_item = GetGameItem(id);
    bool flag = !new_game_item;
    if (flag)
    {
        new_game_item = new GameItem();
    }
    ...

    Меня больше всего поразило название локальной переменной new_game_item, которая чаще даже совсем не new. Но кого это волнует...

    pomahin, 20 Мая 2015

    Комментарии (1)
  2. PHP / Говнокод #18208

    +143

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    $find_email = $this->db_users->prepare("SELECT * FROM `users` WHERE `email` = :email");
    $find_email->execute(array(':email' => $user['email']));
    $row = $find_email->fetch(PDO::FETCH_ASSOC);
    if($row['id']) {
      $hash_passw = crypt($user['password'], $row['sault']);
      $auth = $this->db_users->prepare("SELECT * FROM `users` WHERE `email` = :email AND `password` = :hash_passw");
      $auth->execute(array(':email' => $user['email'],
    		                        ':hash_passw' => $hash_passw));
      $_row = $auth->fetch(PDO::FETCH_ASSOC);
      if($_row) {
        $auth_token = '$3a$'.sha1(date(dmY).time().$user['email']).'$';
        $auth = $this->db_users->prepare("UPDATE `users` SET `auth_token`=:auth_token, WHERE `email` = :email");
        $auth->execute(array(':auth_token' => $auth_token,
    		                          ':email' => $user['email']));
        $domain = $_SERVER['HTTP_HOST'];
        setcookie('authToken', $value, time()+3600, '', $domain, 1);	
        setcookie('hash', $value, time()+3600, '', $domain, 1);
        return true;

    Авторизация

    Dev_18, 20 Мая 2015

    Комментарии (0)
  3. PHP / Говнокод #18207

    +144

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    <!--Женская одежда Блузки-->
    				<?if($arResult["IBLOCK_SECTION_ID"] == 487 ):?> 
    				<table class="tproperty">
    	<tr><td class="tdproperty"><?=$arResult["PROPERTIES"]["SOSTAV"]["NAME"];?></td><td><?=$arResult["PROPERTIES"]["SOSTAV"]["VALUE"];?></td></tr>
    	<tr><td class="tdproperty" ><?=$arResult["PROPERTIES"]["TSVET"]["NAME"];?></td><td><?=$arResult["PROPERTIES"]["TSVET"]["VALUE"];?></td></tr>
    	<tr><td class="tdproperty" ><?=$arResult['PROPERTIES']['RAZMER']['NAME'];?></td><td><?=$arResult["PROPERTIES"]["RAZMER"]["VALUE"];?></td></tr>
    	<tr><td class="tdproperty" ><?=$arResult['PROPERTIES']['UPAKOVKA']['NAME'];?></td><td><?=$arResult["PROPERTIES"]["UPAKOVKA"]["VALUE"];?></td></tr>
    	<tr><td class="tdproperty"><?=$arResult['PROPERTIES']['POKROY']['NAME'];?></td><td><?=$arResult["PROPERTIES"]["POKROY"]["VALUE"];?></td></tr>
    	<tr><td class="tdproperty"><?=$arResult['PROPERTIES']['DLINNA_RUKAVA']['NAME'];?></td><td><?=$arResult["PROPERTIES"]["DLINNA_RUKAVA"]["VALUE"];?></td></tr>
    				</table>
    
    <!--Женская одежда Брючные костюмы-->
    				<?elseif($arResult["IBLOCK_SECTION_ID"] == 489 ):?> 
    <table class="tproperty">
    	<tr><td class="tdproperty"><?=$arResult["PROPERTIES"]["SOSTAV"]["NAME"];?></td><td><?=$arResult["PROPERTIES"]["SOSTAV"]["VALUE"];?></td></tr>
    	<tr><td class="tdproperty"><?=$arResult["PROPERTIES"]["TSVET"]["NAME"];?></td><td><?=$arResult["PROPERTIES"]["TSVET"]["VALUE"];?></td></tr>
    	<tr><td class="tdproperty"><?=$arResult['PROPERTIES']['RAZMER']['NAME'];?></td><td><?=$arResult["PROPERTIES"]["RAZMER"]["VALUE"];?></td></tr>
    	<tr><td class="tdproperty"><?=$arResult['PROPERTIES']['UPAKOVKA']['NAME'];?></td><td><?=$arResult["PROPERTIES"]["UPAKOVKA"]["VALUE"];?></td></tr>
    				</table>
    
    <!--Женская одежда Жакеты-->
    <?elseif($arResult["IBLOCK_SECTION_ID"] == 491 ):?> 
    <table class="tproperty" >
    	<tr><td class="tdproperty"><?=$arResult["PROPERTIES"]["SOSTAV"]["NAME"];?></td><td><?=$arResult["PROPERTIES"]["SOSTAV"]["VALUE"];?></td></tr>
    	<tr><td class="tdproperty"><?=$arResult["PROPERTIES"]["TSVET"]["NAME"];?></td><td><?=$arResult["PROPERTIES"]["TSVET"]["VALUE"];?></td></tr>
    	<tr><td class="tdproperty"><?=$arResult['PROPERTIES']['RAZMER']['NAME'];?></td><td><?=$arResult["PROPERTIES"]["RAZMER"]["VALUE"];?></td></tr>
    	<tr><td class="tdproperty"><?=$arResult['PROPERTIES']['UPAKOVKA']['NAME'];?></td><td><?=$arResult["PROPERTIES"]["UPAKOVKA"]["VALUE"];?></td></tr>
    	<tr><td class="tdproperty"><?=$arResult['PROPERTIES']['POKROY']['NAME'];?></td><td><?=$arResult["PROPERTIES"]["POKROY"]["VALUE"];?></td></tr>
    	<tr><td class="tdproperty"><?=$arResult['PROPERTIES']['DLINNA_RUKAVA']['NAME'];?></td><td><?=$arResult["PROPERTIES"]["DLINNA_RUKAVA"]["VALUE"];?></td></tr>
    </table>
    
    
    ........................................

    И так еще 900 строчек.... Как такие люди рождаются вообще? :)

    lscin, 20 Мая 2015

    Комментарии (9)
  4. 1C / Говнокод #18206

    −107

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    47. 47
    48. 48
    49. 49
    50. 50
    51. 51
    52. 52
    53. 53
    54. 54
    Процедура ПокрытияКодПокрытияОкончаниеВводаТекста(Элемент, Текст, Значение, СтандартнаяОбработка)
    Покрытия = ЭтаФорма.Покрытия;
    Количество = 0;
    Для Каждого СтрокаПокрытия из Покрытия Цикл 
    Если СтрокаПокрытия.КодПокрытия = Текст Тогда
    Количество = 1;
    КонецЕсли;
    КонецЦикла;
    
    
    Если Количество > 0 Тогда 
    ПоказатьОповещениеПользователя("Ошибка!",,"Такое покрытие уже присутствует в составе изделия", БиблиотекаКартинок.Ошибка);
    НеНайденоПокрытие = Истина;
    Возврат;
    КонецЕсли;
    
    
    НеНайденоПокрытие = Ложь;
    ЭлементыФормы.Покрытия.ТекущиеДанные.СвязьСПокрытиями = Неопределено;
    
    
    Если ЭлементыФормы.Покрытия.ТекущиеДанные <> Неопределено Тогда
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    | Покрытия.Ссылка,
    | Покрытия.НаименованиеПокрытия
    |ИЗ
    | Документ.Покрытия КАК Покрытия
    |ГДЕ
    | Покрытия.КодПокрытия = &КодПокрытия";
    
    
    Запрос.УстановитьПараметр("КодПокрытия", Текст);
    
    
    Результат = Запрос.Выполнить();
    
    
    ВыборкаДетальныеЗаписи = Результат.Выбрать();
    
    
    Если ВыборкаДетальныеЗаписи.Количество() > 0 Тогда
    ВыборкаДетальныеЗаписи.Следующий();
    ЭлементыФормы.Покрытия.ТекущиеДанные.СвязьСПокрытиями = ВыборкаДетальныеЗаписи.Ссылка;
    ЭлементыФормы.Покрытия.ТекущиеДанные.НаименованиеПокрытия = ВыборкаДетальныеЗаписи.НаименованиеПокрытия;
    Иначе
    ПоказатьОповещениеПользователя("Ошибка!",,"Не найдено введенное покрытие", БиблиотекаКартинок.Ошибка);
    ЭлементыФормы.Покрытия.ТекущиеДанные.СвязьСПокрытиями = Неопределено;
    ЭлементыФормы.Покрытия.ТекущиеДанные.НаименованиеПокрытия = Неопределено;
    НеНайденоПокрытие = Истина;
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры

    Моё творение. =)

    Startwar, 20 Мая 2015

    Комментарии (3)
  5. Objective C / Говнокод #18205

    −405

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    /**
    *\brief isinteger
     *isinteger function will check if the NSString is a number or not
     * \Param    NSSting*
     * \return    true or false
     */
    bool isinteger(NSString* theString)
    {
        int myInt;
        NSScanner *theScanner = [NSScanner scannerWithString:theString];
        if ([theScanner scanInt:&myInt] && [theScanner isAtEnd] )
            return true;
        else
            return false;
    }

    Такой чудо-код встретился в проекте.

    EMax, 20 Мая 2015

    Комментарии (9)
  6. PHP / Говнокод #18204

    +142

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    $act = isset($_REQUEST['act']) ? $_REQUEST['act'] : '';
    	
    	if ($act == 'details') {
    		orders_details();
    	} elseif ($act == 'details_xls') {
    		orders_details_xls();
    	} elseif ($act == 'set_status') {
    		orders_set_status();
    	// ... ещё строчек 30
    	} else {
    		orders_list();
    	}

    Так мы реализуем роутер

    Tairesh, 20 Мая 2015

    Комментарии (5)
  7. PHP / Говнокод #18203

    +140

    1. 1
    http://phpocean.com/tutorials/back-end/create-your-first-desktop-application-with-php-and-php-desktop/4

    верстка самого сайта, phpdesktop, zooboole - у меня жестко бортануло

    Fike, 20 Мая 2015

    Комментарии (17)
  8. C# / Говнокод #18202

    +144

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    string q = DateTime.Now.ToString().Substring(3, 3);
    string w = DateTime.Now.ToString().Substring(0, 2);
    string e = DateTime.Now.ToString().Substring(5, DateTime.Now.ToString().Length - 5);
    string dsasd = q + w + e;
    
    CrmDateTimeProperty _new_date_fitst_update_rstatus = new CrmDateTimeProperty();
    _new_date_fitst_update_rstatus.Name = "new_date_first_update_rstatus";
    _new_date_fitst_update_rstatus.Value = new CrmDateTime();
    _new_date_fitst_update_rstatus.Value.Value = dsasd;
    dynamicEntity.Properties.Add(_new_date_fitst_update_rstatus);

    Попался проект на фрилансе. Попросили исправить ошибки. Начал исправлять и вот такое.

    Shturman, 19 Мая 2015

    Комментарии (0)
  9. PHP / Говнокод #18200

    +142

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    foreach ($id as $k) {
    		//Помним, что меньший id всегда пишется первым
    		if ($firm_id < $k)
    			{ $a = 1; $b = 2; }
    		else
    			{ $a = 2; $b = 1; }
    			if ($_REQUEST['submit'] == 1) {
                                    //  ...
    			}
    			if ($_REQUEST['submit'] > 1) {
    				sql_query("UPDATE partners SET ".$type.$a.$b." = 1, firm{$a}_date = {$NOW} WHERE firm{$a} = $firm_id AND firm{$b} = $k");
                                    //  ...
    			}
    	}
    }

    А Вы знаете что будет если -1 отправить?)

    dimka3210, 19 Мая 2015

    Комментарии (5)
  10. Куча / Говнокод #18199

    +143

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    <div class="line_6" id="item_7" style="width:0px;"></div>
            <div class="line_3" id="item_4" style="width:0px;"></div>
    	<div class="line_2" id="item_3" style="width:0px;"></div>
            <div class="line_5" id="item_6" style="width:0px;"></div>
            <div class="line_4" id="item_5" style="width:0px;"></div>
    	<div class="line_1" id="item_1" style="width:845px; visibility:hidden;"></div>
    	<div class="line_7" id="item_2" style="right:100px; visibility:hidden;"></div>

    Размещение блоков делалось так, а вот когда через JS решили анимировать и вводить id то ...

    stail, 19 Мая 2015

    Комментарии (1)