1. Куча / Говнокод #23390

    +1

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    Make Sean moan
    Worship Carrie's feet
    
    Bind Amy to Saint Andrew's Cross
        Have Amy hogtie Sean
        If Amy is Carrie's bitch
            Make Slave scream Sean's name
            Make Sean moan

    https://github.com/Property404/fetlang

    dxd, 07 Октября 2017

    Комментарии (0)
  2. Java / Говнокод #23389

    +4

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    public TkApp(final Base base) throws IOException {
            super(
                new TkWithHeaders(
                    new TkVersioned(
                        new TkMeasured(
                            new TkFlash(
                                new TkAppFallback(
                                    new TkAppAuth(
                                        new TkForward(
                                            new TkFork(
                                                new FkHost(
                                                    "relay.jare.io",
                                                    new TkFallback(
                                                        new TkRelay(base),
                                                        req -> new Opt.Single<>(
                                                            new RsWithType(
                                                                new RsWithBody(
                                                                    new RsWithStatus(req.code()),
                                                                    new Sprintf(
                                                                        "Please, submit this stacktrace to GitHub and we'll try to help: https://github.com/yegor256/jare/issues\n\n%s",
                                                                        ExceptionUtils.getStackTrace(
                                                                            req.throwable()
                                                                        )
                                                                    )
                                                                ),
                                                                "text/plain"
                                                            )
                                                        )
                                                    )
                                                ),
                                                ...

    Взято отсюда: https://github.com/yegor256/jare/blob/master/src/main/java/io/jare/tk/TkApp.java#L70

    mazoxox, 06 Октября 2017

    Комментарии (5)
  3. C++ / Говнокод #23388

    +4

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    MMappedReader &operator=(MMappedReader &&other) {
        if (this != &other) {
            *this = std::move(other);
        } 
        return *this;
    }

    I like to move it, move it!

    Yuuri, 06 Октября 2017

    Комментарии (13)
  4. Assembler / Говнокод #23387

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    47. 47
    48. 48
    49. 49
    50. 50
    51. 51
    52. 52
    53. 53
    54. 54
    55. 55
    56. 56
    57. 57
    58. 58
    59. 59
    60. 60
    61. 61
    62. 62
    63. 63
    64. 64
    65. 65
    66. 66
    67. 67
    68. 68
    69. 69
    70. 70
    71. 71
    72. 72
    73. 73
    74. 74
    75. 75
    76. 76
    77. 77
    tms часть коррелятора
    
    
    ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
               movl          XAR6     ,#str_korel     ;
               movl          XAR7     ,#str_f1_faz    ;
               mov            AH      ,@@dlin_mass    ;
               dec            AH                      ;
               movb           AL      ,#0             ;
               movl          XAR1     ,ACC            ;
               movz           AR2     ,AH             ;
               mov     @@max_num      ,AL             ;
               mov   @@start_num      ,AR1            ;
               subb          XAR2     ,#1             ;
               mpy           ACC      ,@@index_f      ,#max_f__faz*dln_f__faz
               add           ACC      ,@@start_base   ;
               addl          XAR7     ,ACC            ;
               movb          XAR3     ,#0             ;
               movz           AR0     ,*+XAR6[AR1%++] ;
               mov             T      ,@@temp_R       ;
               movl            P      ,*+XAR7[AR0]    ;pl=alp ph=R
               mpyu          ACC      ,T     ,PH      ;R0
               mov    @@factor_R      ,AH             ;
    loopi_0:   movz           AR0     ,*+XAR6[AR1%++] ;
               mov             T      ,#0             ;
               movl          ACC      ,*+XAR7[AR0]    ;
               sub            AL      ,PL             ;alpa<0
               cmp            AL      ,@@factor_alp   ;
               movb            T      ,#1            ,LO
               sub            AH      ,PH             ;
               abs           ACC                      ;
               cmp            AH      ,@@factor_R     ;
               movb            T      ,#0            ,HI
               mov            AL      ,T              ;
               add     @@max_num      ,AL             ;
               banz       loopi_0     ,AR2--          ;
    ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
               movz           AR2     ,@@dlin_mass    ;
               subb          XAR2     ,#3             ;
    zabul:     movz           AR0     ,*+XAR6[AR1%++] ;
               push           AR3:AR2                 ;
    ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
               mov     @@start_n      ,AR1            ;
               movz           AR0     ,*+XAR6[AR1%++] ;
               mov             T      ,@@temp_R       ;
               movl            P      ,*+XAR7[AR0]    ;
               mpyu          ACC      ,T     ,PH      ;
               mov    @@factor_R      ,AH             ;
               movb       @@max_n     ,#0           ,UNC
    loopi_1:   movz           AR0     ,*+XAR6[AR1%++] ;
               mov             T      ,#0             ;
               movl          ACC      ,*+XAR7[AR0]    ;
               sub            AL      ,PL             ;alpa<0
               cmp            AL      ,@@factor_alp   ;
               movb            T      ,#1            ,LO
               sub            AH      ,PH             ;
               abs           ACC                      ;
               cmp            AH      ,@@factor_R     ;
               movb            T      ,#0            ,HI
               mov             AL     ,T              ;
               add       @@max_n      ,AL
               banz       loopi_1     ,AR2--
    ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
    loopi_2:   movz           AR0     ,*+XAR6[AR1%++] ;
               mov             T      ,#0             ;
               movl          ACC      ,*+XAR7[AR0]    ;
               sub            AL      ,PL             ;alpa<0
               cmp            AL      ,@@factor_alp   ;
               movb            T      ,#1            ,LO
               sub            AH      ,PH             ;
               abs           ACC                      ;
               cmp            AH      ,@@factor_R     ;
               movb            T      ,#0            ,HI
               mov            AL      ,T              ;
               add       @@max_n      ,AL             ;
               banz       loopi_2     ,AR3--          ;
               pop            AR3:AR2                 ;

    maxxx, 06 Октября 2017

    Комментарии (34)
  5. Ruby / Говнокод #23386

    0

    1. 1
    2. 2
    3. 3
    4. 4
    Руби говно на всей Земле
    Руби говно другим во благо
    Не за красивое "спасибо"
    А за хорошее бабло

    inho, 05 Октября 2017

    Комментарии (3)
  6. Куча / Говнокод #23385

    +4

    1. 1
    (\+7|8)\d\d\d\d\d\d\d\d\d\d

    хуита, 05 Октября 2017

    Комментарии (11)
  7. PHP / Говнокод #23384

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    if ("any string" == 0) {
        echo 'php govno';
    } else {
        echo 'php ne govno';
    }

    Баян, как с вложенным тернарным оператором?

    vistefan, 05 Октября 2017

    Комментарии (8)
  8. PHP / Говнокод #23383

    +10

    1. 1
    $output = preg_replace("/[0-9]{2}$/", ".$0", $input);

    На входе строка с числом. На выходе должно быть это число, поделенное на 100. Далее, диалог:

    [И]нтересующийся: А чем плохо просто поделить на сто?
    [Г]овнокодер: У числа могут быть нули впереди .
    [И]: Ну оно же приведется к флоату при делении
    [Г]: php > var_dump(‎‎5435353534/100);
    float(‎‎54353535.34)
    [Г]: php > var_dump(‎‎00005435353534/100);
    float(‎‎7459203.48)
    [Г]: результат должен быть как у первого

    lex, 05 Октября 2017

    Комментарии (74)
  9. 1C / Говнокод #23382

    +2

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    &НаКлиенте
    Процедура ИзменитьПометкуУдаления(Команда)
    	...
    	Если ПУ(ссылкаНаОтчет) = Истина 
    	Тогда
    		текстВопроса = "Снять с """ + ссылкаНаОтчет + """ пометку на удаление?";
    	Иначе 
    		текстВопроса = "Пометить """ + ссылкаНаОтчет + """ на удаление?";
    	КонецЕсли;
    	Если Вопрос(текстВопроса, РежимДиалогаВопрос.ДаНет, 0) = КодВозвратаДиалога.Да
    	Тогда
    		СПУ( ссылкаНаОтчет, Не(ПУ(ссылкаНаОтчет)));                                      	
    	КонецЕсли; 
    	ОбновитьСписок();
    КонецПроцедуры
    
    &НаСервере
    Функция ПУ(ссылка)
    	Возврат ссылка.ПометкаУдаления;
    КонецФункции
    
    &НаСервере
    Процедура СПУ(ссылка, значение)
    	о = Документы.РегламентированныйОтчет.Выбрать();
    	Пока о.Следующий() Цикл 	
    		если о.Ссылка = ссылка тогда
    			оо = о.ПолучитьОбъект();
    			оо.ПометкаУдаления = значение;
    			оо.Записать();
    		КонецЕсли;	
    	КонецЦикла;
    КонецПроцедуры

    Установка пометки на удаление во внешней обработке от одного интегратора. Дважды происходит получение признака пометки удаления из ссылки. Код процедуры СПУ даже комментировать трудно.

    maalssy, 05 Октября 2017

    Комментарии (1)
  10. JavaScript / Говнокод #23381

    +1

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    function xhr(method, url, async, user, password) {
        let r = new XMLHttpRequest();
        r.open(method, url, async, user, password);
        r.timeout = 10;
    }

    Аффтар данной конструкции задаёт типа загадку:
    "Есть у нас обертка над XMLHttpRequest. Отгадайте что может пойти не так?"

    Ссыль: https://pikabu.ru/story/zagadka_po_js_5383775

    ps. Учи стандарты JS фокусник!

    Dg_INC, 04 Октября 2017

    Комментарии (9)