1. 1C / Говнокод #23514

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    ДействующиеПостановления = Новый Структура;
    			ДействующиеПостановления.Вставить("Постановление914",  ДанныеПечати.Дата < ДатаНачалаПримененияПостановления1137);
    			ДействующиеПостановления.Вставить("Постановление1137", НЕ (ДанныеПечати.Дата < ДатаНачалаПримененияПостановления1137));
    			ДействующиеПостановления.Вставить("Постановление1137_625", ВедетсяУчетНДСПоФЗ56(ДанныеПечати.Дата,ДанныеПечати.ДатаИсправления));
    			ДействующиеПостановления.Вставить("Постановление981", ДействуетПостановление981(ДанныеПечати.Дата,ДанныеПечати.ДатаИсправления));
    			
    			ОпцииПечатиСчетаФактуры.Вставить("ДействующиеПостановления", ДействующиеПостановления);
    			
    			Если ДанныеПечати.КорректировочныйСчетФактура Тогда
    				Если ДействующиеПостановления.Постановление981 Тогда
    					Макет = МакетКорр_981;
    					ЕстьПостановление981 = Истина;
    				ИначеЕсли ДействующиеПостановления.Постановление1137_625 Тогда
    					Макет = МакетКорр_625;
    					ЕстьПостановление1137_625 = Истина;
    				Иначе
    					Макет = МакетКорр;
    					ЕстьПостановление1137 = Истина;
    				КонецЕсли;
    			ИначеЕсли ДействующиеПостановления.Постановление914 Тогда
    				Макет = Макет451;
    				ЕстьПостановление914 = Истина;
    			ИначеЕсли ДействующиеПостановления.Постановление981 Тогда
    				Макет = Макет981;
    				ЕстьПостановление981 = Истина;
    			ИначеЕсли ДействующиеПостановления.Постановление1137_625 Тогда
    				Макет = Макет1137_625;
    				ЕстьПостановление1137_625 = Истина;
    			Иначе
    				Макет = Макет1137;
    				ЕстьПостановление1137 = Истина;
    			КонецЕсли;
    			
    			Если (ЕстьПостановление914 И ЕстьПостановление1137) 
    				ИЛИ (ЕстьПостановление914 И ЕстьПостановление981)
    				ИЛИ ((ЕстьПостановление1137 ИЛИ ЕстьПостановление1137_625) И ЕстьПостановление981) Тогда
    				
    				Текст = НСтр("ru = 'Недоступна одновременная печать счетов-фактур, сформированных по разным постановлениям Правительства РФ'");
    				ОбщегоНазначенияКлиентСервер.СообщитьПользователю(
    					Текст,
    					ДанныеПечати.Ссылка);
    				
    				ТабличныйДокумент.Очистить();
    				Прервать;
    				
    			КонецЕсли;

    Типовая УТ 11.3.4.93, ПечатьОбщихФорм, модуль менеджера

    Что проверяют эти "Если"? Не ошибся ли программист?
    Постановление определяется по дате счета-фактуры. Интересно, как можно сформировать счет-фактуру одновременно "по разным постановлениям Правительства РФ"?

    И мало того, что вторая и третья строки всегда дают противоположный результат. Нет, на всякий случай проверим "Если (ЕстьПостановление914 И ЕстьПостановление1137)".
    Интересно также, как после ИначеЕсли ожидали получить сочетание разных "постановлений"? И почему проверяется всего три неправильных сочетания? Надо больше кода!

    Еще понравилась оригинальная идея завести на каждый элемент структуры отдельную переменную, потом присвоить этой переменной то же, что и в структуре, а потом проверить сочетание этих переменных. Надо заметить, что переменные ЕстьПостановлениеYYYY больше нигде не используются.

    romanvk, 10 Ноября 2017

    Комментарии (6)
  2. Куча / Говнокод #23513

    −1

    1. 1
    2. 2
    3. 3
    Знаете что такое GCC?
    Ни за что не угадаете! 
    В описании пояснение

    [quote]
    GCC: продвинутые оптимизации
    Продвинутый режим оптимизации google closure compiler включается опцией –compilation_level ADVANCED_OPTIMIZATIONS.
    [/quote]
    https://learn.javascript.ru/gcc-advanced-optimization

    SemaReal, 10 Ноября 2017

    Комментарии (2)
  3. PHP / Говнокод #23512

    −1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    var varijabl = "<?php
    
                            if (isset($_SERVER['HTTP_REFERER'])) {
                                if ($_SERVER['HTTP_REFERER'] == "http://%hostname%/profile_edit") {
                                    echo "1";
                                } else {
                                    echo "0";
                                }
                            } else {
                                echo "0";
                            } ?>";
                        if (varijabl == 1) {
                            alert("Sucessfuly saved");
                        }

    Зачем?

    vadim-job-hg, 09 Ноября 2017

    Комментарии (2)
  4. Java / Говнокод #23511

    −4

    1. 1
    Итого байт: 205812872340

    Результат прошлого кода! А давайте письками померяемся?

    samopisiets, 09 Ноября 2017

    Комментарии (4)
  5. PHP / Говнокод #23510

    −2

    1. 1
    PHP - самое большое говно которое я встречал. Стив Джобс

    samopisiets, 09 Ноября 2017

    Комментарии (1)
  6. Java / Говнокод #23509

    −2

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    47. 47
    48. 48
    49. 49
    50. 50
    51. 51
    52. 52
    53. 53
    54. 54
    55. 55
    56. 56
    57. 57
    58. 58
    59. 59
    60. 60
    61. 61
    62. 62
    63. 63
    import java.io.*;
    import java.security.*;
    import java.nio.file.*;
    
    class mdsumall
    {
    	static long bytes = 0;
    
      public static void main(String[] args)
      {
        System.out.println("Программа начинает работу...");
        findAndStore cEtc = new findAndStore("/etc");
        Thread etc = new Thread(cEtc);
        findAndStore cUsr = new findAndStore("/usr");
        Thread usr = new Thread(cUsr);
        findAndStore cHome = new findAndStore("/home");
        Thread home = new Thread(cHome);
        etc.start();
        usr.start();
        home.start();
        try {
        	etc.join();
        	usr.join();
        	home.join();
        }
        catch(InterruptedException e) {
          System.out.println("Прерывание основного потока");
        }
        System.out.println("Итого байт: "+bytes);
      }
    }
    
    class findAndStore implements Runnable
    {
    	String name;
    
    	findAndStore(String name)
    	{
    		this.name = name;
    	}
    
    	public void run()
    	{
    		System.out.println("Начат сбор в папке "+name);
    		storeRecursive(name);
    	}
    
    	void storeRecursive(String folder)
    	{
    		File f = new File(folder);
    		File[] list = f.listFiles();
    		for(File item : list) {
    			if(item.isDirectory())
    				storeRecursive(item.getPath());
    			try {
    				mdsumall.bytes += Files.size(item.toPath());
    			}
    			catch(IOException e) {
    				System.out.println(e);
    			}
    		}
    	}
    }

    Зацените пасаны!!! Это реально нагружает процессор до 80 градусов греет

    samopisiets, 09 Ноября 2017

    Комментарии (0)
  7. Java / Говнокод #23508

    −2

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    47. 47
    48. 48
    49. 49
    50. 50
    51. 51
    52. 52
    53. 53
    54. 54
    55. 55
    56. 56
    57. 57
    58. 58
    59. 59
    60. 60
    61. 61
    62. 62
    63. 63
    64. 64
    65. 65
    66. 66
    67. 67
    68. 68
    69. 69
    70. 70
    71. 71
    72. 72
    class MoreThreads
    {
      public static void main(String[] args)
      {
        println("Запуск основного потока");
        
        MyThread mt1 = new MyThread("Child #1");
        MyThread mt2 = new MyThread("Child #2");
        MyThread mt3 = new MyThread("Child #3");
        MyThread mt4 = new MyThread("Child #4");
        MyThread mt5 = new MyThread("Child #5");
        MyThread mt6 = new MyThread("Child #6");
        MyThread mt7 = new MyThread("Child #7");
        MyThread mt8 = new MyThread("Child #8");
        MyThread mt9 = new MyThread("Child #9");
        MyThread mt10 = new MyThread("Child #10");
        MyThread mt11 = new MyThread("Child #11");
        MyThread mt12 = new MyThread("Child #12");
        MyThread mt13 = new MyThread("Child #13");
        MyThread mt14 = new MyThread("Child #14");
        MyThread mt15 = new MyThread("Child #15");
        MyThread mt16 = new MyThread("Child #16");
        MyThread mt17 = new MyThread("Child #17");
        MyThread mt18 = new MyThread("Child #18");
        
        for(int i=0; i<50; i++) {
          print(".");
          try {
            Thread.sleep(100);
          }
          catch(InterruptedException e) {
            println("Прерывание основного потока");
          }
        }
        
        println("Завершение основного потока");
      }
      
      static void print(String text)
      {
        System.out.print(text);
      }
      
      static void println(String text)
      {
        System.out.println(text);
      }
    }
    
    class MyThread extends Thread
    {
      
      MyThread(String name) {
        super(name);
        setName(name);
        start();
      }
      
      public void run() {
        System.out.println(getName()+" - запуск");
        try {
          for(int count=0; count<10; count++) {
            Thread.sleep(400);
            System.out.println("В "+getName()+", счётчик: "+count);
          }
        }
        catch(InterruptedException e) {
          System.out.println(getName()+" прерван");
        }
        System.out.println(getName()+" - завершение");
      }
    }

    samopisiets, 09 Ноября 2017

    Комментарии (0)
  8. Куча / Говнокод #23507

    0

    1. 1

    Stallman, 09 Ноября 2017

    Комментарии (2)
  9. Куча / Говнокод #23506

    +7

    1. 1

    Полиглот и квайн на брейнфаке, питоне и ещё куче языков размером в 0 байт.

    vistefan, 09 Ноября 2017

    Комментарии (9)
  10. Куча / Говнокод #23505

    +1

    1. 1
    Поцаны, шестой уровень вложенности - это ок или говнокод?

    У вас обычно сколько?

    subaru, 08 Ноября 2017

    Комментарии (112)