1. Java / Говнокод #23521

    −4

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    while( (i=xyi.read()) != -1 )
    	    {
    	    	al.add( i+b-e*b*e+b+e-b+e-b+e+e+e+e+b-b-e+b+b-xer*e-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer );
    	    }
    	    for(int n=0; n<al.size(); n++)
    	    	out.println(al.get(n));
    	    out.println("\nА теперь ебашим в обратку...");
    	    Thread.sleep(1000);
    	    int pizdec;
    	    for(int n=0; n<al.size(); n++)
    	    {
    	    	i = al.get(n);
    	    	pizdec = i+xer*e-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-b+e-b+e-b+e+e+e+e+b-b-e+b+b+e*b*e-b;
    	    	out.print((char)pizdec);
    	    }

    пиздец сложный код!
    выдаёт вот что: ◇◓▸○◇◊○◘▎●◔▏□╰╯▆▆▆▆●◔◚▆●▣▖□╰╯▆▆▆▆●◔◚▆◈▣▝ ▝▒▆○▣▟▟▟▒▆◞○◘▣▗▙□╰╯▆▆▆▆▧◘◘◇◟▲●◙◚▢▯◔◚○◍○◘ ▤▆◇◒▆▣▆◔○◝▆▧◘◘◇◟▲●◙◚▢▤▎▏□╰╯▆▆▆▆◝◎●◒○▎▆▎● ▣◞◟●▔◘○◇◊▎▏▏▆▇▣▆▓▗▆▏╰╯▆▆▆▆◡╰╯▆▆▆▆╯◇◒▔◇◊◊ ▎▆●░◈▓○▐◈▐○░◈░○▓◈░○▓◈░○░○░○░○░◈▓◈▓○░◈░◈▓ ◞○◘▐○▓◞○◘▓◞○◘▓◞○◘▓◞○◘▓◞○◘▓◞○◘▓◞○◘▓◞○◘▓◞○ ◘▓◞○◘▓◞○◘▓◞○◘▓◞○◘▓◞○◘▓◞○◘▓◞○◘▆▏□╰╯▆▆▆▆◣╰ ╯▆▆▆▆◌◕◘▎●◔◚▆◔▣▖□▆◔▢◇◒▔◙●◠○▎▏□▆◔░░▏╰╯▆▆▆ ▆╯◕◛◚▔◖◘●◔◚◒◔▎◇◒▔◍○◚▎◔▏▏□╰╯▆▆▆▆◕◛◚▔◖◘●◔◚ ◒◔▎█◂◔⥶▆⦨⦛⦥⦛⦦⦲▆⦛⦗⦖⦮⦞⦢▆⦘▆⦤⦗⦦⦖⦨⦠⦩▔▔▔█▏□╰╯▆ ▆▆▆►◎◘○◇◊▔◙◒○○◖▎▗▖▖▖▏□╰╯▆▆▆▆●◔◚▆◖●◠◊○◉□╰ ╯▆▆▆▆◌◕◘▎●◔◚▆◔▣▖□▆◔▢◇◒▔◙●◠○▎▏□▆◔░░▏╰╯▆▆▆ ▆◡╰╯▆▆▆▆╯●▆▣▆◇◒▔◍○◚▎◔▏□╰╯▆▆▆▆╯◖●◠◊○◉▆▣▆● ░◞○◘▐○▓◞○◘▓◞○◘▓◞○◘▓◞○◘▓◞○◘▓◞○◘▓◞○◘▓◞○◘▓◞ ○◘▓◞○◘▓◞○◘▓◞○◘▓◞○◘▓◞○◘▓◞○◘▓◞○◘▓◈░○▓◈░○▓◈ ░○░○░○░○░◈▓◈▓○░◈░◈░○▐◈▐○▓◈□╰╯▆▆▆▆╯◕◛◚▔◖◘ ●◔◚▎▎◉◎◇◘▏◖●◠◊○◉▏□╰╯▆▆▆▆◣╰╯◣╰╯◉◇◚◉◎▎▯▵▫◞ ◉○◖◚●◕◔▆○▏▆◡╰╯╯◕◛◚▔◖◘●◔◚◒◔▎█⦫⦩⦟▆⦨⦖⦢▆⦥⦡⦖⦘ ⦖⦡▇█▏□╰╯◣╰▆▆◣╰◣╰

    FlowerGay, 13 Ноября 2017

    Комментарии (6)
  2. Java / Говнокод #23520

    −3

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    import static java.lang.System.out;
    import static java.lang.System.in;
    import java.io.*;
    import java.util.*;
    
    class govnoarh
    {
      public static void main(String[] args) throws InterruptedException
      {
        out.println("Начата архивация вашего говна...");
        out.println("Я надеюсь ты пустил данные на поток ввода?");
        try {
    	    InputStreamReader xyi = new InputStreamReader(in);
    	    int i=0;
    	    int b=77, e=999, xer=13;
    	    ArrayList<Integer> al = new ArrayList<>();
    	    while( (i=xyi.read()) != -1 )
    	    {
    	    	al.add( (i+b-((e*b)*e)+(b+e-b+e-b+e+e+e+e+b-b-e+b+b)-(xer*(e-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer))) );
    	    }
    	    for(int n=0; n<al.size(); n++)
    	    	out.println(al.get(n));
    	    out.println("\nА теперь ебашим в обратку...");
    	    Thread.sleep(1000);
    	    int pizdec;
    	    for(int n=0; n<al.size(); n++)
    	    {
    	    	i = al.get(n);
    	    	pizdec = ( i+(xer*(e-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer-xer)) - (b+e-b+e-b+e+e+e+e+b-b-e+b+b) + ((e*b)*e) - b);
    	    	out.print((char)pizdec);
    	    }
    	}
    	catch(IOException e) {
    		out.println("хуй там плавал!");
    	}
      }
    }

    я насрал чутка тут! жиденько бля

    FlowerGay, 13 Ноября 2017

    Комментарии (0)
  3. PHP / Говнокод #23519

    +1

    1. 1
    ideone.com/LfENd1

    Вот мне всегда говорили, что NaN не равен ничему включая себя, но PHP перевернул мой мир

    d_fomenok, 12 Ноября 2017

    Комментарии (13)
  4. bash / Говнокод #23518

    −7

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    #!/bin/bash
    echo Я говно на баш!
    while true; do
    read PS1
    PS2="${PS2} ${PS1} Смищно правда?"
    echo $PS2
    don

    RUSSIAN-PROGRAMMER, 11 Ноября 2017

    Комментарии (6)
  5. Java / Говнокод #23517

    −2

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    StringBuilder data = new StringBuilder();
    	    /*int len = 0;
    	    len = sock.getInputStream().read(recv);
    	    data.setLength(0);
        	data.append(new String(recv, 0, len));
    	    System.out.println("len="+len);*/ // ГАВНОООООО!!!!!
    	    int i;
    	    BufferedInputStream bf = new BufferedInputStream(sock.getInputStream());
    	    while( (i=bf.read()) != -1 ) //заебок!
    	    {
    	    	System.out.print((char)i);
    	    }

    ну а хули блеать

    RUSSIAN-PROGRAMMER, 11 Ноября 2017

    Комментарии (0)
  6. C# / Говнокод #23516

    −1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    public string LastModifiedOnDisplay
     { 
           get 
           {
                if (LastModifiedOn != null)
                    return DateTime.Parse(LastModifiedOn.ToString()).ToShortDateString() + " " + DateTime.Parse(LastModifiedOn.ToString()).ToLongTimeString();
                else
                    return string.Empty;
            }
    }

    Наследие от вроде бы настоящих индусов

    kagetoki, 10 Ноября 2017

    Комментарии (2)
  7. C++ / Говнокод #23515

    0

    1. 1
    https://webhamster.ru/mytetrashare/index/mtb0/1480776952mrczr7xk44

    Какие изменения предлагает инициативная группа стандарта C++!!, чтобы сделать язык C++ красивым, мощным и востребованным средством современной разработки?

    j123123, 10 Ноября 2017

    Комментарии (18)
  8. 1C / Говнокод #23514

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    ДействующиеПостановления = Новый Структура;
    			ДействующиеПостановления.Вставить("Постановление914",  ДанныеПечати.Дата < ДатаНачалаПримененияПостановления1137);
    			ДействующиеПостановления.Вставить("Постановление1137", НЕ (ДанныеПечати.Дата < ДатаНачалаПримененияПостановления1137));
    			ДействующиеПостановления.Вставить("Постановление1137_625", ВедетсяУчетНДСПоФЗ56(ДанныеПечати.Дата,ДанныеПечати.ДатаИсправления));
    			ДействующиеПостановления.Вставить("Постановление981", ДействуетПостановление981(ДанныеПечати.Дата,ДанныеПечати.ДатаИсправления));
    			
    			ОпцииПечатиСчетаФактуры.Вставить("ДействующиеПостановления", ДействующиеПостановления);
    			
    			Если ДанныеПечати.КорректировочныйСчетФактура Тогда
    				Если ДействующиеПостановления.Постановление981 Тогда
    					Макет = МакетКорр_981;
    					ЕстьПостановление981 = Истина;
    				ИначеЕсли ДействующиеПостановления.Постановление1137_625 Тогда
    					Макет = МакетКорр_625;
    					ЕстьПостановление1137_625 = Истина;
    				Иначе
    					Макет = МакетКорр;
    					ЕстьПостановление1137 = Истина;
    				КонецЕсли;
    			ИначеЕсли ДействующиеПостановления.Постановление914 Тогда
    				Макет = Макет451;
    				ЕстьПостановление914 = Истина;
    			ИначеЕсли ДействующиеПостановления.Постановление981 Тогда
    				Макет = Макет981;
    				ЕстьПостановление981 = Истина;
    			ИначеЕсли ДействующиеПостановления.Постановление1137_625 Тогда
    				Макет = Макет1137_625;
    				ЕстьПостановление1137_625 = Истина;
    			Иначе
    				Макет = Макет1137;
    				ЕстьПостановление1137 = Истина;
    			КонецЕсли;
    			
    			Если (ЕстьПостановление914 И ЕстьПостановление1137) 
    				ИЛИ (ЕстьПостановление914 И ЕстьПостановление981)
    				ИЛИ ((ЕстьПостановление1137 ИЛИ ЕстьПостановление1137_625) И ЕстьПостановление981) Тогда
    				
    				Текст = НСтр("ru = 'Недоступна одновременная печать счетов-фактур, сформированных по разным постановлениям Правительства РФ'");
    				ОбщегоНазначенияКлиентСервер.СообщитьПользователю(
    					Текст,
    					ДанныеПечати.Ссылка);
    				
    				ТабличныйДокумент.Очистить();
    				Прервать;
    				
    			КонецЕсли;

    Типовая УТ 11.3.4.93, ПечатьОбщихФорм, модуль менеджера

    Что проверяют эти "Если"? Не ошибся ли программист?
    Постановление определяется по дате счета-фактуры. Интересно, как можно сформировать счет-фактуру одновременно "по разным постановлениям Правительства РФ"?

    И мало того, что вторая и третья строки всегда дают противоположный результат. Нет, на всякий случай проверим "Если (ЕстьПостановление914 И ЕстьПостановление1137)".
    Интересно также, как после ИначеЕсли ожидали получить сочетание разных "постановлений"? И почему проверяется всего три неправильных сочетания? Надо больше кода!

    Еще понравилась оригинальная идея завести на каждый элемент структуры отдельную переменную, потом присвоить этой переменной то же, что и в структуре, а потом проверить сочетание этих переменных. Надо заметить, что переменные ЕстьПостановлениеYYYY больше нигде не используются.

    romanvk, 10 Ноября 2017

    Комментарии (5)
  9. Куча / Говнокод #23513

    −1

    1. 1
    2. 2
    3. 3
    Знаете что такое GCC?
    Ни за что не угадаете! 
    В описании пояснение

    [quote]
    GCC: продвинутые оптимизации
    Продвинутый режим оптимизации google closure compiler включается опцией –compilation_level ADVANCED_OPTIMIZATIONS.
    [/quote]
    https://learn.javascript.ru/gcc-advanced-optimization

    SemaReal, 10 Ноября 2017

    Комментарии (2)
  10. PHP / Говнокод #23512

    −1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    var varijabl = "<?php
    
                            if (isset($_SERVER['HTTP_REFERER'])) {
                                if ($_SERVER['HTTP_REFERER'] == "http://%hostname%/profile_edit") {
                                    echo "1";
                                } else {
                                    echo "0";
                                }
                            } else {
                                echo "0";
                            } ?>";
                        if (varijabl == 1) {
                            alert("Sucessfuly saved");
                        }

    Зачем?

    vadim-job-hg, 09 Ноября 2017

    Комментарии (2)