1. 1C / Говнокод #23606

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    УпрощенныйРежим = ДилерскийЦентр.Автосервис_ИспользуетсяУпрощенныйИнтерфейс;
    
    Если УпрощенныйРежим ТОгда
    		
    		Если ЗначениеЗаполнено(Клиент) Тогда
    			
    			Если ТипЗнч(Клиент) = Тип("СправочникСсылка.Контрагенты") Тогда
    				
    				ТекущийКлиент = Клиент;
    				
    			Иначе
    				
    				ЭлементыФормы.НадписьПредставьтесь.Заголовок = "Клиент представился как: " + Строка(Клиент) + ". Необходимо выбрать клиента";
    				
    			КонецЕсли;
    			
    		КонецЕсли;
    		
    		Если ЗначениеЗаполнено(ТекущийКлиент) Тогда
    		
    			ЗаполнитьДеревоОбращенийКдиента(ТекущийКлиент);
    			
    			ЭлементыФормы.ТекущийКонтрагент.ЦветФонаПоля = Новый Цвет (255, 255, 255);
    			ЭлементыФормы.ТекущийКонтрагент.КнопкаОткрытия = Истина;
    			
    			ОбновитьТелефонИEmail(ТекущийКлиент);
    			
    			Если НЕ ЗначениеЗаполнено(ТекущийАвтомобиль) Тогда
    				
    				ЗаполнитьВыборАвто();
    				
    			КонецЕсли;
    			
    		КонецЕсли;
    		
    	КонецЕсли;

    У формы существует реквизит ТекущийКлиент.
    При открытии выполняться вот этот вот шедевр.
    При сохрани обратно Клиент = ТекущийКлиент;.
    И еще если не Упрощенный режим интерфейса то даже у старых документов контрагент будет не выбран.

    NioGoth, 21 Декабря 2017

    Комментарии (1)
  2. PHP / Говнокод #23605

    −1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    function convert_data($data,$fromTo="MQL")
    {
      if($fromTo=='MQL') {
        $P=explode("-",$data);
        return $P[2].".".$P[1].".".$P[0];
      } else {
        $P=explode(".",$data);
        return $P[2]."-".$P[1]."-".$P[0];
      }
    }

    Подготавливаем дату для сохранения в базу

    SeniorShaurman, 21 Декабря 2017

    Комментарии (10)
  3. C++ / Говнокод #23604

    +7

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    constexpr auto auto​()
    {
      return 1;
    }
    
    typedef decltype(auto​()) auto​​;
    const auto​​ auto​​​ = auto​();
    
    template <typename auto​​​​>
    constexpr auto auto​​​​​() {
        return auto​​​;
    }
    
    template <typename auto​​​​, typename auto​​​​​​, typename... auto​​​​​​​>
    constexpr auto auto​​​​​() {
        return auto​​​ + auto​​​​​<auto​​​​​​, auto​​​​​​​...>();
    }
    
    int main()
    {
      constexpr auto auto​​​​​​​ = auto​​​​​<auto​​,auto​​,auto​​,auto​​,auto​​,auto​​>();
      constexpr auto auto​​​​ = auto​​​​​<auto​​,auto​​,auto​​,auto​​,auto​​,auto​​,auto​​>();
      return auto​​​​​​​*auto​​​​; 
    }

    auto auto auto...
    https://twitter.com/RichardKogelnig/status/943497972481953792
    https://godbolt.org/g/Yvczo1

    Soul_re@ver, 20 Декабря 2017

    Комментарии (43)
  4. PHP / Говнокод #23603

    +1

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    public static function getInstance($model, $attribute)
        {
            //$name = Html::getInputName($model, $attribute); заменил просто на attribute, чтобы работать без Active::Form и т.д.
            $name = $attribute;
            return static::getInstanceByName($name);
        }

    Yii2 - найдено в непосредственно файлах фреймворка

    P.S. getInstanceByName - публичный метод

    Hvreg, 20 Декабря 2017

    Комментарии (1)
  5. PHP / Говнокод #23602

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    public function isSubscribed($subscription_id=0) {
    		if(intval($subscription_id)==0) {
    			return false;
    		}
    		$sql = 'SELECT `subscription_id` FROM `'.DB_PREFIX.'customer_subscriptions` 
    				WHERE `subscription_id` = "'.intval($subscription_id).'" AND `customer_id` = "'.intval($this->customer->getId()).'";';
    		$result = $this->db->query($sql);
    
    		if(!$result || $result->num_rows==Null) {
    			return false;
    		} else {
    			return true;
    		}
    	}

    В этом коде великолепно все

    den_rad, 20 Декабря 2017

    Комментарии (5)
  6. JavaScript / Говнокод #23601

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    if (!App.detection.browser_mobile && !App.detection.browser_tablet) {
      $('.hint', service_list_element)
      .on('mouseover', function() {
    
        var item = $(this),
        text = $('.text', item).text();
    
        if (text !== '' && !tooltip.visible) {
          tooltip.setTarget(item);
    
          tooltip.setData({
            'content' : text
          });
    
          tooltip.show();
        }
      })
      .on('mouseleave', function() {
        if (tooltip.visible) {
          tooltip.hide();
        }
      });
    }
    else {
      $('.hint', service_list_element)
      .on('pep_tap', function() {
        var item = $(this),
        text = $('.text', item).text();
    
        if (text !== '' && !tooltip.visible) {
          tooltip.setTarget(item);
    
          tooltip.setData({
            'content' : text
          });
    
          tooltip.show();
        }
      });
    }

    Если это десктоп, то при клике на иконку всплывает подсказка, но если это мобильник или планшет, то копипастим код с той же логикой, только с другим событием, которое эмулирует клик.

    Кажется парню платили за количество строк в коде =/

    MrFranke, 19 Декабря 2017

    Комментарии (1)
  7. Куча / Говнокод #23600

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    "Не имеет будущего": сооснователь Bitcoin.com продал все свои биткоины
    
    https://ria.ru/economy/20171219/1511236422.html
    
    Красава: когда-то накрутил себе фантиков, а теперь, когда почувствовал запах ануса, сбыл их за реальное бабло.

    COWuTEJIbTBOEuMAMKu, 19 Декабря 2017

    Комментарии (2)
  8. Java / Говнокод #23599

    +2

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    public class RussianNumberUtils {
    
        public static String getRussianNumberFormat(String number) {
    
            StringBuilder numberBuilder = new StringBuilder();
    
            try {
                numberBuilder.append("+");
                numberBuilder.append(number.charAt(0));
                numberBuilder.append(" (");
                numberBuilder.append(number.substring(1, 4));
                numberBuilder.append(") ");
                numberBuilder.append(number.substring(4, 7));
                numberBuilder.append("-");
                numberBuilder.append(number.substring(7, 9));
                numberBuilder.append("-");
                numberBuilder.append(number.substring(9, Math.max(number.length(), 11)));
    
                return numberBuilder.toString();
            } catch (Exception e) {}
    
            return number;
        }
    }

    Форматирование русского номера телефона

    lukaville, 19 Декабря 2017

    Комментарии (13)
  9. Python / Говнокод #23598

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    import re
    
    alphabet = ['a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm',
                'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z']
    text = input('Enter your message: ')
    text = re.findall(r'\w', text)
    
    key = input('Enter your key: ')
    key = int(key)
    a = len(text)
    b = 0
    num = 0
    message = []
    c = ''
    
    for i in range(a):
        num = alphabet.index(text[b])
        num = num + key
        b = b + 1
        if num <= 25:
            message.append(alphabet[num])
        else:
            num = num%25 - 1
            message.append(alphabet[num])
           
    print(text)
    print(message)
    for i in range(a):
        c += message[(i)]
    print(c)

    Шифр Цезаря

    Alex1982, 19 Декабря 2017

    Комментарии (0)
  10. Куча / Говнокод #23597

    −4

    1. 1
    Сайт пора закрывать. Клуб мастурбирующих друг на друга долбоёбов изжил себя.

    COWuTEJIbTBOEuMAMKu, 18 Декабря 2017

    Комментарии (2)