1. PHP / Говнокод #23612

    +1

    1. 1
    $data->setReferrerCode($data->getReferrerCode());

    antosha, 22 Декабря 2017

    Комментарии (5)
  2. C# / Говнокод #23611

    −1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    47. 47
    48. 48
    49. 49
    50. 50
    51. 51
    52. 52
    53. 53
    54. 54
    55. 55
    56. 56
    57. 57
    58. 58
    59. 59
    60. 60
    61. 61
    62. 62
    63. 63
    64. 64
    65. 65
    66. 66
    67. 67
    68. 68
    private void button1_Click(object sender, EventArgs e)
            {
    textBox3.Clear();
    textBox4.Clear();
    
    Stringstr = textBox2.Text;
    String code = textBox1.Text;
    
    int size = str.Length;
    char[] s = newchar[size];
    
    if (size == 0) { textBox4.Text = "Ошибка! Вы не ввели исходный текст для шифрования."; return; }
    
    intsize C = code.Length;
    char[] sC = new char[sizeC];
    
    if (sizeC == 0) { textBox4.Text = "Ошибка! Вы не ввели ключевое слово."; return; }
    
    int[] secret = new int[sizeC];
    int[] string1 = new int[size];
    
    for (inti = 0; i< size; i++)
    s[i] = str[i];
    
    for (inti = 0; i<sizeC; i++)
    sC[i] = code[i];
    
    int j = 0;
    
    for (inti = 0; i<sizeC; i++)
                {
                    j = 0;
    while (j != kolAl)
                    {
    if (sC[i] == Al[j]) { secret[i] = j + 1; break; }
    j++;
                    }
                }
    
    for (inti = 0; i< size; i++)
                {
                    j = 0;
    while (j != kolAl)
                    {
    if (s[i] == Al[j]) { string1[i] = j; break; }
    j++;
                    }
                }
    
    char[] finish = newchar[size];
    int x = 0;
    
    for (inti = 0; i< size; i++)
                {
    if (Al.Length<= string1[i] + secret[x])
                    {
    finish[i] = Al[string1[i] + secret[x] - Al.Length];
                    }
    else { finish[i] = Al[string1[i] + secret[x]]; }
    
    x++;
    
    if (x == secret.Length) x = 0;
    
                    textBox3.Text += finish[i];
                }
                textBox4.Text = "Шифрованиезавершеноудачно!";
            }

    Одногрупница сделала Шифр Вижинера
    https://ru.wikipedia.org/wiki/Шифр_Виженера
    Беда в том, что код тоже представляет из себя шифр.
    Сделал сам, получилось 4 строчки на зашифровку и 4 на расшифровку.
    Я в шоке. Это отличница у нас (4 курс :) *:(*)
    Ладно, это говнище еще можно понять и простить, только там расшифровка функция еще 200 строк, а так же шифровка и расшифровка файла, соответственно по 300 строк. Так и живем.
    Я в академ отпуск.

    GovnoIzJopy, 22 Декабря 2017

    Комментарии (4)
  3. Java / Говнокод #23609

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    47. 47
    48. 48
    49. 49
    50. 50
    51. 51
    52. 52
    53. 53
    54. 54
    55. 55
    56. 56
    57. 57
    58. 58
    59. 59
    60. 60
    61. 61
    62. 62
    63. 63
    64. 64
    65. 65
    66. 66
    67. 67
    68. 68
    69. 69
    import javax.swing.*;
    import javax.swing.event.ListSelectionEvent;
    import javax.swing.event.ListSelectionListener;
    import java.awt.*;
    import java.awt.event.*;
    
    
    public class Experiment5 implements ActionListener{
        JFrame frame;
        JList list;
        JTextField text;
        public static void main(String[] args) {
            Experiment5 experiment5 = new Experiment5();
            experiment5.go();
        }
    
        public void go(){
            frame = new JFrame();
            frame.setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE);
    
            JPanel panel = new JPanel();
    
            JButton button = new JButton("Click me");
            button.addActionListener(this);
    
            text = new JTextField();
    
            String[] listEntries = {"Java", "C++", "Perl", "Python", "JavaScript", "PHP", "C#"};
            list = new JList(listEntries);
            list.setSelectionMode(ListSelectionModel.SINGLE_SELECTION);
            list.addListSelectionListener(new SelectionOne());
    
            MyDrawPanel1 panel1 = new MyDrawPanel1();
    
            frame.getContentPane().add(BorderLayout.SOUTH, button);
            frame.getContentPane().add(BorderLayout.NORTH, text);
            frame.getContentPane().add(BorderLayout.EAST, list);
            frame.getContentPane().add(BorderLayout.CENTER, panel1);
            frame.setSize(500, 300);
            frame.setVisible(true);
        }
    
        public void actionPerformed(ActionEvent event){
            int ran = (int) (Math.random() * 255);
            text.setText("New random - " + ran);
            frame.repaint();
        }
    
        class SelectionOne implements ListSelectionListener {
            public void valueChanged(ListSelectionEvent lse) {
                if(!lse.getValueIsAdjusting()){
                    String selection = (String) list.getSelectedValue();
                    System.out.println(selection);
                }
            }
        }
    }
    class MyDrawPanel1 extends JPanel{
        public void paintComponent(Graphics g){
    
            int one = (int)(Math.random() * 255);
            int two = (int)(Math.random() * 255);
            int three = (int)(Math.random() * 255);
    
            Color color = new Color(one, two, three);
            g.setColor(color);
            g.fillOval(110, 10, 200, 200);
        }
    }

    SWING!!! Jlist, JTextField, JPanel !!! КАК УЛУЧШИТЬ ЭТОТ ПОНОС???

    babushkaAntona, 21 Декабря 2017

    Комментарии (2)
  4. JavaScript / Говнокод #23608

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    47. 47
    48. 48
    49. 49
    50. 50
    51. 51
    52. 52
    53. 53
    54. 54
    55. 55
    56. 56
    57. 57
    58. 58
    59. 59
    60. 60
    61. 61
    62. 62
    switch (true) {
                        case puid.TrafIntensityCoefficient>=0 && puid.TrafIntensityCoefficient<0.05:
                            value = "000";
                            break;
                        case puid.TrafIntensityCoefficient>=0.05 && puid.TrafIntensityCoefficient<0.1:
                            value = "005";
                            break;
                        case puid.TrafIntensityCoefficient>=0.1 && puid.TrafIntensityCoefficient<0.15:
                            value = "010";
                            break;
                        case puid.TrafIntensityCoefficient>=0.15 && puid.TrafIntensityCoefficient<0.2:
                            value = "015";
                            break;
                        case puid.TrafIntensityCoefficient>=0.2 && puid.TrafIntensityCoefficient<0.25:
                            value = "020";
                            break;
                        case puid.TrafIntensityCoefficient>=0.25 && puid.TrafIntensityCoefficient<0.3:
                            value = "025";
                            break;
                        case puid.TrafIntensityCoefficient>=0.3 && puid.TrafIntensityCoefficient<0.35:
                            value = "030";
                            break;
                        case puid.TrafIntensityCoefficient>=0.35 && puid.TrafIntensityCoefficient<0.4:
                            value = "035";
                            break;
                        case puid.TrafIntensityCoefficient>=0.4 && puid.TrafIntensityCoefficient<0.45:
                            value = "040";
                            break;
                        case puid.TrafIntensityCoefficient>=0.45 && puid.TrafIntensityCoefficient<0.5:
                            value = "045";
                            break;
                        case puid.TrafIntensityCoefficient>=0.5 && puid.TrafIntensityCoefficient<0.55:
                            value = "050";
                            break;
                        case puid.TrafIntensityCoefficient>=0.55 && puid.TrafIntensityCoefficient<0.6:
                            value = "055";
                            break;
                        case puid.TrafIntensityCoefficient>=0.6 && puid.TrafIntensityCoefficient<0.65:
                            value = "060";
                            break;
                        case puid.TrafIntensityCoefficient>=0.65 && puid.TrafIntensityCoefficient<0.7:
                            value = "065";
                            break;
                        case puid.TrafIntensityCoefficient>=0.7 && puid.TrafIntensityCoefficient<0.75:
                            value = "070";
                            break;
                        case puid.TrafIntensityCoefficient>=0.75 && puid.TrafIntensityCoefficient<0.8:
                            value = "075";
                            break;
                        case puid.TrafIntensityCoefficient>=0.8 && puid.TrafIntensityCoefficient<0.85:
                            value = "080";
                            break;
                        case puid.TrafIntensityCoefficient>=0.85 && puid.TrafIntensityCoefficient<0.9:
                            value = "085";
                            break;
                        case puid.TrafIntensityCoefficient>=0.9 && puid.TrafIntensityCoefficient<0.95:
                            value = "090";
                            break;
                        case puid.TrafIntensityCoefficient>=0.95:
                            value = "100";
                            break;
                    }

    ivli, 21 Декабря 2017

    Комментарии (1)
  5. PHP / Говнокод #23607

    0

    1. 1
    2. 2
    3. 3
    4. 4
    <?foreach($Result_zay_complex as $k=>$v) {?>
    
    	<td><?=($Result_zena[$k]['zena']*100)/100;?></td>
    <?}?>

    Тайп кастинг как по учебнику

    SeniorShaurman, 21 Декабря 2017

    Комментарии (1)
  6. 1C / Говнокод #23606

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    УпрощенныйРежим = ДилерскийЦентр.Автосервис_ИспользуетсяУпрощенныйИнтерфейс;
    
    Если УпрощенныйРежим ТОгда
    		
    		Если ЗначениеЗаполнено(Клиент) Тогда
    			
    			Если ТипЗнч(Клиент) = Тип("СправочникСсылка.Контрагенты") Тогда
    				
    				ТекущийКлиент = Клиент;
    				
    			Иначе
    				
    				ЭлементыФормы.НадписьПредставьтесь.Заголовок = "Клиент представился как: " + Строка(Клиент) + ". Необходимо выбрать клиента";
    				
    			КонецЕсли;
    			
    		КонецЕсли;
    		
    		Если ЗначениеЗаполнено(ТекущийКлиент) Тогда
    		
    			ЗаполнитьДеревоОбращенийКдиента(ТекущийКлиент);
    			
    			ЭлементыФормы.ТекущийКонтрагент.ЦветФонаПоля = Новый Цвет (255, 255, 255);
    			ЭлементыФормы.ТекущийКонтрагент.КнопкаОткрытия = Истина;
    			
    			ОбновитьТелефонИEmail(ТекущийКлиент);
    			
    			Если НЕ ЗначениеЗаполнено(ТекущийАвтомобиль) Тогда
    				
    				ЗаполнитьВыборАвто();
    				
    			КонецЕсли;
    			
    		КонецЕсли;
    		
    	КонецЕсли;

    У формы существует реквизит ТекущийКлиент.
    При открытии выполняться вот этот вот шедевр.
    При сохрани обратно Клиент = ТекущийКлиент;.
    И еще если не Упрощенный режим интерфейса то даже у старых документов контрагент будет не выбран.

    NioGoth, 21 Декабря 2017

    Комментарии (1)
  7. PHP / Говнокод #23605

    −1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    function convert_data($data,$fromTo="MQL")
    {
      if($fromTo=='MQL') {
        $P=explode("-",$data);
        return $P[2].".".$P[1].".".$P[0];
      } else {
        $P=explode(".",$data);
        return $P[2]."-".$P[1]."-".$P[0];
      }
    }

    Подготавливаем дату для сохранения в базу

    SeniorShaurman, 21 Декабря 2017

    Комментарии (10)
  8. C++ / Говнокод #23604

    +7

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    constexpr auto auto​()
    {
      return 1;
    }
    
    typedef decltype(auto​()) auto​​;
    const auto​​ auto​​​ = auto​();
    
    template <typename auto​​​​>
    constexpr auto auto​​​​​() {
        return auto​​​;
    }
    
    template <typename auto​​​​, typename auto​​​​​​, typename... auto​​​​​​​>
    constexpr auto auto​​​​​() {
        return auto​​​ + auto​​​​​<auto​​​​​​, auto​​​​​​​...>();
    }
    
    int main()
    {
      constexpr auto auto​​​​​​​ = auto​​​​​<auto​​,auto​​,auto​​,auto​​,auto​​,auto​​>();
      constexpr auto auto​​​​ = auto​​​​​<auto​​,auto​​,auto​​,auto​​,auto​​,auto​​,auto​​>();
      return auto​​​​​​​*auto​​​​; 
    }

    auto auto auto...
    https://twitter.com/RichardKogelnig/status/943497972481953792
    https://godbolt.org/g/Yvczo1

    [email protected], 20 Декабря 2017

    Комментарии (43)
  9. PHP / Говнокод #23603

    +1

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    public static function getInstance($model, $attribute)
        {
            //$name = Html::getInputName($model, $attribute); заменил просто на attribute, чтобы работать без Active::Form и т.д.
            $name = $attribute;
            return static::getInstanceByName($name);
        }

    Yii2 - найдено в непосредственно файлах фреймворка

    P.S. getInstanceByName - публичный метод

    Hvreg, 20 Декабря 2017

    Комментарии (1)
  10. PHP / Говнокод #23602

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    public function isSubscribed($subscription_id=0) {
    		if(intval($subscription_id)==0) {
    			return false;
    		}
    		$sql = 'SELECT `subscription_id` FROM `'.DB_PREFIX.'customer_subscriptions` 
    				WHERE `subscription_id` = "'.intval($subscription_id).'" AND `customer_id` = "'.intval($this->customer->getId()).'";';
    		$result = $this->db->query($sql);
    
    		if(!$result || $result->num_rows==Null) {
    			return false;
    		} else {
    			return true;
    		}
    	}

    В этом коде великолепно все

    den_rad, 20 Декабря 2017

    Комментарии (5)