1. Python / Говнокод #25324

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    ( '''' )
    ( 3 ) : 'HELLO-FORTH  ." Hello, Forth!" BEGIN REFILL 0= UNTIL ; 'HELLO-FORTH
    echo 'Hello, J!'
    print =: ]
    NB.''')
    print('Hello, Python!')

    1. Forth
    2. J
    3. Python1
    4. Python2
    5. Python3

    Rooster, 24 Января 2019

    Комментарии (11)
  2. Haskell / Говнокод #25323

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    doit({txs, [Tx]}) ->
        X = tx_pool_feeder:absorb(Tx),
        Y = case X of
    	    ok -> hash:doit(testnet_sign:data(Tx));
    	    _ -> <<"error">>
    		     end,
        {ok, Y};

    Прекраснейший код на Erlang из великолепнейшей криптовалюты AMOVEO
    Здесь мы видим эндпоинт для отправки транзакций в сеть, возвращающий в случае ошибки ["ok","ZXJyb3I="]
    Приглядевшись можно увидеть закодированное в base64 слово «error»

    silvesterdrago, 24 Января 2019

    Комментарии (58)
  3. 1C / Говнокод #25322

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    // Проверим необходимость проведения авторизаций безналичных платежей
    	АвторизацийБПЕсть = НЕ (НетОплатПлатежнойКартой()
    	Если АвторизацийБПЕсть Тогда
    		// Выполняем авторизации безналичных платежей
    		Если НЕ ВыполнитьАвторизациюБП() Тогда
    .....
    
    
    
    Функция НетОплатПлатежнойКартой()
    
    	НетОплатПлатежнойКартой = Истина;
    	Для Каждого СтрокаОплаты Из Оплаты Цикл
    		Если СтрокаОплаты.ТипОплаты.Объект = Перечисления.ТипыОплатыВРознице.Безналичные Тогда
    			НетОплатПлатежнойКартой = Ложь;
    			Прервать;
    		КонецЕсли;
    	КонецЦикла;
    
    	Возврат НетОплатПлатежнойКартой;
    
    КонецФункции

    Нужно больше инверсий!

    Jtsuken, 23 Января 2019

    Комментарии (5)
  4. PHP / Говнокод #25321

    0

    1. 1
    2. 2
    3. 3
    $loc = "^.+\.(jpg|jpeg|gif|png|svg|js|css|mp3|ogg|mpe?g|avi|zip|gz|bz2?|rar|swf)$";
    $extensions = explode("|",explode(")",explode("(",$loc)[1])[0]);
    $extensions = preg_match("/\((.*)\)/",$loc);

    What's better?

    TAW, 22 Января 2019

    Комментарии (45)
  5. C# / Говнокод #25320

    +5

    1. 1
    2. 2
    Yandere Simulator
    https://f0ck.me/b/09d3f680.mp4

    j123123, 22 Января 2019

    Комментарии (14)
  6. C++ / Говнокод #25319

    +3

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    // https://www.tutorialspoint.com/Read-a-character-from-standard-input-without-waiting-for-a-newline-in-Cplusplus
    
    
    
    // A portable solution doesn't exist for doing this. On windows, you can use the getch() function from the conio(Console I/O) library to get characters pressed. For example,
    
    #include<iostream>
    #include<conio.h>
    using namespace std;
    int main() {
        char c;
        while(1){ // infinite loop
            c = getch();
            cout << c;
        }
    }
    
    // This will output whatever character you input to the terminal. Note that this will only work on windows as the conio library exists only on windows. On UNIX, you can achieve this by entering in system raw mode. For example,
    
    #include<iostream>
    #include<stdio.h>
    int main() {
        char c;
       // Set the terminal to raw mode
        system("stty raw");
        while(1) {
            c = getchar(); 
            // terminate when "." is pressed
            if(c == '.') {
                system("stty cooked");
                exit(0);
            }  
            std::cout << c << " was pressed."<< std::endl;
        }
    }

    Вариант под UNIX еще и очень секурный, ЕВПОЧЯ

    j123123, 22 Января 2019

    Комментарии (39)
  7. PHP / Говнокод #25318

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    public static function copyImage($params)
    {
    ...
            if (!UploadImage::getOrder($barcode, $num)) {
                $num++;
                return self::copyImage($filename, $code, $ext, $sync, $user_id, $num); //тут ебаная рекурсия
            }
    ...
        public static function getOrder($barcode, $num = 0)
        {
            if (Images::findOne(['order' => $num, 'barcode' => $barcode])){
                return false;
            }
            return true;
        }
    
    вся эта рекурсия вместо простого...
    
        public static function getOrder($barcode, $num = 0)
        {
            if (Images::findOne(['order' => $num, 'barcode' => $barcode])){
                self::getOrder($barcode, $num + 1);
            }
            return $num;
        }

    просто убейте меня...

    dasauser, 21 Января 2019

    Комментарии (15)
  8. JavaScript / Говнокод #25317

    +2

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    (function(_){
    _.mixin({makeCarouselWidget: function (container, el, width, height, tmpl) {
        var list_of_rows = _(container).groupBy(function(e, index){
            return Math.floor(index / (width * height));
        });                                             // transform collection to list by 'num_of_cols' chunks
        _(list_of_rows).each(function(row){
            var list_of_chunks = _(row).groupBy(function(e, index){
                return Math.floor(index/width);
            });
            var li = $('<li>').appendTo(el);
            _.each(list_of_chunks, function(chunk){
                var r = $('<div>').attr('class','row fooitem')
                    .attr('style', "margin-right:50px;").appendTo(li);
                _.each(chunk, function(item){
                    r.append(
                        tmpl.render(item)
                    );
                });
            })
        });                                             // each list_of_rows
    }});
    })(_);

    Я хочу быть кочегаром, кочегаром, кочегаром.
    Работать сутки-через-трое, через-трое, через-трое...

    gueest8, 20 Января 2019

    Комментарии (20)
  9. Python / Говнокод #25316

    +2

    1. 1
    print(__import__('pickle').loads(b'c__builtin__\ngetattr\n(c__builtin__\nlist\n(c__builtin__\nmap\n(c__builtin__\neval\n(S\'(lambda x:(lambda y:[x.__setitem__(0,(x[0]+2)**0.5),x.__setitem__(1,x[1]*x[0]/2),2/x[1]][2]))\'\ntR((I0\nI1\nltRc__builtin__\nxrange\n(I27\ntRtRtRS\'__getitem__\'\ntR(I-1\ntR.'))

    https://wandbox.org/permlink/sdhWOEIBVq3iiDgF

    j1392184, 18 Января 2019

    Комментарии (12)
  10. C++ / Говнокод #25315

    +1

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    HRESULT SomeClass::GetVersion(std::wstring& version)
    {
        CComBSTR versionBstr;
        m_Interface->get_Version(&versionBstr);
        version = std::move(std::wstring((_bstr_t)versionBstr, versionBstr.Length()));
        return S_OK;
    }

    Как показать в одном методе (не)знание move семантики, правил приведения типов и COM фреймворка

    salamon_style, 18 Января 2019

    Комментарии (42)