1. 1C / Говнокод #19554

    +3

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    tmpDt = ДобавитьМесяц(СсылкаНаОбъект.Дата, -3);
    Если Месяц(СсылкаНаОбъект.Дата)<4 Тогда
    	txt = "Д.в. "+Месяц(tmpDt)+"/"+Год(tmpDt)+"-"+ "0"+Месяц(СсылкаНаОбъект.Дата)+"/"+Формат(Год(СсылкаНаОбъект.Дата),"ЧГ=0");
    Иначе
    	Если Месяц(СсылкаНаОбъект.Дата)<10 Тогда
    		txt="Д.в. "+"0"+Месяц(tmpDt)+"-"+"0"+Месяц(СсылкаНаОбъект.Дата)+"/"+Формат(Год(СсылкаНаОбъект.Дата),"ЧГ=0");
    	Иначе    
    		txt="Д.в. "+"0"+Месяц(tmpDt)+"-"+Месяц(СсылкаНаОбъект.Дата)+"/"+Формат(Год(СсылкаНаОбъект.Дата),"ЧГ=0");
    	КонецЕсли;
    КонецЕсли;

    Неумение пользоваться форматной строкой приводит к перлам наподобие "если месяц меньше 10, то добавить к месяцу нолик слева".
    Это не считая разборки в числа и сборки назад в строку.

    WildSery, 01 Марта 2016

    Комментарии (1)
  2. 1C / Говнокод #19527

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    Процедура ОсновныеДействияФормыПароль(Кнопка)
    	Если ЭтотОбъект.Пароль = "база7" Тогда
    		ЭлементыФормы.РедактированиеСклада.Доступность = Истина;
    		ЭтотОбъект.Пароль = "";
    		Сообщить("Вы можете изменить галку 'Редактирование склада'");
    	ИначеЕсли ЭтотОбъект.Пароль = "разрешение" Тогда
    		ЭлементыФормы.ПривелигированныйПользователь.Доступность = Истина;
    		ЭтотОбъект.Пароль = "";
    		Сообщить("Вы можете изменить галку 'Привелигированный пользователь'");
    	Иначе
    		Сообщить("Вы ввели неверный пароль");
    	КонецЕсли;
    
    КонецПроцедуры

    Реализация ограничения прав на установку прав для пользователей ИБ.

    CMblCL, 25 Февраля 2016

    Комментарии (8)
  3. 1C / Говнокод #19520

    +4

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    Запас=0; ВПутиУжеЗаказано=0;Остаток=0;Резерв=0;
    	
    	Для Каждого ВыбСклад из СписокСкладов Цикл
    		Скл=Справочники.Склады.НайтиПоНаименованию(СокрЛП(ВыбСклад.Ссылка.Наименование));
    		СтруктураОтбора = Новый Структура(); // для отбора остатков взаиморасчетов
    		СтруктураОтбора.Вставить("Номенклатура", Номенклатура);
    		СтруктураОтбора.Вставить("Склад", Скл);
    		Остаток =Остаток+ РегистрыНакопления.ТоварыНаСкладах.Остатки(КонецДня(КонДата),
    		СтруктураОтбора,"Номенклатура,Склад","Количество").Итог("Количество");
    		Резерв = Резерв+РегистрыНакопления.ТоварыВРезервеНаСкладах.Остатки(КонецДня(КонДата),
    		СтруктураОтбора,"Номенклатура,Склад","Количество").Итог("Количество");
    	КонецЦикла;
    		
    	СтрокаЗапаса=СокрЛП(Остаток);
    	СтрокаЗапаса=СтрЗаменить(СтрокаЗапаса," ","");
    	Запас=?(СтрокаЗапаса="",0,Число(СтрокаЗапаса));

    Лихие манипуляции со стоками. Следите за руками!

    saturn5, 24 Февраля 2016

    Комментарии (4)
  4. 1C / Говнокод #19519

    +5

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    47. 47
    48. 48
    49. 49
    50. 50
    51. 51
    52. 52
    53. 53
    54. 54
    55. 55
    56. 56
    57. 57
    58. 58
    59. 59
    60. 60
    61. 61
    62. 62
    63. 63
    64. 64
    65. 65
    66. 66
    67. 67
    68. 68
    69. 69
    70. 70
    71. 71
    72. 72
    73. 73
    74. 74
    75. 75
    76. 76
    77. 77
    78. 78
    79. 79
    80. 80
    81. 81
    82. 82
    83. 83
    84. 84
    85. 85
    86. 86
    87. 87
    88. 88
    89. 89
    90. 90
    91. 91
    92. 92
    93. 93
    94. 94
    95. 95
    96. 96
    97. 97
    Запрос = Новый Запрос;
    	Запрос.Текст = 
    	 "текст запроса не важен...";
    	Запрос.УстановитьПараметр("Заказ", Заказ);
    	Выборка = Запрос.Выполнить().Выбрать();
    	Пока Выборка.Следующий() Цикл
    		Если Выборка.Версия = 0 Тогда 
    			Версия = "0";
    		Иначе
    			Версия = Выборка.Версия;
    		КонецЕсли;
    		ИмяФайла = "\\eskoautomation\HotFolders\zakaz\" +Выборка.НомерЗаказа+"_"+Версия+".xml";
    		Файл = Новый ЗаписьXML;
    		Файл.ОткрытьФайл(ИмяФайла);
    		Файл.ЗаписатьНачалоЭлемента("Главный");
    			Файл.ЗаписатьНачалоЭлемента("НомерЗаказа");
    			ЗаписатьXML(Файл,Выборка.НомерЗаказа);
    			Файл.ЗаписатьКонецЭлемента();
    			Файл.ЗаписатьНачалоЭлемента("Версия");
    			ЗаписатьXML(Файл,Выборка.Версия);
    			Файл.ЗаписатьКонецЭлемента();
    			Файл.ЗаписатьНачалоЭлемента("Контрагент");
    			ЗаписатьXML(Файл,Выборка.Контрагент);
    			Файл.ЗаписатьКонецЭлемента();
    			Файл.ЗаписатьНачалоЭлемента("ТипЗаказа");
    			ЗаписатьXML(Файл,Выборка.ТипЗаказа);
    			Файл.ЗаписатьКонецЭлемента();
    			Файл.ЗаписатьНачалоЭлемента("ВидЗаказа");
    			ЗаписатьXML(Файл,Выборка.ВидЗаказа);
    			Файл.ЗаписатьКонецЭлемента();
    	        Файл.ЗаписатьНачалоЭлемента("ТипРЦ");
    			ЗаписатьXML(Файл,Выборка.ТипРЦ);
    			Файл.ЗаписатьКонецЭлемента();
    			РабочийЦентр = Выборка.РабочийЦентр;
    			Если Не ЗначениеЗаполнено(РабочийЦентр) Тогда
    				Отбор = Новый Структура;
    				Отбор.Вставить("НомерПроката", 1);
    				Отбор.Вставить("Номерварианта", Выборка.НомерВарианта);
    				строки = Выборка.Спецификация.ВидыРабот.НайтиСтроки(Отбор);
    				Если строки<>Неопределено Тогда 
    					РабочийЦентр = строки[0].рабочийЦентр.порядковыйномер;
    				КонецЕсли;
    			КонецЕсли;	
    	        Файл.ЗаписатьНачалоЭлемента("РабочийЦентр");
    			ЗаписатьXML(Файл,РабочийЦентр);
    			Файл.ЗаписатьКонецЭлемента();
    			Файл.ЗаписатьНачалоЭлемента("ОсновнойМатериал");
    			ЗаписатьXML(Файл,Выборка.ОсновнойМатериал);
    			Файл.ЗаписатьКонецЭлемента();
    			Файл.ЗаписатьНачалоЭлемента("Штамп");
    			ЗаписатьXML(Файл,Выборка.Штамп);
    			Файл.ЗаписатьКонецЭлемента();
    			Файл.ЗаписатьНачалоЭлемента("ЭтикетокНаЛисте");
    			ЗаписатьXML(Файл,Выборка.ЭтикетокНаЛисте);
    			Файл.ЗаписатьКонецЭлемента();
    			Файл.ЗаписатьНачалоЭлемента("Нарезка");
    			ЗаписатьXML(Файл,Выборка.Нарезка);
    			Файл.ЗаписатьКонецЭлемента();
    			Файл.ЗаписатьНачалоЭлемента("Ручьи");
    			ЗаписатьXML(Файл,Выборка.Ручьи);
    			Файл.ЗаписатьКонецЭлемента();
    			Файл.ЗаписатьНачалоЭлемента("Z");
    			ЗаписатьXML(Файл,Выборка.Z);
    			Файл.ЗаписатьКонецЭлемента();
    	        Файл.ЗаписатьНачалоЭлемента("ШагПечати");
    			ЗаписатьXML(Файл,Выборка.ШагПечати);
    			Файл.ЗаписатьКонецЭлемента();
    	        Файл.ЗаписатьНачалоЭлемента("ДлинаЭтикетки");
    			ЗаписатьXML(Файл,Выборка.ДлинаЭтикетки);
    			Файл.ЗаписатьКонецЭлемента();
    			Файл.ЗаписатьНачалоЭлемента("ШиринаЭтикетки");
    			ЗаписатьXML(Файл,Выборка.ШиринаЭтикетки);
    			Файл.ЗаписатьКонецЭлемента();
    			Файл.ЗаписатьНачалоЭлемента("ДлинаКонтрЭтикетки");
    			ЗаписатьXML(Файл,Выборка.ДлинаКонтрЭтикетки);
    			Файл.ЗаписатьКонецЭлемента();
    			Файл.ЗаписатьНачалоЭлемента("ДлинаКольеретки");
    			ЗаписатьXML(Файл,Выборка.ДлинаКольеретки);
    			Файл.ЗаписатьКонецЭлемента();
    			Файл.ЗаписатьНачалоЭлемента("ШиринаКонтрЭтикетки");
    			ЗаписатьXML(Файл,Выборка.ШиринаКонтрЭтикетки);
    			Файл.ЗаписатьКонецЭлемента();
    			Файл.ЗаписатьНачалоЭлемента("ШиринаКольеретки");
    			ЗаписатьXML(Файл,Выборка.ШиринаКольеретки);
    			Файл.ЗаписатьКонецЭлемента();
    			Файл.ЗаписатьНачалоЭлемента("ШиринаПоНожам");
    			ЗаписатьXML(Файл,Выборка.ШиринаПоНожам);
    			Файл.ЗаписатьКонецЭлемента();
    	        Файл.ЗаписатьНачалоЭлемента("ИнтервалМеждуРучьями");
    			ЗаписатьXML(Файл,Выборка.ИнтервалМеждуРучьями);
    			Файл.ЗаписатьКонецЭлемента();
    	        Файл.ЗаписатьНачалоЭлемента("ИнтервалМеждуЭтикетками");
    			ЗаписатьXML(Файл,Выборка.ИнтервалМеждуЭтикетками);
    			Файл.ЗаписатьКонецЭлемента();
    			Файл.ЗаписатьНачалоЭлемента("Комментарий");
    			ЗаписатьXML(Файл,Заказ.Комментарий);
    			Файл.ЗаписатьКонецЭлемента();

    А вот так мы выгружаем XML. Можно конечно было бы пройтись циклом по колонкам выборки или таблицы значений, но зачем?! Зачем, когда можно написать лишних 300 строчек. Я соду с ума.

    levxxx, 24 Февраля 2016

    Комментарии (4)
  5. 1C / Говнокод #19518

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    ВыборкаЗаказов = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    
    	Пока ВыборкаЗаказов.Следующий() Цикл
    
    		ВыборкаГрузополучателей = ВыборкаЗаказов.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    		Пока ВыборкаГрузополучателей.Следующий() Цикл
    
    			ВыборкаАдресовДоставки = ВыборкаГрузополучателей.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    			Пока ВыборкаАдресовДоставки.Следующий() Цикл
    
    				РезультатЗапроса = ВыборкаАдресовДоставки.Выбрать();
    				СтавкаНДС = ПолучитьСтавкуНДСдляДокументов(Переменные.ОргПроизводитель, РезультатЗапроса[0].Контрагент);
    				Если РезультатЗапроса.Количество() <> 0 Тогда
     
    					ТАблицаДАнных = ПреобразоватьВыборкуВТаблицуЗначение(РезультатЗапроса);
    
    Функция ПреобразоватьВыборкуВТаблицуЗначение(ИсходнаяВыборка)
    	
    	ТаблицаРЕзультат = Новый ТаблицаЗначений;
    	
    	Для каждого Колонка Из ИсходнаяВыборка.Колонки Цикл
    		ТаблицаРезультат.Колонки.Добавить(Колонка.Имя);	
    	КОнецЦикла;
    	
    	
    	Для каждого СтрокаВыборки из ИсходнаяВыборка Цикл
    		СтрокаРезультата = ТаблицаРЕзультат.Добавить();
    		ЗаполнитьЗначенияСвойств(СтрокаВыборки, СтрокаРезультата);
    	КонецЦикла;
    	
    	Возврат ТаблицаРЕзультат;
    КонецФункции

    Я допускаю, что это было написано в староглиняные времена, когда у РезультатЗапроса не было метода Выгрузить() но блин! Всей истории 1С я не знаю, и сомневаюсь, что такие времена когда-то были. А вообще что-то подсказывает что песатель просто не знал...

    levxxx, 24 Февраля 2016

    Комментарии (3)
  6. 1C / Говнокод #19515

    +1

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    Запрос.УстановитьПараметр("Бумага", Справочники.Номенклатура.НайтиПоКоду("g0000000012"));
    	Запрос.УстановитьПараметр("Пленка", Справочники.Номенклатура.НайтиПоКоду("g0000000382"));
    	Запрос.УстановитьПараметр("Тиснение", Справочники.Номенклатура.НайтиПоКоду("g0000000481"));
    	Запрос.УстановитьПараметр("Фольга", Справочники.Номенклатура.НайтиПоКоду("g0000000459"));
    	Запрос.УстановитьПараметр("Полуфабрикат", Справочники.Номенклатура.НайтиПоКоду("g0000001919"));
    	Запрос.УстановитьПараметр("Ламинация1", Справочники.Номенклатура.НайтиПоКоду("g0000000074"));
    	Запрос.УстановитьПараметр("Ламинация2", Справочники.Номенклатура.НайтиПоКоду("g0000001292"));

    Возможно стоило использовать предопределенные элементы? Или справочник виды номенклатуры? Или свойства и категории объектов? Или создать своё перечисление? ДА БЛИН ЧТО УГОДНО ТОЛЬКО НЕ ЭТО!!!

    levxxx, 24 Февраля 2016

    Комментарии (7)
  7. 1C / Говнокод #19513

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    47. 47
    48. 48
    49. 49
    50. 50
    51. 51
    52. 52
    53. 53
    54. 54
    55. 55
    56. 56
    57. 57
    58. 58
    59. 59
    60. 60
    61. 61
    62. 62
    63. 63
    64. 64
    65. 65
    66. 66
    67. 67
    68. 68
    69. 69
    70. 70
    71. 71
    72. 72
    73. 73
    74. 74
    75. 75
    76. 76
    77. 77
    // 
    //Функция проверяет наличие товара на складе для проведения документа
    Функция СверкаОстатковТовараПоСкладу(Док)Экспорт
    	Отказ=Ложь;
    	ВыбСклад="";
    	ЗаказВРеализации=неопределено;
    	ЭтоЗаказ=Ложь; 
    	Если ТипЗнч(Док)=Тип("ДокументСсылка.ЗаказПокупателя") Тогда
    		 ВыбСклад=Док.СкладГруппа;
    		 ЭтоЗаказ=Истина;
    	ИначеЕсли ТипЗнч(Док)=Тип("ДокументСсылка.РеализацияТоваровУслуг") Тогда	 
    		ВыбСклад=Док.Склад;
    		Если СокрЛП(Док.Сделка)<>"" Тогда
    			Если ТипЗнч(Док.Сделка)=Тип("ДокументСсылка.ЗаказПокупателя") Тогда
    				ЗаказВРеализации=Док.Сделка;
    			КонецЕсли;	
    		КонецЕсли;	
    	Иначе
    		Возврат Отказ;
    	КонецЕсли;
        ТаблТовара=Док.Товары.Выгрузить();
    	
    	Если ТипЗнч(ТаблТовара)=Тип("ТаблицаЗначений") Тогда
    		СписокНом=ТаблТовара.ВыгрузитьКолонку("Номенклатура");
    		Если ЭтоЗаказ ИЛИ ЗаказВРеализации=неопределено Тогда  //Заказ или реализация не на основании заказа
    			Запрос=Новый Запрос;
    			Запрос.Текст="ВЫБРАТЬ
    			|	ТоварыНаСкладахОстатки.Номенклатура,
    			|	СУММА(ТоварыНаСкладахОстатки.КоличествоОстаток) КАК КоличествоОстаток
    			|ИЗ
    			|	РегистрНакопления.ТоварыНаСкладах.Остатки(&КонДата, Склад = &Склад) КАК ТоварыНаСкладахОстатки
    			|ГДЕ
    			|	ТоварыНаСкладахОстатки.Номенклатура В ИЕРАРХИИ(&Номенклатура)
    			|
    			|СГРУППИРОВАТЬ ПО
    			|	ТоварыНаСкладахОстатки.Номенклатура";
    			
    			Запрос.УстановитьПараметр("Номенклатура",СписокНом);
    			Запрос.УстановитьПараметр("КонДата",Док.Дата);
    			Запрос.УстановитьПараметр("Склад",ВыбСклад);
    			Рез=Запрос.Выполнить().Выгрузить();
    			ТаблТовара.Свернуть("Номенклатура,ЕдиницаИзмерения,Коэффициент","Количество");
    			Для каждого Стр из ТаблТовара Цикл
    				СтрОстаток=Рез.Найти(Стр.Номенклатура,"Номенклатура");
    				Если СтрОстаток=Неопределено Тогда //Нет остатка товара
    					 Сообщить("Остаток товара:  "+СокрЛП(Стр.Номенклатура)+"  на складе:  "+СокрЛП(ВыбСклад)+" =0");
    					 Отказ=Истина;
    				//	 Прервать;
    				Иначе
    					 Остаток=СтрОстаток.КоличествоОстаток;
    					 Если Остаток<(Стр.Количество*Стр.Коэффициент)Тогда
    						 Сообщить("Остаток товара:  "+СокрЛП(Стр.Номенклатура)+"  на складе:  "+СокрЛП(ВыбСклад)+" ="+СокрЛП(Остаток)+"  требуется ="+СокрЛП(Стр.Количество*Стр.Коэффициент));
    						 Отказ=Истина;
    					 КонецЕсли;	 
    				КонецЕсли;	 
    			КонецЦикла;	
    		Иначе	//Реализация на основании заказа
    			ТаблТовара.Свернуть("Номенклатура,ЕдиницаИзмерения,Коэффициент","Количество");
    			ТоварВЗаказе=ЗаказВРеализации.Товары.Выгрузить();
    			Для каждого Стр из ТаблТовара Цикл
    				СтрЗаказ=ТоварВЗаказе.Найти(Стр.Номенклатура,"Номенклатура");
    				Если СтрЗаказ=Неопределено Тогда //Нет остатка товара
    					 Сообщить("Требуется:  "+СокрЛП(Стр.Номенклатура)+"  "+СокрЛП(Стр.Количество*Стр.Коэффициент)+"  в заказе:  "+" =0  "+СокрЛП(Стр.Номенклатура.ЕдиницаХраненияОстатков));
    					 Отказ=Истина;
    				//	 Прервать;
    				Иначе
    					 Остаток=(СтрЗаказ.Количество*СтрЗаказ.Коэффициент);
    					 Если Остаток<(Стр.Количество*Стр.Коэффициент)Тогда
    					 	 Сообщить("Требуется:  "+СокрЛП(Стр.Номенклатура)+"  "+СокрЛП(Стр.Количество*Стр.Коэффициент)+"  в заказе:  "+" = "+СокрЛП(Остаток)+" "+СокрЛП(Стр.Номенклатура.ЕдиницаХраненияОстатков));
    						 Отказ=Истина;
    					 КонецЕсли;	 
    				КонецЕсли;	 
    			КонецЦикла;	
    		КонецЕсли;	
    	КонецЕсли;
    	Возврат Отказ;
    КонецФункции

    !!!!!!!!!!!!!!!!!!

    saturn5, 22 Февраля 2016

    Комментарии (10)
  8. 1C / Говнокод #19512

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    Процедура СводПродажКоличество_Свод()
         ТаблицаПродаж.Очистить();
         //Здесь с учетом возвратов
         Запрос = Новый Запрос;
         Запрос.Текст = "ВЫБРАТЬ
                             |     ТоварыОрганизацийОбороты.Номенклатура,
                             |     ТоварыОрганизацийОбороты.КоличествоРасход КАК Количество
                             |ИЗ
                             |     РегистрНакопления.ТоварыОрганизаций.Обороты(&Период1, &Период2, Период, Склад = &Склад) КАК ТоварыОрганизацийОбороты";
         Запрос.УстановитьПараметр("Период1"     , НачалоДня(НачДата));
         Запрос.УстановитьПараметр("Период2"     , КонецДня(КонДата));
         Запрос.УстановитьПараметр("Склад"      , СкладПриемник);
         
         Рез=Запрос.Выполнить().Выбрать();
         Пока Рез.Следующий() Цикл
              Нов=ТаблицаПродаж.Добавить();
              Нов.Номенклатура=Рез.Номенклатура;
              Нов.Количество=Рез.Количество;
         КонецЦикла;     
        ТаблицаПродаж.Свернуть("Номенклатура","Количество");
    КонецПроцедуры

    Вот так некоторые суровые красноярские 1С-ники феерически говнокодят в вакууме!

    saturn5, 22 Февраля 2016

    Комментарии (9)
  9. 1C / Говнокод #19503

    +3

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    Если  Стрк.Контрагент.ИНН = "7702691545" Тогда
    				ТекДок.Грузополучатель = Справочники.Контрагенты.НайтиПоКоду("000401789");
    			ИначеЕсли  ПоХенкелю Тогда
    				ТекДок.Грузополучатель = Заявка.Контрагент;
    			КонецЕсли;

    Навряд ли конечно кто-то из тех кто пишет такой код, читает этот сайт, но всё же обращаюсь к ним. Вот скажите, есть какой-то негласный принцип так писать? У вас какой-то орден масонский, где вас так учат делать? Расскажите же про свой негласный кодекс хорошего программиста! Просто я много где поработал, и постоянно в коде такое говно, написанное разными людьми. Генезис такого говна понятен: приходит тупорылый менеджер и приносит не менее тупорылую хотелку, но ведь вы программист, а значит вы должны видеть за деревьями лес.
    В каждой задаче нужно видеть за деревьями лес - вот принцип хорошего кода. Если менеджер пришёл 1 раз, он 100% придёт ещё раз, и принесёт подобную задачу. Не лучше ли сейчас немножко посидеть, написать ХОРОШО а в следующий раз решить подобную задачу за 1 минуту и дальше сидеть и пинать говно? Не лучше?!
    Что значит хорошо? Хорошо, это когда ваше решение шире задачи, а задача которую вам дали всего лишь частный случай того функционала, который вы реализовали. 1 - Мыслить нужно шире.
    Так же надо чётко разделять ту информацию которая хранится в базе, и имена переменных. Если наименование контрагента "Хенкель" то какого члена в тексте делает переменная "КонтрагентХенкель"?! Предопределенные элементы - это максимум хардкода, который приемлем. Вы вообще слышали про компиляцию? Компиляция процесс необратимый, и часто её делать нежелательно, поэтому максимум параметров надо выносить во всевозможные настройки и параметры, чтобы можно было их поменять на ходу. Ладно. Вы всё равно нифига не поймёте.

    levxxx, 20 Февраля 2016

    Комментарии (19)
  10. 1C / Говнокод #19498

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    9. 9
    |ИЗ
    |	РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(
    |			&ДатаНач,
    |			&ДатаКон,
    |			СчетДт В ИЕРАРХИИ (&СчетаРасчетов)
    |				И СчетКт В ИЕРАРХИИ (&СчетаВозврата)
    |				И Организация = &Организация
    |				И Активность = ИСТИНА
    |				И (НЕ СчетДт В ИЕРАРХИИ (&СчетаРасчетов))) КАК ХозрасчетныйОборотыДтКт

    БП 2.0, типовой отчет.

    OdinAss, 19 Февраля 2016

    Комментарии (4)