1. 1C / Говнокод #19513

    −100

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    47. 47
    48. 48
    49. 49
    50. 50
    51. 51
    52. 52
    53. 53
    54. 54
    55. 55
    56. 56
    57. 57
    58. 58
    59. 59
    60. 60
    61. 61
    62. 62
    63. 63
    64. 64
    65. 65
    66. 66
    67. 67
    68. 68
    69. 69
    70. 70
    71. 71
    72. 72
    73. 73
    74. 74
    75. 75
    76. 76
    77. 77
    // 
    //Функция проверяет наличие товара на складе для проведения документа
    Функция СверкаОстатковТовараПоСкладу(Док)Экспорт
    	Отказ=Ложь;
    	ВыбСклад="";
    	ЗаказВРеализации=неопределено;
    	ЭтоЗаказ=Ложь; 
    	Если ТипЗнч(Док)=Тип("ДокументСсылка.ЗаказПокупателя") Тогда
    		 ВыбСклад=Док.СкладГруппа;
    		 ЭтоЗаказ=Истина;
    	ИначеЕсли ТипЗнч(Док)=Тип("ДокументСсылка.РеализацияТоваровУслуг") Тогда	 
    		ВыбСклад=Док.Склад;
    		Если СокрЛП(Док.Сделка)<>"" Тогда
    			Если ТипЗнч(Док.Сделка)=Тип("ДокументСсылка.ЗаказПокупателя") Тогда
    				ЗаказВРеализации=Док.Сделка;
    			КонецЕсли;	
    		КонецЕсли;	
    	Иначе
    		Возврат Отказ;
    	КонецЕсли;
        ТаблТовара=Док.Товары.Выгрузить();
    	
    	Если ТипЗнч(ТаблТовара)=Тип("ТаблицаЗначений") Тогда
    		СписокНом=ТаблТовара.ВыгрузитьКолонку("Номенклатура");
    		Если ЭтоЗаказ ИЛИ ЗаказВРеализации=неопределено Тогда  //Заказ или реализация не на основании заказа
    			Запрос=Новый Запрос;
    			Запрос.Текст="ВЫБРАТЬ
    			|	ТоварыНаСкладахОстатки.Номенклатура,
    			|	СУММА(ТоварыНаСкладахОстатки.КоличествоОстаток) КАК КоличествоОстаток
    			|ИЗ
    			|	РегистрНакопления.ТоварыНаСкладах.Остатки(&КонДата, Склад = &Склад) КАК ТоварыНаСкладахОстатки
    			|ГДЕ
    			|	ТоварыНаСкладахОстатки.Номенклатура В ИЕРАРХИИ(&Номенклатура)
    			|
    			|СГРУППИРОВАТЬ ПО
    			|	ТоварыНаСкладахОстатки.Номенклатура";
    			
    			Запрос.УстановитьПараметр("Номенклатура",СписокНом);
    			Запрос.УстановитьПараметр("КонДата",Док.Дата);
    			Запрос.УстановитьПараметр("Склад",ВыбСклад);
    			Рез=Запрос.Выполнить().Выгрузить();
    			ТаблТовара.Свернуть("Номенклатура,ЕдиницаИзмерения,Коэффициент","Количество");
    			Для каждого Стр из ТаблТовара Цикл
    				СтрОстаток=Рез.Найти(Стр.Номенклатура,"Номенклатура");
    				Если СтрОстаток=Неопределено Тогда //Нет остатка товара
    					 Сообщить("Остаток товара:  "+СокрЛП(Стр.Номенклатура)+"  на складе:  "+СокрЛП(ВыбСклад)+" =0");
    					 Отказ=Истина;
    				//	 Прервать;
    				Иначе
    					 Остаток=СтрОстаток.КоличествоОстаток;
    					 Если Остаток<(Стр.Количество*Стр.Коэффициент)Тогда
    						 Сообщить("Остаток товара:  "+СокрЛП(Стр.Номенклатура)+"  на складе:  "+СокрЛП(ВыбСклад)+" ="+СокрЛП(Остаток)+"  требуется ="+СокрЛП(Стр.Количество*Стр.Коэффициент));
    						 Отказ=Истина;
    					 КонецЕсли;	 
    				КонецЕсли;	 
    			КонецЦикла;	
    		Иначе	//Реализация на основании заказа
    			ТаблТовара.Свернуть("Номенклатура,ЕдиницаИзмерения,Коэффициент","Количество");
    			ТоварВЗаказе=ЗаказВРеализации.Товары.Выгрузить();
    			Для каждого Стр из ТаблТовара Цикл
    				СтрЗаказ=ТоварВЗаказе.Найти(Стр.Номенклатура,"Номенклатура");
    				Если СтрЗаказ=Неопределено Тогда //Нет остатка товара
    					 Сообщить("Требуется:  "+СокрЛП(Стр.Номенклатура)+"  "+СокрЛП(Стр.Количество*Стр.Коэффициент)+"  в заказе:  "+" =0  "+СокрЛП(Стр.Номенклатура.ЕдиницаХраненияОстатков));
    					 Отказ=Истина;
    				//	 Прервать;
    				Иначе
    					 Остаток=(СтрЗаказ.Количество*СтрЗаказ.Коэффициент);
    					 Если Остаток<(Стр.Количество*Стр.Коэффициент)Тогда
    					 	 Сообщить("Требуется:  "+СокрЛП(Стр.Номенклатура)+"  "+СокрЛП(Стр.Количество*Стр.Коэффициент)+"  в заказе:  "+" = "+СокрЛП(Остаток)+" "+СокрЛП(Стр.Номенклатура.ЕдиницаХраненияОстатков));
    						 Отказ=Истина;
    					 КонецЕсли;	 
    				КонецЕсли;	 
    			КонецЦикла;	
    		КонецЕсли;	
    	КонецЕсли;
    	Возврат Отказ;
    КонецФункции

    !!!!!!!!!!!!!!!!!!

    saturn5, 22 Февраля 2016

    Комментарии (10)
  2. 1C / Говнокод #19512

    −99

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    Процедура СводПродажКоличество_Свод()
         ТаблицаПродаж.Очистить();
         //Здесь с учетом возвратов
         Запрос = Новый Запрос;
         Запрос.Текст = "ВЫБРАТЬ
                             |     ТоварыОрганизацийОбороты.Номенклатура,
                             |     ТоварыОрганизацийОбороты.КоличествоРасход КАК Количество
                             |ИЗ
                             |     РегистрНакопления.ТоварыОрганизаций.Обороты(&Период1, &Период2, Период, Склад = &Склад) КАК ТоварыОрганизацийОбороты";
         Запрос.УстановитьПараметр("Период1"     , НачалоДня(НачДата));
         Запрос.УстановитьПараметр("Период2"     , КонецДня(КонДата));
         Запрос.УстановитьПараметр("Склад"      , СкладПриемник);
         
         Рез=Запрос.Выполнить().Выбрать();
         Пока Рез.Следующий() Цикл
              Нов=ТаблицаПродаж.Добавить();
              Нов.Номенклатура=Рез.Номенклатура;
              Нов.Количество=Рез.Количество;
         КонецЦикла;     
        ТаблицаПродаж.Свернуть("Номенклатура","Количество");
    КонецПроцедуры

    Вот так некоторые суровые красноярские 1С-ники феерически говнокодят в вакууме!

    saturn5, 22 Февраля 2016

    Комментарии (9)
  3. 1C / Говнокод #19503

    −97

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    Если  Стрк.Контрагент.ИНН = "7702691545" Тогда
    				ТекДок.Грузополучатель = Справочники.Контрагенты.НайтиПоКоду("000401789");
    			ИначеЕсли  ПоХенкелю Тогда
    				ТекДок.Грузополучатель = Заявка.Контрагент;
    			КонецЕсли;

    Навряд ли конечно кто-то из тех кто пишет такой код, читает этот сайт, но всё же обращаюсь к ним. Вот скажите, есть какой-то негласный принцип так писать? У вас какой-то орден масонский, где вас так учат делать? Расскажите же про свой негласный кодекс хорошего программиста! Просто я много где поработал, и постоянно в коде такое говно, написанное разными людьми. Генезис такого говна понятен: приходит тупорылый менеджер и приносит не менее тупорылую хотелку, но ведь вы программист, а значит вы должны видеть за деревьями лес.
    В каждой задаче нужно видеть за деревьями лес - вот принцип хорошего кода. Если менеджер пришёл 1 раз, он 100% придёт ещё раз, и принесёт подобную задачу. Не лучше ли сейчас немножко посидеть, написать ХОРОШО а в следующий раз решить подобную задачу за 1 минуту и дальше сидеть и пинать говно? Не лучше?!
    Что значит хорошо? Хорошо, это когда ваше решение шире задачи, а задача которую вам дали всего лишь частный случай того функционала, который вы реализовали. 1 - Мыслить нужно шире.
    Так же надо чётко разделять ту информацию которая хранится в базе, и имена переменных. Если наименование контрагента "Хенкель" то какого члена в тексте делает переменная "КонтрагентХенкель"?! Предопределенные элементы - это максимум хардкода, который приемлем. Вы вообще слышали про компиляцию? Компиляция процесс необратимый, и часто её делать нежелательно, поэтому максимум параметров надо выносить во всевозможные настройки и параметры, чтобы можно было их поменять на ходу. Ладно. Вы всё равно нифига не поймёте.

    levxxx, 20 Февраля 2016

    Комментарии (19)
  4. 1C / Говнокод #19498

    −100

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    9. 9
    |ИЗ
    |	РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(
    |			&ДатаНач,
    |			&ДатаКон,
    |			СчетДт В ИЕРАРХИИ (&СчетаРасчетов)
    |				И СчетКт В ИЕРАРХИИ (&СчетаВозврата)
    |				И Организация = &Организация
    |				И Активность = ИСТИНА
    |				И (НЕ СчетДт В ИЕРАРХИИ (&СчетаРасчетов))) КАК ХозрасчетныйОборотыДтКт

    БП 2.0, типовой отчет.

    OdinAss, 19 Февраля 2016

    Комментарии (4)
  5. 1C / Говнокод #19493

    −98

    1. 1
    2. 2
    3. 3
    СтрокаТовары.Качество					       = СтрокиОст.Качество;
    СтрокаТовары.ЕдиницаИзмерения			= СтрокиОст.ЕдИзм;
    СтрокаТовары.ЕдиницаИзмеренияМест		= СтрокиОст.ЕдИзмМест;

    Поражает сам подход. А почему бы не выдумать для (поля/объекта/коллекции) ещё одно уникальное имя?! Ведь столько ещё свободных и красивых уникальных имён в мире есть! К тому же "ЕдИзм" - это ведь короче чем "ЕдиницаИзмерения", не правда ли? Дурак перепутает только, правда? Писать ведь будет удобней, правда?
    Ладно... про ЗаполнитьЗначенияСвойств писать уже баян. Но ведь СтрокиОст - это строка какой-то таблицы? А в исходной таблице это называлось "ЕдиницаИзмерения", наверное, да? Так зачем лишний раз придумывать псевдоним?!!! Зачем? Почему просто не соединить таблицы друг с другом в запросе? Почему?! Почему нужно постоянно дрочить циклами?!
    Циклы надо применять тогда, когда нельзя по-другому, а это узкий круг задач, например те, где нужен CAST которого в 1С нет, или распределение одной таблицы на другую по какому какой нибудь "хитровыдуманной и уникальной" бизнес логике. Даже списание по ФИФО уже придумали как сделать запросом... Не хочу! Хочу циклы...

    levxxx, 19 Февраля 2016

    Комментарии (1)
  6. 1C / Говнокод #19492

    −100

    1. 1
    2. 2
    3. 3
    4. 4
    ТипЗаказа = Число(Сред(СокрЛП(Формат(Стрк.Заказ, "ЧГ=")), 3, 1));
    ...
    Если ТипЗаказа = 9 ИЛИ ТипЗаказа = 8 ИЛИ ТипЗаказа = 7 Тогда
    ...

    Стрк.Заказ - есть строка с номером документа.
    Вообще, к статье брата Б. Нуралиева (простите не помню как его зовут) "1С как продукт инженерной мысли" хочется прилагать иллюстрации. И прилагать иллюстрации почему-то иллюстрации именно такие. Про "грамотное" использование составных типов хочется молчать.
    Если вы слышали про 13 правил Кодда, и слышали про атомарность данных в ячейках, и находите в этом рациональное зерно - ЗАБУДЬТЕ!

    levxxx, 19 Февраля 2016

    Комментарии (0)
  7. 1C / Говнокод #19481

    −99

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    Типовая зуп 2.5 данные берутся из справочника  "Степени родства физических лиц" не предопределенные элементы. 
    
    
    
    	Если ТекущаяСтрока.Пол = Перечисления.ПолФизическихЛиц.Мужской Тогда
    		
    		Если СтепеньРодстваРебенка = "05 " ИЛИ СтепеньРодстваРебенка = "06 " Тогда // Сын // Дочь
    			
    			ТекущаяСтрока.Статус = СоответствиеСтепенейРодства["03"]; // Отец
    			
    		ИначеЕсли СтепеньРодстваРебенка = "42 " ИЛИ СтепеньРодстваРебенка = "43 " Тогда // Пасынок // Падчерица
    			
    			ТекущаяСтрока.Статус = СоответствиеСтепенейРодства["40"]; // Отчим
    			
    		КонецЕсли; 
    		
    	Иначе
    		
    		Если СтепеньРодстваРебенка = "05 " ИЛИ СтепеньРодстваРебенка = "06 " Тогда // Сын // Дочь
    			
    			ТекущаяСтрока.Статус = СоответствиеСтепенейРодства["04"]; // Мать
    			
    		ИначеЕсли СтепеньРодстваРебенка = "42 " ИЛИ СтепеньРодстваРебенка = "43 " Тогда // Пасынок // Падчерица
    			
    			ТекущаяСтрока.Статус = СоответствиеСтепенейРодства["41"]; // Мачеха
    			
    		КонецЕсли; 
    		
    	КонецЕсли;

    sandrohaos, 18 Февраля 2016

    Комментарии (4)
  8. 1C / Говнокод #19463

    −111

    1. 1
    ПроцентНДС = 18;

    Сферический, в вакууме. При любых условиях. 18! И точка! Что? Перечисление? Какое нахрен ещё перечисление! Перечисления для слабаков!

    levxxx, 15 Февраля 2016

    Комментарии (2)
  9. 1C / Говнокод #19435

    −38

    1. 001
    2. 002
    3. 003
    4. 004
    5. 005
    6. 006
    7. 007
    8. 008
    9. 009
    10. 010
    11. 011
    12. 012
    13. 013
    14. 014
    15. 015
    16. 016
    17. 017
    18. 018
    19. 019
    20. 020
    21. 021
    22. 022
    23. 023
    24. 024
    25. 025
    26. 026
    27. 027
    28. 028
    29. 029
    30. 030
    31. 031
    32. 032
    33. 033
    34. 034
    35. 035
    36. 036
    37. 037
    38. 038
    39. 039
    40. 040
    41. 041
    42. 042
    43. 043
    44. 044
    45. 045
    46. 046
    47. 047
    48. 048
    49. 049
    50. 050
    51. 051
    52. 052
    53. 053
    54. 054
    55. 055
    56. 056
    57. 057
    58. 058
    59. 059
    60. 060
    61. 061
    62. 062
    63. 063
    64. 064
    65. 065
    66. 066
    67. 067
    68. 068
    69. 069
    70. 070
    71. 071
    72. 072
    73. 073
    74. 074
    75. 075
    76. 076
    77. 077
    78. 078
    79. 079
    80. 080
    81. 081
    82. 082
    83. 083
    84. 084
    85. 085
    86. 086
    87. 087
    88. 088
    89. 089
    90. 090
    91. 091
    92. 092
    93. 093
    94. 094
    95. 095
    96. 096
    97. 097
    98. 098
    99. 099
    100. 100
    ВЫБРАТЬ
    	
    	СправочникНоменклатура.Ссылка КАК Ссылка,
    	СправочникНоменклатура.Артикул КАК Артикул,
    	СправочникНоменклатура.Код КАК Код,
    	СправочникНоменклатура.Наименование КАК Наименование,
    	СправочникНоменклатура.ПометкаУдаления КАК ПометкаУдаления,
    	СправочникНоменклатура.Родитель КАК Родитель,
    	СправочникНоменклатура.ЭтоГруппа КАК ЭтоГруппа,
    	СправочникНоменклатура.Ссылка КАК Номенклатура,
    	СправочникНоменклатура.Ссылка КАК ЭлементСписка,
    	СправочникНоменклатура.ВидНоменклатуры КАК ВидНоменклатуры,
    	СправочникНоменклатура.ТипНоменклатуры КАК ТипНоменклатуры,
    	
    	ВЫБОР КОГДА СправочникНоменклатура.ТипНоменклатуры = ЗНАЧЕНИЕ(Перечисление.ТипыНоменклатуры.Набор) ТОГДА
    		ЕСТЬNULL(ВариантыКомплектацииНоменклатуры.ВариантРасчетаЦеныНабора, ЗНАЧЕНИЕ(Перечисление.ВариантыРасчетаЦенНаборов.ПустаяСсылка))
    	ИНАЧЕ
    		ЗНАЧЕНИЕ(Перечисление.ВариантыРасчетаЦенНаборов.ПустаяСсылка)
    	КОНЕЦ КАК ВариантРасчетаЦеныНабора,
    	ВариантыКомплектацииНоменклатуры.СодержитТовары КАК СодержитТовары,
    	ВариантыКомплектацииНоменклатуры.СодержитУслуги КАК СодержитУслуги,
    	
    	СправочникНоменклатура.ЕдиницаИзмерения КАК ЕдиницаИзмерения,
    	СправочникНоменклатура.ЦеноваяГруппа КАК ЦеноваяГруппа,
    	СправочникНоменклатура.Качество КАК Качество,
    	СправочникНоменклатура.ИспользованиеХарактеристик КАК ИспользованиеХарактеристик,
    	ВЫБОР
    		КОГДА СправочникНоменклатура.ТипНоменклатуры В (ЗНАЧЕНИЕ(Перечисление.ТипыНоменклатуры.Товар), ЗНАЧЕНИЕ(Перечисление.ТипыНоменклатуры.МногооборотнаяТара))
    			ТОГДА ИСТИНА
    		КОГДА СправочникНоменклатура.ТипНоменклатуры В (ЗНАЧЕНИЕ(Перечисление.ТипыНоменклатуры.Набор)) И ЕСТЬNULL(ВариантыКомплектацииНоменклатуры.СодержитТовары, ЛОЖЬ) И Не ЕСТЬNULL(ВариантыКомплектацииНоменклатуры.СодержитУслуги, ЛОЖЬ)
    			ТОГДА ИСТИНА
    		ИНАЧЕ ЛОЖЬ
    	КОНЕЦ КАК ЭтоТовар,
    	ВЫБОР
    		КОГДА СправочникНоменклатура.ТипНоменклатуры В (ЗНАЧЕНИЕ(Перечисление.ТипыНоменклатуры.Услуга), ЗНАЧЕНИЕ(Перечисление.ТипыНоменклатуры.Работа))
    			ТОГДА ИСТИНА
    		КОГДА СправочникНоменклатура.ТипНоменклатуры В (ЗНАЧЕНИЕ(Перечисление.ТипыНоменклатуры.Набор)) И ЕСТЬNULL(ВариантыКомплектацииНоменклатуры.СодержитУслуги, ЛОЖЬ) И НЕ ЕСТЬNULL(ВариантыКомплектацииНоменклатуры.СодержитТовары, ЛОЖЬ)
    			ТОГДА ИСТИНА
    		ИНАЧЕ ЛОЖЬ
    	КОНЕЦ КАК ЭтоУслуга,
    	ВЫБОР
    		КОГДА СправочникНоменклатура.ИспользованиеХарактеристик = ЗНАЧЕНИЕ(Перечисление.ВариантыИспользованияХарактеристикНоменклатуры.ОбщиеДляВидаНоменклатуры)
    			ТОГДА СправочникНоменклатура.ВидНоменклатуры
    		КОГДА СправочникНоменклатура.ИспользованиеХарактеристик = ЗНАЧЕНИЕ(Перечисление.ВариантыИспользованияХарактеристикНоменклатуры.ИндивидуальныеДляНоменклатуры)
    			ТОГДА СправочникНоменклатура.Ссылка
    		КОГДА СправочникНоменклатура.ИспользованиеХарактеристик = ЗНАЧЕНИЕ(Перечисление.ВариантыИспользованияХарактеристикНоменклатуры.ОбщиеСДругимВидомНоменклатуры)
    			ТОГДА СправочникНоменклатура.ВладелецХарактеристик
    		ИНАЧЕ Неопределено
    	КОНЕЦ КАК ВладелецХарактеристик,
    	ВЫБОР
    		КОГДА СправочникНоменклатура.ИспользованиеХарактеристик = ЗНАЧЕНИЕ(Перечисление.ВариантыИспользованияХарактеристикНоменклатуры.НеИспользовать)
    			ТОГДА ЛОЖЬ
    		ИНАЧЕ ИСТИНА
    	КОНЕЦ КАК ХарактеристикиИспользуются,
    	ВЫБОР
    		КОГДА СправочникНоменклатура.ЭтоГруппа
    			ТОГДА ВЫБОР
    					КОГДА СправочникНоменклатура.ПометкаУдаления
    						ТОГДА 13
    					ИНАЧЕ 12
    				КОНЕЦ
    		ИНАЧЕ ВЫБОР
    				КОГДА СправочникНоменклатура.ЕстьТоварыДругогоКачества
    					ТОГДА 4 + ВЫБОР
    							КОГДА СправочникНоменклатура.ПометкаУдаления
    								ТОГДА 1
    							ИНАЧЕ 0
    						КОНЕЦ + ВЫБОР
    							КОГДА СправочникНоменклатура.ИспользованиеХарактеристик = ЗНАЧЕНИЕ(Перечисление.ВариантыИспользованияХарактеристикНоменклатуры.НеИспользовать)
    								ТОГДА 0
    							ИНАЧЕ 2
    						КОНЕЦ
    				ИНАЧЕ -1 + ВЫБОР
    						КОГДА СправочникНоменклатура.ПометкаУдаления
    							ТОГДА 1
    						ИНАЧЕ 0
    					КОНЕЦ + ВЫБОР
    						КОГДА СправочникНоменклатура.ИспользованиеХарактеристик = ЗНАЧЕНИЕ(Перечисление.ВариантыИспользованияХарактеристикНоменклатуры.НеИспользовать)
    							ТОГДА 1
    						ИНАЧЕ 3
    					КОНЕЦ
    			КОНЕЦ
    	КОНЕЦ КАК ИндексКартинки,
    
    	&ВидыЦен КАК ВидЦены,
    	ЕСТЬNULL(ЦеныНоменклатуры.Упаковка, ЗНАЧЕНИЕ(Справочник.УпаковкиЕдиницыИзмерения.ПустаяСсылка)) КАК Упаковка,
    	ВЫРАЗИТЬ(ЕСТЬNULL(ЦеныНоменклатуры.Цена, 0) * ВЫБОР
    			КОГДА &Валюта <> ЦеныНоменклатуры.Валюта
    				ТОГДА ВЫБОР
    						КОГДА ЕСТЬNULL(КурсыСрезПоследнихВалютаЦены.Кратность, 0) > 0
    								И ЕСТЬNULL(КурсыСрезПоследнихВалютаЦены.Курс, 0) > 0
    								И ЕСТЬNULL(КурсыСрезПоследнихВалютаДокумента.Кратность, 0) > 0
    								И ЕСТЬNULL(КурсыСрезПоследнихВалютаДокумента.Курс, 0) > 0
    							ТОГДА КурсыСрезПоследнихВалютаЦены.Курс * КурсыСрезПоследнихВалютаДокумента.Кратность / (КурсыСрезПоследнихВалютаДокумента.Курс * КурсыСрезПоследнихВалютаЦены.Кратность)
    						ИНАЧЕ 0
    					КОНЕЦ
    			ИНАЧЕ 1
    		КОНЕЦ КАК ЧИСЛО(15, 2)) КАК Цена,
    	ВЫРАЗИТЬ(ЕСТЬNULL(СвободныеОстатки.ВНаличииОстаток, 0) / ЕСТЬNULL(ВЫБОР
    	КОГДА ЦеныНоменклатуры.Упаковка.ТипИзмеряемойВеличины = ЗНАЧЕНИЕ(Перечисление.ТипыИзмеряемыхВеличин.Вес) И ЦеныНоменклатуры.Номенклатура.ВесИспользовать

    Вот такой текст запроса в типовой конфигурации, причём он присутствует не в одном месте, а склеивается из разных кусков, в зависимости от условий, по моему неплохой претендент на звание лапши.

    VladC, 12 Февраля 2016

    Комментарии (2)
  10. 1C / Говнокод #19404

    −101

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    ЗапросУсл= Новый Запрос;
    ЗапросУсл.Текст=" ВЫБРАТЬ бит_УслугиЖКХ.Ссылка,
    |                       бит_УслугиЖКХ.Код,
    |                       бит_УслугиЖКХ.Наименование,
    |                       бит_УслугиЖКХ.Приоритет,
    |                       бит_УслугиЖКХ.ГруппаУслуги
    | ИЗ Справочник.бит_УслугиЖКХ КАК бит_УслугиЖКХ
    | ГДЕ бит_УслугиЖКХ.ПометкаУдаления=Ложь";
    	  
    tzУслуги=ЗапросУсл.Выполнить().Выгрузить(); 
    	 	 
    kolFind="";
    kolFind=мТаблицаПечати.Колонки.Найти("ГруппаУслуги");
    Если СокрЛП(Строка(kolFind))="" тогда
    	  мТаблицаПечати.Колонки.Добавить("ГруппаУслуги");
    КонецЕсли;
    	
     Для Каждого str_TP  Из мТаблицаПечати  Цикл 
     	//Сообщить(Строка(str_TP.Приоритет)+"    "+Строка(str_TP.Услуга));
    	 ncv="";
    	ncv= tzУслуги.Найти(str_TP.Услуга, "Ссылка" );
    	если СокрЛП(Строка(ncv))<>"" тогда
    		  str_TP.ГруппаУслуги=СокрЛП(Строка(ncv.ГруппаУслуги));
    	 конецесли;
    КонецЦикла;

    Так и хочется расстрелять этих козлов, но у них на сайте написано, что их более 5000 и они, как зараза, проникли в 43 города, в том числе и к буржуям.
    Ребя, скиньтесь на патроны, Greenpeace нас не забудет!

    ivan_0110, 05 Февраля 2016

    Комментарии (10)