1. 1C / Говнокод #21614

    +2

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    	Кавычка = """";
    	ПереносСтроки = Символы.ПС;
    	Строка = "Процедура КнопкаВыполнитьНажатие(Кнопка)	Кавычка = ;	ПереносСтроки = Символы.ПС;	Строка = ;	Сообщить (ПереносСтроки + Лев(Строка, 40) + ПереносСтроки + Сред(Строка, 41, 11) + Кавычка + Кавычка + Кавычка + Кавычка + Сред(Строка, 52, 1) + ПереносСтроки + Сред(Строка, 53, 28) + ПереносСтроки		+ Сред(Строка, 81, 10) + Кавычка + Строка + Кавычка + Сред(Строка, 91, 1) + ПереносСтроки + Сред(Строка, 92, 198) + ПереносСтроки + Сред(Строка, 290, 194) + ПереносСтроки + Сред(Строка, 485)); КонецПроцедуры";
    	Сообщить (ПереносСтроки + Лев(Строка, 40) + ПереносСтроки + Сред(Строка, 41, 11) + Кавычка + Кавычка + Кавычка + Кавычка + Сред(Строка, 52, 1) + ПереносСтроки + Сред(Строка, 53, 28) + ПереносСтроки
    		+ Сред(Строка, 81, 10) + Кавычка + Строка + Кавычка + Сред(Строка, 91, 1) + ПереносСтроки + Сред(Строка, 92, 198) + ПереносСтроки + Сред(Строка, 290, 194) + ПереносСтроки + Сред(Строка, 485));
    КонецПроцедуры

    1С квайн

    Запостил: mrbus, 31 Октября 2016

    Комментарии (9) RSS

    • Сцуко, первой строкой должна идти пустая строка, почему-то не попала.
      Ответить
    • >Лев
      Мне очень нравится название этой функции. Скорей в машину!
      Ответить
    • Каноничный квайн, как на лекциях по МЛТА.
      Функция НапечататьДваРазаВторойРазВКавычках(Т) Кав=Символ(34); Скобка=Символ(41); Сообщить(Т+Кав+Т+Кав+Скобка); КонецФункции НапечататьДваРазаВторойРазВКавычках("Функция НапечататьДваРазаВторойРазВКавычках(Т) Кав=Символ(34); Скобка=Символ(41); Сообщить(Т+Кав+Т+Кав+Скобка); КонецФункции НапечататьДваРазаВторойРазВКавычках(")
      Ответить
    • Кнопка показывает код своего обработчика?
      Ответить
      • По определению слова "квайн", хотя это неформальное словечко
        Ответить

    Добавить комментарий