1. 1C / Говнокод #21707

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    Для каждого зн Из масЗначСтр Цикл
       столбик=столбик+1;
       ЕСЛИ столбик <5 Тогда
        Продолжить;
       ИНАЧЕЕСЛИ столбик =6 ИЛИ столбик =7 ИЛИ  столбик =9 Тогда
        Продолжить;
       ИНАЧЕЕСЛИ (столбик >10) И (столбик <19)  Тогда
        Продолжить;
       ИНАЧЕЕСЛИ (столбик >19) И (столбик <24)  Тогда
        Продолжить;
       ИНАЧЕЕСЛИ (столбик >24) И (столбик <28)  Тогда
        Продолжить;
       ИНАЧЕЕСЛИ  (столбик =29)  Тогда
        Продолжить;
       ИНАЧЕЕСЛИ  (столбик >30)  Тогда
        Продолжить;
       ИНАЧЕ
        номЗнач = номЗнач + 1;
        Если  номЗнач>4  Тогда
         Прервать;
        Иначе
         новСтр[номЗнач] = СтрЗаменить(зн,символОграничения,"""");
         //Запомним сразу дату
         Если  номЗнач=3   Тогда
          Сдата=зн; 
         КонецЕсли;
         А=1;
        КонецЕсли;
       КОНЕЦЕСЛИ;
      КонецЦикла;

    выборка элементов массива, зная позицию этих элементов

    Запостил: DelHayprO, 22 Ноября 2016

    Комментарии (4) RSS

    • Ждём язык программирования, основанный на арабском письме. Ну, а хуле?
      Ответить
    • ЕСЛИ ПРАВДА ТОГДА
      Продолжить;
      ИНАЧЕЕСЛИ ЛОЖЬ ТОГДА
      Прервать;

      пофиксел
      Ответить
    • Наверное, в прошлых релизах этой замечтательной Нетленки в условиях было конкретное действие, а не Продолжить
      Ответить

    Добавить комментарий