1. 1C / Говнокод #21880

    −49

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    Количество = Окр(Строка.Количество,2);
    //
    Если СтрЧислоВхождений(Количество,",")=0 Тогда
    	Если СтрДлина(Количество)=1 Тогда
    		Количество = "00"+количество+"00";
    	ИначеЕсли СтрДлина(Количество)=2 Тогда
    		Количество = "0"+количество+"00";
    	ИначеЕсли СтрДлина(Количество)=3 Тогда
    		Количество = количество+"00";
    	КонецЕсли;
    ИначеЕсли СтрЧислоВхождений(Количество,",")=1 Тогда
    	ДлиннаСтроки = СтрДлина(Количество);
    	ПозТочки = Найти(Количество,",");
    	Если ПозТочки = 2 и ДлиннаСтроки = 3 Тогда
    		Количество ="00"+Количество+"0";
    	ИначеЕсли ПозТочки = 3 и ДлиннаСтроки = 4 Тогда
    		Количество = "0"+Количество+"0";
    	ИначеЕсли ПозТочки = 4 и ДлиннаСтроки = 5 Тогда
    		Количество = Количество+"0";
    	ИначеЕсли ПозТочки = 2 и ДлиннаСтроки = 4 Тогда
    		Количество = "00"+Количество;
    	ИначеЕсли ПозТочки = 3 и ДлиннаСтроки = 5 Тогда
    		Количество = "0"+Количество;
    	ИначеЕсли ПозТочки = 4 и ДлиннаСтроки = 6 Тогда
    		Количество = Количество;
    	ИначеЕсли ПозТочки = 4 и ДлиннаСтроки = 4 Тогда
    		Количество = Количество+"00";
    	КонецЕсли;
    КонецЕсли;
    Если СтрЧислоВхождений(Количество,",")=1 Тогда
    	Количество = СтрЗаменить(Количество,",","");
    КонецЕсли;

    Нужно было получить Количество типа 5 CHAR (NUM)
    Измерение в литрах и штуках
    Пример "00200" - 2 шт. "00650" - 6.5 литра
    Например можно так:
    Формат(Строка.Количество*100,"ЧЦ=5; ЧДЦ=0; ЧВН=; ЧГ=")

    Запостил: 105_306330_ru, 21 Декабря 2016

    Комментарии (0) RSS

    Добавить комментарий

    Ошибка компиляции комментария:
    1. На сайте проводится профилактика, поэтому гостям нельзя писать комментарии до 29 марта 2017. Говнокод.ру благодарит Вас за понимание!
    ava Я, guest, находясь в здравом уме и твердой памяти, торжественно заявляю:
    А не использовать ли нам bbcode?
    • [b]жирный[/b] — жирный
    • [i]курсив[/i] — курсив
    • [u]подчеркнутый[/u] — подчеркнутый
    • [s]перечеркнутый[/s] — перечеркнутый
    • [blink]мигающий[/blink] — мигающий
    • [color=red]цвет[/color] — цвет (подробнее)
    • [size=20]размер[/size] — размер (подробнее)
    • [code=<language>]some code[/code] (подробнее)
    Проверочный код