1. 1C / Говнокод #23081

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    //Модуль основной формы внешней обработки
    
    &НаКлиенте
    Процедура ПродатьСлона(Оферта)
    	
    	Перем Акцепт;
    	
    	Если ПустаяСтрока(Оферта) Тогда
    		
    		Оферта = "Купи слона!";
    		
    	Иначе
    		
    		Оферта = "Все говорят """+Оферта+""" а ты купи слона!";
    		
    	КонецЕсли;	
    		
    	ВвестиСтроку(Акцепт,Оферта,0, Истина); 	
    		
        ПродатьСлона(Акцепт);
    	
    КонецПроцедуры	
    
    &НаКлиенте
    Процедура ПриОткрытии(Отказ)
    	
    	ПродатьСлона("");
    	
    КонецПроцедуры

    Продаём слона!

    Запостил: informatikmarazmatik, 30 Мая 2017

    Комментарии (9) RSS

    • Все говорят "Я, informatikmarazmatik, находясь в здравом уме и твердой памяти, торжественно заявляю: Купи слона!" а ты купи слона!
      Ответить
    • У Вас стек перетечёт, а слона так и не реализуете.
      Ответить
      • Плюсую этого гуеста. В последнее время вижу кучу рекурсивного кода, в котором рекурсия нахуй не сдалась - это что, мода такая, новая?
        Ответить
        • Плюсанул этого госта.
          Ответить
        • Это из той же оперы, что и "ООП не нужно, будущее за ФП и жс".
          Ответить
          • Но объектно-ориентированное программирование действительно не требуется - не в пример удобнее писать код, используя подход процедурного программирования. Сразу исчезает лабиринт из директорий вида "app", "public", "vendor" и прочих. Исчезает множество бессмысленных инициализационных строк, фигурных скобок и знаков "=>". Становится легче дышать.
            Ответить
            • Проблема не в том, нужно ли ООП, проблема в хайпе.
              Ответить
    • //Версия 0.1 (оптимизированная)
      //Устранена текучесть стейка[?]
      //Модуль основной формы внешней обработки
      &НаКлиенте
      Функция ПродатьСлона(Акцепт)
      Если ПустаяСтрока(Акцепт) Тогда
      Оферта = "Купи слона!";
      Иначе
      Оферта = "Все говорят """+Акцепт+""" а ты купи слона!";
      КонецЕсли;
      Акцепт = "";
      ВвестиСтроку(Акцепт,Оферта,141, Истина);
      Возврат Истина;
      КонецФункции
      &НаКлиенте
      Процедура ПриОткрытии(Отказ)
      Перем Акцепт;
      Пока ПродатьСлона(Акцепт) Цикл КонецЦикла;
      КонецПроцедуры
      Ответить

    Добавить комментарий