1. 1C / Говнокод #23595

    +2

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    Запрос = Новый Запрос;
    Запрос.Текст = 
    	"ВЫБРАТЬ
    	|	ркЛицевыеСчета.Ссылка,
    	|	ркЛицевыеСчета.Помещение,
    	|	ркЛицевыеСчета.Дом КАК Дом,
    	|	ркЛицевыеСчета.Код КАК Код,
    	|	ркЛицевыеСчета.Помещение.Владелец Как ПомещениеВладелец
    	|ИЗ
    	|	Справочник.ркЛицевыеСчета КАК ркЛицевыеСчета";
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    	Об = Справочники.ркЛицевыеСчета.НайтиПоКоду(ВыборкаДетальныеЗаписи.Код);
    	О = Об.ПолучитьОбъект();
    	Д = Справочники.ркДома.НайтиПоНаименованию(ВыборкаДетальныеЗаписи.ПомещениеВладелец);
    	ДО = Д.ПолучитьОбъект();
    	Если Не О.ЭтоГруппа Тогда
    	О.Дом = ДО.Ссылка;
    	О.Записать();
    	КонецЕсли;
    	//ВыборкаДетальныеЗаписи
    КонецЦикла;

    Обработка в базе одного клиента.
    Не сразу понял что она вообще делает и зачем она ТАК ЭТО ДЕЛАЕТ.

    Запостил: naodesu, 18 Декабря 2017

    Комментарии (15) RSS

    • А код в 1С сделан на русском, чтобы повысить понятность и читабельность, а сама 1С это продукт жизнедеятельности, то есть полёта высокой инженерной мысли.
      Ответить
      • Тебя минусуют. С чего бы это? Может, потому, что 1с - гуано для офисного планктона?
        Ответить
    • Жуткий говнокодище от пионера-писателя. А плюсануть никак - какой-то сбой у сайта...
      Ответить
      • Видать, в движок сайта внедрили один из сабжей сайта.
        Ответить
    • О, знакомая конфа :) (ЖКХ) она там вся сказочная...
      Ответить
    • ёб@ныйвр.т!!!!
      Ответить
    • Интересно, нафига снова получать ссылку по коду, если уже в выборке запроса есть ссылка.
      Млять... Отрубить руки по самое горло. Ну хоть не запросолм в цикле ищет дома...
      Вообще уродство, аффтар не знал об условии в запросе
      ГДЕ НЕ ркЛицевыеСчета.ЭтоГруппа

      Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      	О = ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
      	О.Дом = ВыборкаДетальныеЗаписи.ПомещениеВладелец;
      	О.Записать();
      КонецЦикла;


      Переговнокодил.
      И вообще есть же всякие там обработки групповых изнасилований изменений объектов.
      Ответить

    Добавить комментарий