1. 1C / Говнокод #24240

    +1

    1. 001
    2. 002
    3. 003
    4. 004
    5. 005
    6. 006
    7. 007
    8. 008
    9. 009
    10. 010
    11. 011
    12. 012
    13. 013
    14. 014
    15. 015
    16. 016
    17. 017
    18. 018
    19. 019
    20. 020
    21. 021
    22. 022
    23. 023
    24. 024
    25. 025
    26. 026
    27. 027
    28. 028
    29. 029
    30. 030
    31. 031
    32. 032
    33. 033
    34. 034
    35. 035
    36. 036
    37. 037
    38. 038
    39. 039
    40. 040
    41. 041
    42. 042
    43. 043
    44. 044
    45. 045
    46. 046
    47. 047
    48. 048
    49. 049
    50. 050
    51. 051
    52. 052
    53. 053
    54. 054
    55. 055
    56. 056
    57. 057
    58. 058
    59. 059
    60. 060
    61. 061
    62. 062
    63. 063
    64. 064
    65. 065
    66. 066
    67. 067
    68. 068
    69. 069
    70. 070
    71. 071
    72. 072
    73. 073
    74. 074
    75. 075
    76. 076
    77. 077
    78. 078
    79. 079
    80. 080
    81. 081
    82. 082
    83. 083
    84. 084
    85. 085
    86. 086
    87. 087
    88. 088
    89. 089
    90. 090
    91. 091
    92. 092
    93. 093
    94. 094
    95. 095
    96. 096
    97. 097
    98. 098
    99. 099
    100. 100
    Функция СоздатьМассив // Экспорт, 29 параметров
    (
    	Значение01 = '05710422152926',
    	Значение02 = '05710422152926',
    	Значение03 = '05710422152926',
    	Значение04 = '05710422152926',
    	Значение05 = '05710422152926',
    	Значение06 = '05710422152926',
    	Значение07 = '05710422152926',
    	Значение08 = '05710422152926',
    	Значение09 = '05710422152926',
    	Значение10 = '05710422152926',
    	Значение11 = '05710422152926',
    	Значение12 = '05710422152926',
    	Значение13 = '05710422152926',
    	Значение14 = '05710422152926',
    	Значение15 = '05710422152926',
    	Значение16 = '05710422152926',
    	Значение17 = '05710422152926',
    	Значение18 = '05710422152926',
    	Значение19 = '05710422152926',
    	Значение20 = '05710422152926',
    	Значение21 = '05710422152926',
    	Значение22 = '05710422152926',
    	Значение23 = '05710422152926',
    	Значение24 = '05710422152926',
    	Значение25 = '05710422152926',
    	Значение26 = '05710422152926',
    	Значение27 = '05710422152926',
    	Значение28 = '05710422152926',
    	Значение29 = '05710422152926'
    )
    Экспорт
    	
    	Нил_ = '05710422152926'; // Предположительная дата рождения пророка Мухаммеда
    	
    	Если Нил_ = Значение02 Тогда
    		Если Нил_ = Значение01 Тогда
    			Массив_ = Новый Массив;
    			Перейти ~Метка00;
    		Иначе
    			Массив_ = Новый Массив(1);
    			Перейти ~Метка01;
    		КонецЕсли;
    	ИначеЕсли Нил_ = Значение06 Тогда
    		Если Нил_ = Значение04 Тогда
    			Если Нил_ = Значение03 Тогда
    				Массив_ = Новый Массив(2);
    				Перейти ~Метка02;
    			Иначе
    				Массив_ = Новый Массив(3);
    				Перейти ~Метка03;
    			КонецЕсли;
    		ИначеЕсли Нил_ = Значение05 Тогда
    			Массив_ = Новый Массив(4);
    			Перейти ~Метка04;
    		Иначе
    			Массив_ = Новый Массив(5);
    			Перейти ~Метка05;
    		КонецЕсли;
    	ИначеЕсли Нил_ = Значение14 Тогда
    		Если Нил_ = Значение10 Тогда
    			Если Нил_ = Значение08 Тогда
    				Если Нил_ = Значение07 Тогда
    					Массив_ = Новый Массив(6);
    					Перейти ~Метка06;
    				Иначе
    					Массив_ = Новый Массив(7);
    					Перейти ~Метка07;
    				КонецЕсли;
    			ИначеЕсли Нил_ = Значение09 Тогда
    				Массив_ = Новый Массив(8);
    				Перейти ~Метка08;
    			Иначе
    				Массив_ = Новый Массив(9);
    				Перейти ~Метка09;
    			КонецЕсли;
    		ИначеЕсли Нил_ = Значение12 Тогда
    			Если Нил_ = Значение11 Тогда
    				Массив_ = Новый Массив(10);
    				Перейти ~Метка10;
    			Иначе
    				Массив_ = Новый Массив(11);
    				Перейти ~Метка11;
    			КонецЕсли;
    		ИначеЕсли Нил_ = Значение13 Тогда
    			Массив_ = Новый Массив(12);
    			Перейти ~Метка12;
    		Иначе
    			Массив_ = Новый Массив(13);
    			Перейти ~Метка13;
    		КонецЕсли;
    	ИначеЕсли Нил_ = Значение22 Тогда
    		Если Нил_ = Значение18 Тогда
    			Если Нил_ = Значение16 Тогда
    				Если Нил_ = Значение15 Тогда
    					Массив_ = Новый Массив(14);
    					Перейти ~Метка14;
    				Иначе
    					Массив_ = Новый Массив(15);

    1С Медицина: Больничные
    Халяль

    Запостил: elizir, 09 Мая 2018

    Комментарии (6) RSS

    • __ТИП__(Массив_, "Массив", "АлгоритмыДляКоллекций.СоздатьМассив ");

      ~Метка29: Массив_[28] = Значение29;
      ~Метка28: Массив_[27] = Значение28;
      ~Метка27: Массив_[26] = Значение27;
      ~Метка26: Массив_[25] = Значение26;
      ~Метка25: Массив_[24] = Значение25;
      ~Метка24: Массив_[23] = Значение24;
      ~Метка23: Массив_[22] = Значение23;
      ~Метка22: Массив_[21] = Значение22;
      ~Метка21: Массив_[20] = Значение21;
      ~Метка20: Массив_[19] = Значение20;
      ~Метка19: Массив_[18] = Значение19;
      ~Метка18: Массив_[17] = Значение18;
      ~Метка17: Массив_[16] = Значение17;
      ~Метка16: Массив_[15] = Значение16;
      ~Метка15: Массив_[14] = Значение15;
      ~Метка14: Массив_[13] = Значение14;
      ~Метка13: Массив_[12] = Значение13;
      ~Метка12: Массив_[11] = Значение12;
      ~Метка11: Массив_[10] = Значение11;
      ~Метка10: Массив_[ 9] = Значение10;
      ~Метка09: Массив_[ 8] = Значение09;
      ~Метка08: Массив_[ 7] = Значение08;
      ~Метка07: Массив_[ 6] = Значение07;
      ~Метка06: Массив_[ 5] = Значение06;
      ~Метка05: Массив_[ 4] = Значение05;
      ~Метка04: Массив_[ 3] = Значение04;
      ~Метка03: Массив_[ 2] = Значение03;
      ~Метка02: Массив_[ 1] = Значение02;
      ~Метка01: Массив_[ 0] = Значение01;
      ~Метка00:

      Возврат Массив_;

      КонецФункции
      Ответить
    • Перейти ~Мекка; // Хадж
      Ответить

    Добавить комментарий