1. 1C / Говнокод #24426

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    Если Найти(_оинв.Комментарий,"#инвентаризация гсм#")=0 Тогда
    		_оинв.Комментарий="#инвентаризация гсм#";
    		Если не Найти(_комментарий,"газ")=0 Тогда
    			_оинв.Комментарий=_оинв.Комментарий+" газ";
    		ИначеЕсли не Найти(_оинв.Склад.Наименование,"АГЗС")=0 Тогда
    			_оинв.Комментарий=_оинв.Комментарий+" газ";
    		КонецЕсли;
    		_оинв.Комментарий=_оинв.Комментарий+" "+_комментарий;
    	ИначеЕсли не Найти(_оинв.Склад.Наименование,"АГЗС")=0 Тогда
    		Если Найти(_комментарий,"газ")=0 Тогда
    			_оинв.Комментарий=_оинв.Комментарий+" газ";
    		ИначеЕсли не Найти(_комментарий," газ газ")=0 Тогда
    			_оинв.Комментарий=СтрЗаменить(_оинв.Комментарий," газ газ"," газ");
    		КонецЕсли;
    	КонецЕсли;

    Где "_оинв" это ДокументОбъект Инвентаризация

    Запостил: MyNameIs, 29 Июня 2018

    Комментарии (6) RSS

    Добавить комментарий