1. 1C / Говнокод #24860

    −10

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    9. 9
    Процедура тпТоварыПриПолученииДанных(Элемент, ОформленияСтрок)
    	Модифицированность_ = Модифицированность;
    	Для Каждого Стр из ОформленияСтрок Цикл
    		Если НЕ Стр.ДанныеСтроки.Вес = 0 И НЕ Стр.ДанныеСтроки.ПроцентУсушки = 0 Тогда			
    			Стр.ДанныеСтроки.Усушка = (Стр.ДанныеСтроки.Вес * Стр.ДанныеСтроки.ПроцентУсушки / 100) * Стр.ДанныеСтроки.Количество;									
    		КонецЕсли;
    	КонецЦикла;
    	Модифицированность = Модифицированность_;
    КонецПроцедуры

    Данные табличной части модифицируются в процедуре ПриПолученииДанных (видимо, лучшего места для этого не нашлось), что закономерно приводит к отложенному на мгновение вызову ПриПолученииДанных ещё раз, и ещё, и так далее. В результате процессор загружается почти на 100%, значок * в заголовке формы дико мерцает.
    Написано программистом с 6-значной ЗП.

    Запостил: strashny_programmist, 04 Октября 2018

    Комментарии (15) RSS

    • Э-эээммм...
      Ответить
      • Это не переводимо, гниль.
        Вот парень рекомендует как вылечится https://youtu.be/VWSwlZZ9gHc
        Ответить
        • Попробую угадать, не запуская клип. Он предлагает капать малахитовый зелёный? Он есть в любом зоомагазине, но людей им лечить не рекомендуют из-за токсичности (ну типа рыбу не так жалко, как людей). Бриллиантовый зелёный вместо него подойдёт?
          Ответить
          • Мне бриллиантовый зелёный не помог. По-прежнему гнию.
            Ответить
          • Изумрудный
            Ответить
            • Не знаю такого. Знаю фуксин, метиленовый синий, метиловый фиолетовый, берлинскую лазурь. Изумрудный не знаю.
              Ответить
              • В принципе, изумрудный можно получить, если в бриллиантовый зелёный или в малахитовый зелёный капнуть немного метиленового синего.
                Ответить
          • >Бриллиантовый зелёный
            Это зеленка? На западе его уже не используют.
            Ответить
            • Барыги на «Ебее» её толкают за астрономическую цену. Дякую тобі, боже, що я не в Європі.
              Ответить
              • Вот тут нашлась в литовской упаковке:
                https://ebay.us/Nf11ac

                Я думал, что осталась только российская...

                Литва —— це Европа чи ни?
                Ответить
              • В жопу тебе толкают?
                Ответить
            • Что вместо неё? Собачья слюна?
              Ответить
    • Не тестировал своё говнецо "великий программист"? А зп - не показатель ничего. Не знаю таких людей, которые отказались бы от хороших денег в пользу умеренных ввиду неуверенности в собственном статусе. Если ищете-берёте человека на хорошую зп, то это не защита от орфографических/грамматических ошибок, а гарантия компетентности в предметной области. Профессия "писатель" существенно отличается от профессии "программист" как "художник" и "дизайнер", к примеру.
      Ответить
      • >> Не знаю таких людей, которые отказались бы от хороших денег в пользу умеренных ввиду неуверенности в собственном статусе.

        Ну я отказывался, когда чувствовал, что выйдет говно.
        Ответить

    Добавить комментарий