1. 1C / Говнокод #25322

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    // Проверим необходимость проведения авторизаций безналичных платежей
    	АвторизацийБПЕсть = НЕ (НетОплатПлатежнойКартой()
    	Если АвторизацийБПЕсть Тогда
    		// Выполняем авторизации безналичных платежей
    		Если НЕ ВыполнитьАвторизациюБП() Тогда
    .....
    
    
    
    Функция НетОплатПлатежнойКартой()
    
    	НетОплатПлатежнойКартой = Истина;
    	Для Каждого СтрокаОплаты Из Оплаты Цикл
    		Если СтрокаОплаты.ТипОплаты.Объект = Перечисления.ТипыОплатыВРознице.Безналичные Тогда
    			НетОплатПлатежнойКартой = Ложь;
    			Прервать;
    		КонецЕсли;
    	КонецЦикла;
    
    	Возврат НетОплатПлатежнойКартой;
    
    КонецФункции

    Нужно больше инверсий!

    Запостил: Jtsuken, 23 Января 2019

    Комментарии (5) RSS

    • НетОплатПлатежнойКартойЛожь = НЕ НетОплатПлатежнойКартой

      Если НЕ НетОплатПлатежнойКартойЛожь ..
      Ответить
      • А ведь были смешные примеры в каких-то библиотеках, когда название функции или параметра функции или флага сбивали с толку. Ну то есть чтобы что-то разрешить, надо было снимать флаг, а чтобы запретить –— устанавливать, хотя из его названия это не следовало.

        Было даже, что автор признавал свою ошибку, но ради обратной совместимости ничего не меняли.
        Ответить
        • Самый известный пример - встроенная функция ЗначениеНеЗаполнено, которую в очередном релизе платформы 1С превратили в ЗначениеЗаполнено. Изменение компания 1С прокомментировала как "приставка "не" во встроенной функции сбивает с толку".
          Ответить
    • Вероятно, функция НетОплатПлатежнойКартой() используется в этом модуле многократно
      Ответить
    • Есть мозговыносящая игрушка Not Not для Андроида, там он пишет, скажем: "синий" - бежишь в синюю дверь, "не синий" - в любую, кроме синей, "не не синий"... ну вы поняли.
      Ответить

    Добавить комментарий