1. 1C / Говнокод #25465

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    Набор = РегистрыСведений.ЗначенияСвойствОбъектов.СоздатьНаборЗаписей();
    		Отбор = Набор.Отбор;
    		Отбор.Объект.Использование = Истина;
    		Отбор.Объект.ВидСравнения = ВидСравнения.Равно;
    		Отбор.Свойство.ВидСравнения = ВидСравнения.Равно;
    		Отбор.Объект.Значение = Грузополучатель;                
    		Отбор.Свойство.Значение = ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоНаименованию("GLN").Ссылка;
    		Набор.Прочитать();
    		GLN_получ = "";
    		Если Набор.Количество() > 0 Тогда
    			Для нумер = 0 по Набор.Количество()-1 Цикл
    				Свво = Набор.Получить(нумер).Свойство;
    				Если СокрЛП(Свво.Наименование) = "GLN" Тогда
    					GLN_получ = Набор.Получить(нумер).Значение;
    				КонецЕсли;
    			КонецЦикла;
    		КонецЕсли;
    
    		ОбластьМакета.Параметры.GLN_получ       = GLN_получ;

    Запостил: cdpoma, 22 Марта 2019

    Комментарии (18) RSS

    • Набор.прочитать();
      ВОчко.отъебать();
      Ответить
    • Цикл, потому что автор не доверяет фильтру Отбор?
      Ответить
      • Автор молодой, зеленый, индусский программист.
        3 строчки кода, медленно превращаются в 1.
        //Отбор.Объект.Использование = Истина;
        //Отбор.Объект.ВидСравнения = ВидСравнения.Равно;
        //Отбор.Объект.Значение = Грузополучатель;
        Отбор.Объект.Уставновить(Грузополучатель, Истина);

        PS: А вообще, в печатных форма нужно использовать запрос для получения всех сведений, его доработать легко, достаточно заглянуть в "УправлениеОтчетами"
        Ответить
    • Набор.Отбор
      Ответить

    Добавить комментарий