1. 1C / Говнокод #25568

    +2

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    Функция ПолучитьСтавкуНДС(СуммаСНДС, НДС)
    	Если НДС = 0  Тогда
    		Возврат Перечисления.СтавкиНДС.БезНДС;
    	ИначеЕсли СуммаСНДС = 0 Тогда //некорректные данные
    		Возврат Перечисления.СтавкиНДС.БезНДС;
    	ИначеЕсли НДС / СуммаСНДС <= 0.152+0.0152 и НДС / СуммаСНДС >= 0.152-0.0152 Тогда
    		Возврат Перечисления.СтавкиНДС.НДС18;
    	ИначеЕсли НДС / СуммаСНДС <= 0.091+0.0091 и НДС / СуммаСНДС >= 0.091-0.0091 Тогда
    		Возврат Перечисления.СтавкиНДС.НДС10;
    	КонецЕсли;
    КонецФункции

    Костыль костыльный

    Запостил: sandvich, 24 Апреля 2019

    Комментарии (31) RSS

    • Функция ПолучитьСтавкуНДС(СуммаСНДС, НДС)
      	
      	СуммаБезНДС = СуммаСНДС - НДС;
      
      	Если СуммаБезНДС > 0 Тогда
      		Ставка = Окр(100 * НДС / СуммаБезНДС);
      
      		Если Ставка = 20 Тогда
      			Возврат Перечисления.СтавкиНДС.НДС20;
      		ИначеЕсли Ставка = 18 Тогда
      			Возврат Перечисления.СтавкиНДС.НДС18;
      		ИначеЕсли Ставка = 10 Тогда
      			Возврат Перечисления.СтавкиНДС.НДС10;
      		ИначеЕсли Ставка = 0 Тогда
      			Возврат Перечисления.СтавкиНДС.НДС0;
      		КонецЕсли;
      	КонецЕсли;
      
      	Возврат Перечисления.СтавкиНДС.БезНДС;
      
      КонецФункции
      Ответить
      • С нулевой ставкой вопрос вообще-то спорный. и обыграть в коде его можно было ещё ранее:
        Если НДС = 0 Тогда Возврат ...БезНДС /.НДС0; КонецЕсли;
        Ответить
      • Переведи на «PHP».
        Ответить
        • PHP не выполняется в среде 1С:Предприятия, которое потребуется для получения ссылочных объектов вида "Перечисление". Перевод данного кода будет обычным "кривлянием".
          Ответить
          • Это доказывает что даже php является языком программирования
            Ответить
            • TOPT, я не понимаю, к чему все эти Ваши разговоры про PHP и Lua. Я не вижу ссылки на конкретную, что-то доказывающую, вещь, сказанную мной.
              Ответить
              • Забей на них. Они пытаются зафорсить пхп как референсный язык, на который нужно переводить все говнокоды.
                Ответить
                • Именно поэтому я за "PHP".
                  Ответить
                  • Видно, ты знаешь толк в извращениях. Давай пошпилимся?
                    Ответить
                    • Зачем ты это сказал... Взял и разрезал... https://media.springernature.com/full/springer-static/image/art%3A10.1186%2F1752-1947-1-14/MediaObjects/13256_2006_Article_14_Fig3_HTML.jpg
                      Ответить
                    • Или как хочешь... Бензопилой? Серной кислотой? Паяльником? Горелкой? Или просто скобозабивателем немного... А ты будешь кричать?
                      Ответить
                • Само существование PHP является говнокодом.
                  Ответить
                  • «PHP» — это первородный грех IT-индустрии. Раньше все программы работали идеально, без багов и зависаний, пользователи понимали, как работают системы, которые они используют, а программисты как сыр в масле катались, ездили в отпуск 11 месяцев в году, зарплаты получали золотыми слитками и акциями компании «Google». А потом появился Архипредатель Расмус Лердорф и создал богомерзкий «PHP». С тех пор всё пошло по пизде, и в какой жопе оказалось — сейчас прекрасно видно. Но самое поганое в том, что в будущем будут изобретены квантовые компьютеры, на которых Безымянное Зло — Второй Предатель — запустит «PHP». И из-за этого — второго — предательства, разлагающее влияние «PHP» распространится и в прошлое, а истинное положение дел будут помнить только немногие Избранные.

                    Покайтесь во грехе!
                    Ответить
                    • Хочешь сказать, что Расмус двинул «PHP» в массы, тем самым сделав программирование более доступным?
                      Ответить
                      • Нет. На самом деле, раньше всё было хорошо потому, что в Законах Мироздания отсутствовала сама концепция «говнокода». Говнокод просто нельзя было написать — он не выражался в терминах существующих концепций. А Архипредатель Расмус изобрёл «PHP», язык, на котором принципиально невозможно написать ничего, кроме говнокода. В результате в Мироздании произошёл системный сбой, из-за которого концепция говнокода спонтанно самозародилась и была прописана на самые основные, базовые уровни Бытия.
                        Ответить
                        • Аминь.
                          Ответить
                          • https://youtu.be/op918vGvCMo
                            Ответить
                            • Приговор, так приговор! Я думаю, что религия достойна наивысшего обвинения, какое только возможно! Это колыбель любых мыслимых извращении, которые когда-либо были или будут возможны. Религия ничего не оставила не испорченным, обесценила все ценности, из истины произвела ложь, из всего честного — попираемое и ненавидимое. Религия — сеть и обман!
                              Ответить
                              • > Религия — сеть
                                Какой топологии?
                                Ответить
                                • Полносвязная
                                  https://i.imgur.com/daKuVzY.png
                                  Ответить
                                  • Это смотря какая религия

                                    Скажем, католичество это однонаправленный граф с папой в корне
                                    Ответить
                                    • Католицизм охуенен, дал нам Коперника и Оккама. А прослабие пиццот лет спустя учит лепить петухов их говна и продавать дьютифри сигареты.
                                      Ответить
                                      • Притом, что католическая церковь официально запретила придерживаться и защищать теории Коперника, а Оккама выступал против папской власти и отрицал светскую власть папы.
                                        Ответить
                                        • Приэтом прослабная церковь пиццот лет спустя тоже оффицально против курения и петухов. Кокая гормония!
                                          https://en.wikipedia.org/wiki/List_of_Catholic_clergy_scientists
                                          Ответить
                                      • > петухов из говна
                                        Реквестирую HABO3Hblu_nemyx
                                        Ответить
                                  • Какой домен!

                                    Надо хосты заменить раутерами, тогда можно присвоить метрики и делать цисколабу
                                    Ответить
                      • сделав хуевое программирование более доступным
                        Ответить

    Добавить комментарий