1. 1C / Говнокод #25664

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    Если ВидОперации = Перечисления.МОЛ_ВидыОперацийПоступленияСырья.Перемещение  Тогда
    		ДоговорКонтрагента = "";
    		ТипЦен = "";
    		Если Сырье.Количество()>0 Тогда
    			Для каждого СтрокаСырье Из Сырье Цикл
    				СтрокаСырье.Цена = 0;
    				СтрокаСырье.Сумма = 0;
    				СтрокаСырье.СуммаНДС = 0;
    			КонецЦикла;	
    		КонецЕсли;	
    			
    	КонецЕсли;

    Добавлена проверка, чтобы цикл вдруг не выполнился при пустой таб части!
    Кстати выполняется при открытии формы и постоянно вызывает модифицированность

    Молокозавод 1.3.121

    Запостил: doom2good, 06 Июня 2019

    Комментарии (25) RSS

    • Кстати когда я жил в одном городе, там был молокозавод вимм билль данн прямо под окном. Можно было всякие дешевые вкусняшки покупать прямо с завода. А потом его выкупил пепси и стало не очень.
      Ответить
    • лол) а без проверки бы сколько раз он выполнился?
      Ответить
      • Это из серии
        if (hui) return true;
        return false;

        Или даже
        if (hui) return true;
        else return false;
        Ответить
        • ну или так
          let foo = ["a", "b", "c"];
          
          if (foo.length > 0) {
              for (let a of foo) {
                  console.warn(a);
              }
          }
          Ответить
          • То ли дело 'J':
            a =: 'a'; 'b'; 'c'
               echo each ^:(0 ~: #a) a
            # —– возвращает длину массива
            ~: —– не равно
            ^: —– возводит глагол в степень, если возвести в степень 0 глагол не выполнится и вернёт свой аргумент
            echo each —– применяет глагол each к каждому элементу массива, предварительно извлекая каждый елемент из коробки, затем результат кладётся в коробку. echo возвращает пустую матрицу, т.е. результат выражения будет массив из 3 пустых коробок.

            Конечно можно просто написать echo each a.
            Ответить
    • Обнаружена уязвимость в Молокозавод 1.3.121. Исправлена в Молокозавод 1.3.122
      Ответить
    • а что это за язык такой ОДИН ЦЕ?
      типа первый из ЦЕ??? це москаль
      Ответить

    Добавить комментарий