1. 1C / Говнокод #27164

    +2

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    &НаКлиенте
    Процедура ИмяФайла_ПроизводственнаяПрограммаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    	ДиалогВыборФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    	ДиалогВыборФайла.Фильтр = "Файлы Microsoft Excel (*.xls, *.xlsx, *.xlsm)|*.xls; *.xlsx; *.xlsm|Все файлы (*.*)|*.*";
    	ДиалогВыборФайла.Показать(Новый ОписаниеОповещения("ИмяФайла_ПроизводственнаяПрограммаНачалоВыбораЗавершение", ЭтотОбъект, Новый Структура("ДиалогВыборФайла,ИмяФайла", ДиалогВыборФайла, Элемент.Имя)));
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ИмяФайла_ПроизводственнаяПрограммаНачалоВыбораЗавершение(ВыбранныеФайлы, ДополнительныеПараметры) Экспорт
        
        ДиалогВыборФайла = ДополнительныеПараметры.ДиалогВыборФайла;
        
        Если (ВыбранныеФайлы <> Неопределено) Тогда
            ЭтаФорма[ДополнительныеПараметры.ИмяФайла] = ДиалогВыборФайла.ПолноеИмяФайла;
        КонецЕсли;
    
    КонецПроцедуры

    Асинхронные вызовы??? Нее.... Не слышал...

    Запостил: nytlenc, 15 Декабря 2020

    Комментарии (30) RSS

    • Достойный конкурент для «PHP».
      Ответить
    • > Новый ОписаниеОповещения
      > Новый Структура

      В "1С" явно не хватает алиасов Новая и Новое для таких случаев... Без них читается как речь какого-то иммигранта.
      Ответить
    • > ПроизводственнаяПрограммаНачалоВыбораЗав ершение
      Шизофрения какая-то, блядь.
      Ответить
      • ...скажет любой англоговорящий, глядя на наши идентификаторы в коде
        Ответить
    • >Новый ОписаниеОповещения
      >Новый Структура

      Слющий, вах Какой Адын Эс )))
      Ответить
      • Хочу язык 1С++, где ключевые слова нужно согласовывать с родом функции и имени класса.

        Новый Питух() //ок
        Новый Группа() //UB
        Новая Группа() //OK
        Новый Кофе()// Имплементейшн дефайнд
        
        Класс Парампарампамю //ошибка: создать такой класс в куче невозможно, так как невозможно определить его род, но можно создать на стеке, в новых версиях и через умные указатели
        Ответить
      • Адин це. Дурилка!
        Ответить
        • «Це» — це украинство якесь. Уроженцы Кавказа так не говорят.
          Ответить
          • Только "українство".
            Ти давно ВНЗ закінчив?
            Ответить
            • >Только
              Тільки, чи нi?
              Ответить
              • Не знаешь куда подевался «inkanus»?
                Ответить
                • не знаю

                  он в жж пишет?
                  Ответить
                  • Не знаю. А есть ссылки?
                    Ответить
                    • тыж мне сам его блох показывал
                      Ответить
                    • надо подумать

                      https://inkanusgray.livejournal.com/
                      Ответить
                      • Он в твиттере активность вёл, но там его забанили, а другой его файки я не знаю.
                        Ответить
                        • неполиткорректный небось

                          на лавнхейте он есть, не?
                          Ответить
                          • МАКАКА, эта песня для тебя

                            https://github.com/sarah-walker-pcem/pcem
                            Ответить
                          • Не в курсе про такой петушатник.
                            А, понял о чем ты.
                            Ответить
                            • Первый раз я услышал про L&H в 2000-м. Второй раз от Инкануса
                              Ответить
                              • Ебать ты олд.
                                Ответить
                                • "Лавхэйт был создан в 1998 году хабаровским программистом-фрилансером Серёжей Ткачуком как визитная карточка и демонстрация своих навыков в perl." (c) лукр

                                  Инканус тоже не молод
                                  Ответить
                                  • > демонстрация своих навыков в perl

                                    Он опенсурсный что ли?
                                    Ответить
                                    • В 1998-м году скорее всего он мог послать .tar.gz с сырцами заинтересованной стороне.

                                      Публичный CVS он вряд-ли стал бы держать, разве что на сурсфорж или фрешмит бы выложился

                                      А почему ты спрашиваешь? Хочешь почитать перл образца 1998-го года?:)
                                      Ответить

    Добавить комментарий