1. Куча / Говнокод #26996

    0

    1. 1
    https://core.telegram.org/constructor/passwordKdfAlgoSHA256SHA256PBKDF2HMACSHA512iter100000SHA256ModPow

    Какой багор )))

    rotoeb, 02 Октября 2020

    Комментарии (1)
  2. 1C / Говнокод #26995

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
    	
    	Если Данные.Свойство("Ссылка") И ЗначениеЗаполнено(Данные.Ссылка) Тогда
    		СтандартнаяОбработка = Ложь;
    		Представление = Данные.Ссылка.Наименование;
    	КонецЕсли; 
    	
    КонецПроцедуры

    У ребят не заладилось с этой процедурой. Смысла в этих действиях 0. Объект справочник.

    NioGoth, 01 Октября 2020

    Комментарии (24)
  3. 1C / Говнокод #26994

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
    	СтандартнаяОбработка=Ложь;
    	Представление="";
    	Для Каждого Стр Из Данные.Ссылка.Состав Цикл
    		Представление=Представление+?(Представление="","",", ")+Стр.Автомобиль;
    		Если СтрДлина(Представление)>50 Тогда 
    			Представление=Представление+"...";
    			Прервать
    		КонецЕсли;
    	КонецЦикла;
    	//Представление=""+Данные.Ссылка.Клиент+" ("+Представление+")";
    КонецПроцедуры

    А чё это списки у нас вдруг тормозить стали?

    NioGoth, 01 Октября 2020

    Комментарии (1)
  4. Си / Говнокод #26993

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    #include <stdio.h>
    
    int main()
    {
        goto a;
        h: printf("W"); goto i;
        g: printf(" "); goto h;
        m: printf("!"); goto n;
        i: printf("o"); goto j;
        n: printf("\n"); goto end;
        b: printf("e"); goto c;
        e: printf("o"); goto f;
        j: printf("r"); goto k;
        d: printf("l"); goto e;
        f: printf(","); goto g;
        a: printf("H"); goto b;
        k: printf("l"); goto l;
        l: printf("d"); goto m;
        c: printf("l"); goto d;
        end: ;
        
        return 0;
    }

    GDMaster, 01 Октября 2020

    Комментарии (39)
  5. JavaScript / Говнокод #26992

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    const breakpointChecker = function() {
        if ( breakpoint.matches === true ) {
            //...
            return;
        } else if ( breakpoint.matches === false ) {
            //...
        }
    };

    Источник: https://medium.com/@networkaaron/swiper-how-to-destroy-swiper-on-min-width-breakpoints-a947491ddec8

    denistrator, 01 Октября 2020

    Комментарии (5)
  6. Java / Говнокод #26991

    +1

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    9. 9
    public static <T> Comparator<T> reverseOrder(Comparator<T> cmp) {
        if (cmp == null)
            return reverseOrder();
    
        if (cmp instanceof ReverseComparator2)
            return ((ReverseComparator2<T>)cmp).cmp;
    
        return new ReverseComparator2<>(cmp);
    }

    кишки стандартной библиотеки йажи продолжают радовать, хорошо хоть нет ReverseComparatorFinal или ReverseComparatorBassBoostedByKirillXXL

    Fike, 30 Сентября 2020

    Комментарии (8)
  7. C# / Говнокод #26990

    −1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    47. 47
    48. 48
    49. 49
    50. 50
    51. 51
    52. 52
    53. 53
    54. 54
    55. 55
    56. 56
    57. 57
    58. 58
    59. 59
    60. 60
    61. 61
    62. 62
    using System;
    
    namespace c_2
    {
        class Program
        {
            static void Main(string[] args)
            {
            start: 
            Console.WriteLine("введите первое число");
            var a = Convert.ToDouble(Console.ReadLine());;
            Console.WriteLine("введите второе число");
            var b = Convert.ToDouble(Console.ReadLine());;
            Console.WriteLine("Введите действие(+ - * /)");
            string act=Console.ReadLine();
            if (act == "+") 
            {
                Console.WriteLine(a+b);
            } 
            else
            {
                if (act == "-")
                {
                    Console.WriteLine(a - b); 
                }
                else
                {
                    if(act=="*")
                    {
                        Console.WriteLine(a*b);
                    }
                    else
                    {
                        if (act == "/")
                        {
                            Console.WriteLine(a/b); 
                        }
                    }
            }
            Console.WriteLine("Выйти?(y/n)");
            string exit = Console.ReadLine();
            if (exit == "y" )
            {
                Environment.Exit(0);
    
            }
            else
            {
                if (exit == "n")
                {
                    goto start;
                }
                
                {
                    
                }
            }
            }
            }
            
        }
    }

    Калькулятор(моя первая прога на шарпе)

    abrewbrew, 30 Сентября 2020

    Комментарии (26)
  8. PHP / Говнокод #26989

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    $userId = getUser(); //получаем список всех пользователей 
    
        $valueArray = array(); 
        $keyArray = array(); 
        $valueArray1 = array();
        $keyArray1 = array();
        $resultArray = array();
        $resultArray1 = array();
        for($i=0;$i<count($userId);$i++){
            array_push($valueArray,$userId[$i]['user_id']);
            array_push($keyArray,$userId[$i]['status']);
        }
        for ($i = 0; $i<count($keyArray); $i++) {
            $resultArray[$valueArray[$i]] = $keyArray[$i];
        }
        for($i=0;$i<count($userId);$i++){
            array_push($valueArray1,$userId[$i]['user_id']);
            array_push($keyArray1,$userId[$i]['active']);
        }
        for ($i = 0; $i<count($keyArray1); $i++) {
            $resultArray1[$valueArray1[$i]] = $keyArray1[$i];
        }
        $array = array();
        foreach ($resultArray as $key => $value){
            if($value==="finish"){
                if($resultArray1[$key]==='Y'){
                    array_push($array,$key);
                }
            }
        }

    Получаем массив пользователей у которых завершен звонок.

    Антон, 30 Сентября 2020

    Комментарии (5)
  9. C++ / Говнокод #26988

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    9. 9
    class std::unordered_map<class std::basic_string<char,struct std::char_traits<char>,class std::allocator<char> >,
    enum REG,struct std::hash<class std::basic_string<char,struct std::char_traits<char>,class std::allocator<char> > >,
    struct std::equal_to<class std::basic_string<char,struct std::char_traits<char>,class std::allocator<char> > >,
    class std::allocator<struct std::pair<class std::basic_string<char,struct std::char_traits<char>,
    class std::allocator<char> > const ,enum REG> > > registers" 
    ([email protected]@[email protected][email protected][email protected]@[email protected]@[email protected]@[email protected]@[email protected]@[email protected]@[email protected]?$
    [email protected][email protected]@[email protected]@[email protected]@[email protected]@[email protected]@@[email protected][email protected][email protected][email protected]@[email protected]@V?
    [email protected]@[email protected]@[email protected]@@[email protected][email protected][email protected][email protected][email protected]@[email protected]@[email protected]@[email protected]@[email protected]@W4
    [email protected]@@[email protected]@@[email protected]@[email protected]@A) уже определен в decoder.obj	PVC-16	C:\Users\Люда\source\repos\PVC-16\PVC-16\interrupt.obj	1

    Похлопаем visual c++ за понятный лог.

    digitalEugene, 30 Сентября 2020

    Комментарии (58)
  10. Куча / Говнокод #26987

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    Я вот смотрю на Ричарда Столлмана... Вижу, как он всю жизнь рвёт на себе жопчик за халявное ПО...
    И думаю: а что сделал ОН? Он написал "Photoshop"? Создал "Windows"? Разработал хоть что-то?
    Знает ли он, что такое многочасовой, многодневный, многомесячный, а иногда и многолетний труд разработки?
    Всё его достижение - это ТЕКСТ лицензии "GNU". Всё.
    В чём смысл Ричарда Столлмана?

    И, кстати, нахуй вообще нужны лицензии на халявное ПО?

    rotoeb, 30 Сентября 2020

    Комментарии (13)