1. Список говнокодов пользователя doom2good

    Всего: 7

  2. 1C / Говнокод #25664

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    Если ВидОперации = Перечисления.МОЛ_ВидыОперацийПоступленияСырья.Перемещение  Тогда
    		ДоговорКонтрагента = "";
    		ТипЦен = "";
    		Если Сырье.Количество()>0 Тогда
    			Для каждого СтрокаСырье Из Сырье Цикл
    				СтрокаСырье.Цена = 0;
    				СтрокаСырье.Сумма = 0;
    				СтрокаСырье.СуммаНДС = 0;
    			КонецЦикла;	
    		КонецЕсли;	
    			
    	КонецЕсли;

    Добавлена проверка, чтобы цикл вдруг не выполнился при пустой таб части!
    Кстати выполняется при открытии формы и постоянно вызывает модифицированность

    Молокозавод 1.3.121

    doom2good, 06 Июня 2019

    Комментарии (25)
  3. 1C / Говнокод #17669

    −119

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    Процедура ДействияФормыДействие5(Кнопка)
    	
    	ТекущиеДанные = ЭлементыФормы.СправочникСписок.ТекущиеДанные;
    	Если ТекущиеДанные = Неопределено Тогда 
    		Возврат;
    	КонецЕсли;
    	
    	ТекПометкаУдаления = ТекущиеДанные.Ссылка.ПометкаУдаления;
    	
    	КонтрагентОбъект = ТекущиеДанные.Ссылка.ПолучитьОбъект();
    	КонтрагентОбъект.ПометкаУдаления = Не ТекПометкаУдаления;
    	Попытка
    		КонтрагентОбъект.записать();
    	Исключение 
    		Сообщить("Не удалось " + ?(ТекПометкаУдаления, "снять", "установить") + " пометку удаления.");
    	КонецПопытки;	
    	
    КонецПроцедуры

    На форме списка справочника "Контрагенты" добавлена кнопка со значком "непосредственное удаление". А это её обработчик.
    НАХРЕНА???

    doom2good, 20 Февраля 2015

    Комментарии (4)
  4. 1C / Говнокод #16570

    −158

    1. 1
    2. 2
    3. 3
    4. 4
    Если Переменная1 <> 0 Тогда
    Иначе
       Переменная1 = 0;
    КонецЕсли;

    Пять минут пытался убедить нашу "программистку" с десятилетним стажем, что этот высер ничего не делает! Сошлись на том, что она "всё таки удалит его, но если появятся ошибки - она здесь не при чем"!
    Этот кусок я бы и не заметил, если бы не бросился в глаза пустой блок "Тогда" при использовании блока "Иначе"

    doom2good, 20 Августа 2014

    Комментарии (66)
  5. 1C / Говнокод #13518

    −172

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    Наименование=Выборка.Наименование;
    АдресМестонахождения=Выборка.АдресМестонахождения;
    ВнешнийОбъект=Выборка.ВнешнийОбъект;
    ДатаВводаВЭксплуатацию=Выборка.ДатаВводаВЭксплуатацию;
    ДатаВыпуска=Выборка.ДатаВыпуска;
    ДоговорКонтрагента=Выборка.ДоговорКонтрагента;
    ЗаводскойНомер=Выборка.ЗаводскойНомер;
    Изготовитель=Выборка.Изготовитель;
    ИнвентарныйНомер=Выборка.ИнвентарныйНомер;
    КодРегиона=Выборка.КодРегиона;
    КодПоОКОФ=Выборка.КодПоОКОФ;
    Комментарий=Выборка.Комментарий;
    Контрагент=Выборка.Контрагент;
    КонтрагентИсполнительРемонта=Выборка.КонтрагентИсполнительРемонта;
    НомерПаспорта=Выборка.НомерПаспорта;
    ОбъектОсновныхСредств=Выборка.ОбъектОсновныхСредств;
    Организация=Выборка.Организация;
    ПлановыйГрафикРаботы=Выборка.ПлановыйГрафикРаботы;
    Подразделение=Выборка.Подразделение;
    ПодразделениеИсполнительРемонта=Выборка.ПодразделениеИсполнительРемонта;
    Приоритет=Выборка.Приоритет;
    РемонтнаяГруппа=Выборка.РемонтнаяГруппа;
    СрокПолезногоИспользования=Выборка.СрокПолезногоИспользования;
    ТехНомер=Выборка.ТехНомер;
    ТипОборудования=Выборка.ТипОборудования;
    ЭтоГруппаОбъектов=Выборка.ЭтоГруппаОбъектов;

    "Архитектор" явно не был знаком с методом ЗаполнитьЗначенияСвойств()

    doom2good, 31 Июля 2013

    Комментарии (10)
  6. 1C / Говнокод #13437

    −174

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    Стр = ТЗОбщая.Добавить();
    Стр.сотрудник = Выборка.сотрудник;
    Стр.Результат = ВЫборка.Результат;
    ИскомаяСтрока = ТЗСотрДатаПриема.Найти(Стр.сотрудник,"Сотрудник");
    Если ИскомаяСтрока <> Неопределено Тогда
    	месяц_ = Месяц(ИскомаяСтрока.ДатаПриемаНаРаботу);
    	если месяц_ > 7 тогда  // чел принят после июля
    		число_ = 12 - месяц_;  //кол-во отработанных месяцев
    	иначе	  
    		число_ = 6 ; 
    	конецесли;	  
    КонецЕсли;	
    число_ = число_+ Месяц(ВыбДата) ;
    если число_ >=12 тогда
    	число_=12;
    конецесли;	 
    Стр.СреднийЗаработок = Окр(ВЫборка.Результат/29.4/число_,2);

    Вот так у нас считают средний заработок за последний год)))

    doom2good, 17 Июля 2013

    Комментарии (10)
  7. 1C / Говнокод #13436

    −126

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    Функция ЗначениеСвойства(Объект, ИмяСвойства) Экспорт
    	
    	Возврат Объект[ИмяСвойства]
    	
    КонецФункции

    Пипец полезная функция!

    doom2good, 17 Июля 2013

    Комментарии (30)
  8. 1C / Говнокод #12987

    −167

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    МассивКоэффициентов = Новый Структура;
    -------------------------------------------------------------------------------------------------------
    Если Элемент.Имя = "КнопкаПерсонал" тогда
    	СписокВидоврасчета = 1;
    иначе
    	СписокВидоврасчета = 2;
    конецЕсли;

    "Принцип наименьшего удивления" при выборе имен переменных в работе

    doom2good, 13 Мая 2013

    Комментарии (4)