1. 1C / Говнокод #23244

    +3

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    Если Отладка Тогда
    				ЗаписьXML.ЗаписатьТекст(СокрЛП(КодИнтернетЗаказа));
    			Иначе
    				ЗаписьXML.ЗаписатьТекст(СокрЛП(КодИнтернетЗаказа));
    			КонецЕсли;

    Безысходность. Судьба предрешена. Бедный Йорик.

    M1CE, 08 Августа 2017

    Комментарии (1)
  2. 1C / Говнокод #23234

    +1

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    Если ЭтоНовыйОбъект Тогда
    		Если Найти(НРег(ЭтотОбъект.ТекстЗаявки),"принтер") > 0 Тогда
    			ЭтотОбъект.ВидОбращения = Справочники.ИТ_ПричинаОбращения.НайтиПоНаименованию("Принтер");
    		КонецЕсли;
    	КонецЕсли;

    Если в тексте заявки есть "принтер", значит это по принтеру, если в тексте "Замените картридж" - peaceDa рулю.

    M1CE, 02 Августа 2017

    Комментарии (1)
  3. 1C / Говнокод #23173

    +2

    1. 1
    2. 2
    3. 3
    4. 4
    defmodule Utils.String do
      @moduledoc false
      def comma_split(str), do: String.split(str, " ", trim: true)
    end

    AndrewDryga, 10 Июля 2017

    Комментарии (7)
  4. 1C / Говнокод #23081

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    //Модуль основной формы внешней обработки
    
    &НаКлиенте
    Процедура ПродатьСлона(Оферта)
    	
    	Перем Акцепт;
    	
    	Если ПустаяСтрока(Оферта) Тогда
    		
    		Оферта = "Купи слона!";
    		
    	Иначе
    		
    		Оферта = "Все говорят """+Оферта+""" а ты купи слона!";
    		
    	КонецЕсли;	
    		
    	ВвестиСтроку(Акцепт,Оферта,0, Истина); 	
    		
        ПродатьСлона(Акцепт);
    	
    КонецПроцедуры	
    
    &НаКлиенте
    Процедура ПриОткрытии(Отказ)
    	
    	ПродатьСлона("");
    	
    КонецПроцедуры

    Продаём слона!

    informatikmarazmatik, 30 Мая 2017

    Комментарии (9)
  5. 1C / Говнокод #23071

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    Попытка
               ЗаблокироватьДанныеФормыДляРедактирования();
    Исключение
               ВызватьИсключение КраткоеОписаниеОшибки(ОписаниеОшибки());
    КонецПопытки

    Процедура ЗаблокироватьДанныеФормыДляРедактировани я() при невозможности заблокировать данные сама вызывает исключение

    acula98, 26 Мая 2017

    Комментарии (3)
  6. 1C / Говнокод #23056

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    рсДополнительныеСведения = РегистрыСведений.ДополнительныеСведения.СоздатьНаборЗаписей();
    СвойствоУведомление = рсДополнительныеСведения.Добавить();
    СвойствоУведомление.Объект = ЭтотОбъект.Ссылка;
    СвойствоУведомление.Свойство = ДопСведение;
    СвойствоУведомление.Значение = Истина;
    рсДополнительныеСведения.Записать();

    Код одних франчей.
    причем все ж по ТЗ)) запись записалась? записалась! И побоку, что остальные записи при этом снесли нах)))

    Moonlight, 22 Мая 2017

    Комментарии (1)
  7. 1C / Говнокод #22905

    −263

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    Ответ = Вопрос("Будет запущена процедура создания договоров и печати документов. Продолжить?",
              РежимДиалогаВопрос.ДаНет, 60, КодВозвратаДиалога.Да, ЗаголовокОкнаПредупреждения);
        
    Если НЕ Ответ = КодВозвратаДиалога.Да Тогда
             Возврат;
    КонецЕсли;

    wezug, 05 Мая 2017

    Комментарии (2)
  8. 1C / Говнокод #22823

    −10

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    Функция РазностьДатВДнях(Дата1, Дата2, ВключаяГраницы = Истина)
    	
    	Результат = ?(ВключаяГраницы, 1, 0);
    	Если Дата1 < Дата2 Тогда
    		ТекущаяДата = НачалоДня(Дата1);
    		ДатаОкончания = НачалоДня(Дата2);
    	Иначе
    		ТекущаяДата = НачалоДня(Дата2);
    		ДатаОкончания = НачалоДня(Дата1);
    	КонецЕсли;
    	Пока ТекущаяДата < ДатаОкончания Цикл
    		ТекущаяДата = НачалоДня(ТекущаяДата + 24 * 60 * 60);
    		Результат = Результат + 1;
    	КонецЦикла;
    	Возврат Результат;
    
    КонецФункции

    можно тремя строками заменить:
    ДатаНачала = Мин(НачалоДня(Дата1), НачалоДня(Дата2));
    ДатаОкончания = Макс(НачалоДня(Дата1), НачалоДня(Дата2));
    Возврат ?(ВключаяГраницы, 1, 0) + (ДатаОкончания - ДатаНачала) / 86400

    noncode, 17 Апреля 2017

    Комментарии (1)
  9. 1C / Говнокод #22734

    −99

    1. 1
    2. 2
    Если НоменклатураКонтрагентов.Наличие=Перечисления.ДаНет.Да тогда
    ....

    Создан новый элемент перечисления "ДаНет" на который ссылается измерение регистра сведений. Джордж Буль продолжает медленно крутиться...

    FesenkoA, 03 Апреля 2017

    Комментарии (5)
  10. 1C / Говнокод #22715

    −99

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    Процедура ДвиженияПоРегистрамНесортированнаяПродукция(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоПродукции, Отказ, Заголовок);
    
    	Если Не Отказ Тогда
    
    		Запрос = Новый Запрос;
    		Запрос.Текст = 
    			"ВЫБРАТЬ
    			|	ОтчетПроизводстваЗаСменуПродукция.Количество КАК Количество,
    			|	ОтчетПроизводстваЗаСменуПродукция.Номенклатура,
    			|	ОтчетПроизводстваЗаСменуПродукция.ХарактеристикаНоменклатуры
    			|ИЗ
    			|	Документ.ОтчетПроизводстваЗаСмену.Продукция КАК ОтчетПроизводстваЗаСменуПродукция
    			|ГДЕ
    			|	ОтчетПроизводстваЗаСменуПродукция.Ссылка = &Ссылка
    			|	И ОтчетПроизводстваЗаСменуПродукция.Номенклатура.АС_УчетНесортированнойПродукции = &ФлагДа";
    
    		Запрос.УстановитьПараметр("ФлагДа", Истина);
    		Запрос.УстановитьПараметр("Ссылка", Ссылка);
    
    		Результат = Запрос.Выполнить().Выгрузить();
    
    		НаборДвижений = Движения.АС_НесортированнаяПродукцияНаСкладах;
    		Если Результат.Количество()>0 Тогда
    			Для Каждого Стр ИЗ Результат Цикл
    				НоваяСтрока = НаборДвижений.Добавить();
    				НоваяСтрока.ВидДвижения = ВидДвиженияНакопления.Приход;
    				ЗаполнитьЗначенияСвойств(НоваяСтрока,Стр);
    				НоваяСтрока.Период = Дата;
    				НоваяСтрока.Регистратор = Ссылка;
    			КонецЦикла;
    		КонецЕсли;	
    	КонецЕсли;
    	
    КонецПроцедуры

    Нужно больше параметров! Иначе ты не адинэсник, а полное ничтожество. (Это не результат легаси, там реально скопипащено ПЯТЬ процедур с одинаковыми параметрами, из которых используется только "Отказ", да и то как видим - через заднепроходное отверстие)

    Old_Chroft, 31 Марта 2017

    Комментарии (3)