1. 1C / Говнокод #25236

    0

    1. 1
    Сумма = Цел(Окр(Сумма * 1000, 0, 1)) / 1000;

    Или я мандаринов переел, или от этого портал должен открыться

    valchara, 27 Декабря 2018

    Комментарии (42)
  2. 1C / Говнокод #25211

    +2

    1. 1
    2. 2
    3. 3
    4. 4
    СообщениеСМС = Перечисления.СостоянияСообщенияSMS.Исходящее;
    		Для каждого СообщениеСМС Из СообщениеSMS.Услуги Цикл
    			СообщениеСМС.СостояниеСообщения = Перечисления.СостоянияСообщенияSMS.Исходящее;
    		КонецЦикла;

    1С:Медицина. Поликлинка

    gk-5ccd112a, 21 Декабря 2018

    Комментарии (4)
  3. 1C / Говнокод #25210

    +2

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    ТекЧас = Строка(Час(Дата2));
    ТекЧас = Прав("00" + ТекЧас, 2);
    ТекМин = Строка(Минута(Дата2));
    ТекМин = Прав("00" + ТекМин, 2);
    ТекВремя = ТекЧас + ":" + ТекМин;

    Это способ получить время в формате "чч:мм" из даты и времени (переменная Дата2).
    Заменяется этим:
    ТекВремя = Формат(Дата2, "ДФ=hh:mm");

    VladC, 21 Декабря 2018

    Комментарии (4)
  4. 1C / Говнокод #25178

    −5

    1. 1
    EFG тред иди.

    Тред в котором мы пишим реквесты и пожелания EFG.
    EFG, прикрути живое обновление через вебсокеты, переделай фронт уже с этого древнего говна, на модное SPA, прикрути нейросеточку и блокчейн.

    хуита, 11 Декабря 2018

    Комментарии (24)
  5. 1C / Говнокод #25164

    −1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    	//...
    	Если НЕ Отказ Тогда
    		
    		ЭтотОбъект.ОбменДанными.Загрузка = Истина;
    		ЭтотОбъект.Записать();
    		ЭтотОбъект.ОбменДанными.Загрузка = Ложь;
    		//...
    	КонецЕсли; 	
    	
    КонецПроцедуры // ПередЗаписью

    БУдУ, УТПдУ, УППдУ
    Бля, ну как так можно? Что за идиот это писал?
    Сначала Пактум от школьника, теперь эта херь...

    Asaharu, 07 Декабря 2018

    Комментарии (6)
  6. 1C / Говнокод #25161

    −1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    процедура расш_таблицаприактивациистроки(элемент)
    простодеревозначений = новый деревозначений;
    простодеревозначений.очистить();
    конецпроцедуры
    //впадает в рекурсию и программа умирает
    
    процедура расш_таблицаприактивациистроки_(элемент)
    простодеревозначений = новый таблицазначений;
    простодеревозначений.очистить();
    конецпроцедуры
    //не впадает в рекурсию

    Чо поцоны, изи рекурсия. УТ 11. Насчет других не тестил.
    При активации строки ТЧ, срабатывает эта процедура. Создаю новое дерево значений, и при его очистки вызывается какой-то общий модуль который я не звал и начинает активировать всю форму - охуенно. соответственно вызывается эта процедура пофторно. При ТЗ такой хуйни нет.

    3oJIoTou_xyu, 06 Декабря 2018

    Комментарии (6)
  7. 1C / Говнокод #25096

    −3

    1. 1
    2. 2
    ТекстОшибки = НСтр("ru='Клиенту ""%Партнер%"" запрещена отгрузка.'");
    ТекстОшибки = СтрЗаменить(ТекстОшибки, "%Партнер%", Партнер);

    Когда платят за количество строчек, а не смысл. Ебала жаба гадюку просто.

    ChoaNyan, 19 Ноября 2018

    Комментарии (1)
  8. 1C / Говнокод #25093

    +1

    1. 1
    Выб = выбратьизсписка(элемент.списоквыбора,элемент);

    СИДЕЛ НАД ЭТОЙ ХУЕТОЙ ДЖВА ЧАСА, И НЕ ПОНИМАЛ ПОЧЕМУ ЭТОТ КУСОК НЕОТРАБАТЫВАЛ И ВОЗВРАЩАЛ НЕОПРЕДЕЛЕНО И СРАЗУ ЖЕ ПРОСКАКИВАЛ ДАЛЬШЕ. ХОТЯ ЭЛЕМЕНТ И СПИСОК ЕСТЬ, ПОИДЕИ ДОЛЖЕН БЫЛ ПОВЫСНУТЬ В ОЖИДАНИИ ПОКА ПОЛЬЗОВАТЕЛЬ ВЫБЕРЕТ ИЗ НЕГО ЗНАЧЕНИЕ.

    ОКАЗАЛОСЬ. ОТЛАДЧИК... РЕШИЛ ВЫЗЫВАТЬ САМ СЕБЕ ЭТОТ СПИСОК И САМ ПО СЕБЕ НИХУЯ НЕ ВЫБИРАТЬ.

    TOPT, 19 Ноября 2018

    Комментарии (8)
  9. 1C / Говнокод #25089

    −1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    Функция ПолучитьСтавкуНДС(СтавкаНДС) Экспорт
    
    	Если СтавкаНДС = Перечисления.СтавкиНДС.НДС20 ИЛИ СтавкаНДС = Перечисления.СтавкиНДС.НДС20_120 Тогда
    		Возврат 20;
    	ИначеЕсли СтавкаНДС = Перечисления.СтавкиНДС.НДС10 ИЛИ СтавкаНДС = Перечисления.СтавкиНДС.НДС10_110 Тогда
    		Возврат 10;
    	ИначеЕсли СтавкаНДС = Перечисления.СтавкиНДС.НДС18 ИЛИ СтавкаНДС = Перечисления.СтавкиНДС.НДС18_118 Тогда
    		Возврат 18;
    	КонецЕсли;
    
    	Возврат 0;
    
    КонецФункции

    Банально.
    Рарус.

    3oJIoTou_xyu, 16 Ноября 2018

    Комментарии (61)
  10. 1C / Говнокод #24935

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    Писал значит обмен ну там по http запросами и прочим говном на 1С между сайтом на битриксе и самой базой.
    Сидел и думал, каким форматом обмениваться
    Эти ссаные phpшники из центральной россии предлагали JSON и CSV.
    А я подумал, и подумал что не хочу слишком банально. Написал сериализацию с 1С в lua, и обмениваюсь lua.
    эти phpшные хуйни в шоке, ведь у них нет такого десериализатора. Жду от них результата уже джва года.

    ух какой я злодей.

    3oJIoTou_xyu, 18 Октября 2018

    Комментарии (32)