1. Java / Говнокод #24245

    +3

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    9. 9
    public static Date round(Date d) {
        try {
            SimpleDateFormat sdf = new SimpleDateFormat("ddMMyyyy");
            return sdf.parse(sdf.format(d));
        } catch (ParseException ex) {
            //This exception will never be thrown, because sdf parses what it formats
            return d;
        }
    }

    Простейший коробочный способ округления даты до дня.

    3.14159265, 10 Мая 2018

    Комментарии (9)
  2. SQL / Говнокод #24243

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    select
      x1.airport, x1.amount, x1.exempt
    from
      Taxes x1
    where
      x1.code = 'departure'
      and x1.airport in (
        select
          xx1.airport
        from
          (select
            yx1.airport
          from
            Taxes yx1
          where
            yx1.airport = x1.airport
            and yx1.code = x1.code
          group by
            yx1.airport, yx1.amount, yx1.exempt
          ) xx1
        group by xx1.airport
        having count(xx1.airport) > 1
      )
    ;

    Давно я не копался в SQL. Вот что нагородил :(

    Суть такова: у аэропортов есть departure tax, который может быть разный в зависимости от некоторых критериев (нерелевантно каких).
    А может быть и одинаковый. Но все равно аэропорт может иметь несколько рядков в БД (с одинаковым amount). А еще может быть exempt = 'X',
    что тождественно amount = 0.

    Задача: выбрать все рядки с departure tax для аэропортов у которых taxamt/exempt разный в зависимости от некоторых других критериев.

    Elvenfighter, 10 Мая 2018

    Комментарии (11)
  3. C++ / Говнокод #24241

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    https://github.com/dotnet/coreclr/blob/a589e3926a1780256fdb52376f8681fe047daf54/src/vm/i386/cgenx86.cpp#L1551-L1553
    
        PAL_TRY(Param *, pParam, &param)
        {
            unsigned char buffer[16];
            DWORD* dwBuffer = NULL;
    
            DWORD maxCpuId = getcpuid(0, buffer);
    
            if (maxCpuId < 1)
                goto lDone;
    
            dwBuffer = (DWORD*)buffer;
    
            if (dwBuffer[1] == 'uneG') {
                if (dwBuffer[3] == 'Ieni') {
                    if (dwBuffer[2] == 'letn')  {  // get SMT/multicore enumeration for Intel EM64T

    С каких пор в одинарные кавычки можно писать больше одного символа? Это какое-то MSVC или что?

    j123123, 09 Мая 2018

    Комментарии (232)
  4. 1C / Говнокод #24240

    +2

    1. 001
    2. 002
    3. 003
    4. 004
    5. 005
    6. 006
    7. 007
    8. 008
    9. 009
    10. 010
    11. 011
    12. 012
    13. 013
    14. 014
    15. 015
    16. 016
    17. 017
    18. 018
    19. 019
    20. 020
    21. 021
    22. 022
    23. 023
    24. 024
    25. 025
    26. 026
    27. 027
    28. 028
    29. 029
    30. 030
    31. 031
    32. 032
    33. 033
    34. 034
    35. 035
    36. 036
    37. 037
    38. 038
    39. 039
    40. 040
    41. 041
    42. 042
    43. 043
    44. 044
    45. 045
    46. 046
    47. 047
    48. 048
    49. 049
    50. 050
    51. 051
    52. 052
    53. 053
    54. 054
    55. 055
    56. 056
    57. 057
    58. 058
    59. 059
    60. 060
    61. 061
    62. 062
    63. 063
    64. 064
    65. 065
    66. 066
    67. 067
    68. 068
    69. 069
    70. 070
    71. 071
    72. 072
    73. 073
    74. 074
    75. 075
    76. 076
    77. 077
    78. 078
    79. 079
    80. 080
    81. 081
    82. 082
    83. 083
    84. 084
    85. 085
    86. 086
    87. 087
    88. 088
    89. 089
    90. 090
    91. 091
    92. 092
    93. 093
    94. 094
    95. 095
    96. 096
    97. 097
    98. 098
    99. 099
    100. 100
    Функция СоздатьМассив // Экспорт, 29 параметров
    (
    	Значение01 = '05710422152926',
    	Значение02 = '05710422152926',
    	Значение03 = '05710422152926',
    	Значение04 = '05710422152926',
    	Значение05 = '05710422152926',
    	Значение06 = '05710422152926',
    	Значение07 = '05710422152926',
    	Значение08 = '05710422152926',
    	Значение09 = '05710422152926',
    	Значение10 = '05710422152926',
    	Значение11 = '05710422152926',
    	Значение12 = '05710422152926',
    	Значение13 = '05710422152926',
    	Значение14 = '05710422152926',
    	Значение15 = '05710422152926',
    	Значение16 = '05710422152926',
    	Значение17 = '05710422152926',
    	Значение18 = '05710422152926',
    	Значение19 = '05710422152926',
    	Значение20 = '05710422152926',
    	Значение21 = '05710422152926',
    	Значение22 = '05710422152926',
    	Значение23 = '05710422152926',
    	Значение24 = '05710422152926',
    	Значение25 = '05710422152926',
    	Значение26 = '05710422152926',
    	Значение27 = '05710422152926',
    	Значение28 = '05710422152926',
    	Значение29 = '05710422152926'
    )
    Экспорт
    	
    	Нил_ = '05710422152926'; // Предположительная дата рождения пророка Мухаммеда
    	
    	Если Нил_ = Значение02 Тогда
    		Если Нил_ = Значение01 Тогда
    			Массив_ = Новый Массив;
    			Перейти ~Метка00;
    		Иначе
    			Массив_ = Новый Массив(1);
    			Перейти ~Метка01;
    		КонецЕсли;
    	ИначеЕсли Нил_ = Значение06 Тогда
    		Если Нил_ = Значение04 Тогда
    			Если Нил_ = Значение03 Тогда
    				Массив_ = Новый Массив(2);
    				Перейти ~Метка02;
    			Иначе
    				Массив_ = Новый Массив(3);
    				Перейти ~Метка03;
    			КонецЕсли;
    		ИначеЕсли Нил_ = Значение05 Тогда
    			Массив_ = Новый Массив(4);
    			Перейти ~Метка04;
    		Иначе
    			Массив_ = Новый Массив(5);
    			Перейти ~Метка05;
    		КонецЕсли;
    	ИначеЕсли Нил_ = Значение14 Тогда
    		Если Нил_ = Значение10 Тогда
    			Если Нил_ = Значение08 Тогда
    				Если Нил_ = Значение07 Тогда
    					Массив_ = Новый Массив(6);
    					Перейти ~Метка06;
    				Иначе
    					Массив_ = Новый Массив(7);
    					Перейти ~Метка07;
    				КонецЕсли;
    			ИначеЕсли Нил_ = Значение09 Тогда
    				Массив_ = Новый Массив(8);
    				Перейти ~Метка08;
    			Иначе
    				Массив_ = Новый Массив(9);
    				Перейти ~Метка09;
    			КонецЕсли;
    		ИначеЕсли Нил_ = Значение12 Тогда
    			Если Нил_ = Значение11 Тогда
    				Массив_ = Новый Массив(10);
    				Перейти ~Метка10;
    			Иначе
    				Массив_ = Новый Массив(11);
    				Перейти ~Метка11;
    			КонецЕсли;
    		ИначеЕсли Нил_ = Значение13 Тогда
    			Массив_ = Новый Массив(12);
    			Перейти ~Метка12;
    		Иначе
    			Массив_ = Новый Массив(13);
    			Перейти ~Метка13;
    		КонецЕсли;
    	ИначеЕсли Нил_ = Значение22 Тогда
    		Если Нил_ = Значение18 Тогда
    			Если Нил_ = Значение16 Тогда
    				Если Нил_ = Значение15 Тогда
    					Массив_ = Новый Массив(14);
    					Перейти ~Метка14;
    				Иначе
    					Массив_ = Новый Массив(15);

    1С Медицина: Больничные
    Халяль

    elizir, 09 Мая 2018

    Комментарии (6)
  5. C# / Говнокод #24237

    −1

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    public override bool IsViewFromObject(View view, Java.Lang.Object @object)
    		{
    			// actually... i don't know
    			return true;
    		}

    Прод код одного ведро-приложения, адаптер к листалке

    cherepets, 09 Мая 2018

    Комментарии (0)
  6. C++ / Говнокод #24235

    −1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    // https://github.com/dotnet/coreclr/blob/a589e3926a1780256fdb52376f8681fe047daf54/src/vm/binder.cpp#L503-L511
    
    const MscorlibBinder::OffsetAndSizeCheck MscorlibBinder::OffsetsAndSizes[] =
    {
        #define DEFINE_CLASS_U(nameSpace, stringName, unmanagedType) \
            { PTR_CSTR((TADDR) g_ ## nameSpace ## NS ), PTR_CUTF8((TADDR) # stringName), sizeof(unmanagedType), 0, 0, 0 },
        
        #define DEFINE_FIELD_U(stringName, unmanagedContainingType, unmanagedOffset) \
            { 0, 0, 0, PTR_CUTF8((TADDR) # stringName), offsetof(unmanagedContainingType, unmanagedOffset), sizeof(((unmanagedContainingType*)1)->unmanagedOffset) },
        #include "mscorlib.h"
    };

    Дух старой школы всё еще живет в майкрософт

    j123123, 08 Мая 2018

    Комментарии (8)
  7. Pascal / Говнокод #24233

    −1

    1. 1
    2. 2
    3. 3
    Стертор, ты вообще пишешь полезный код (хотя бы на Delphi) или
    занимаешься только тем, что постишь на говнокод советы по 
    использованию камерунских пенисов на основании своего личного опыта?

    dm_fomenok, 07 Мая 2018

    Комментарии (67)
  8. C++ / Говнокод #24232

    −1

    1. 1
    2. 2
    3. 3
    j123123, ты вообще пишешь полезный код или занимаешься 
    только тем, что постишь на говнокод советы космического масштаба
    и комической же глупости о том, как всё оптимизировать?

    dm_fomenok, 07 Мая 2018

    Комментарии (11)
  9. bash / Говнокод #24231

    +1

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    ...
    # uncomment for a colored prompt, if the terminal has the capability; turned
    # off by default to not distract the user: the focus in a terminal window
    # should be on the output of commands, not on the prompt
    #force_color_prompt=yes
    ...

    .bashrc по умолчанию в Xubuntu.
    Мне казалось, что приглашение должно быть другого цвета, чтобы можно было быстро найти начало вывода программы:
    [email protected]:~$ cat blah.txt
    <много текста>
    <много текста>
    <много текста>
    <много текста>
    <много текста>

    Но тут, понимаешь, решили, что нечего цвета разводить.

    Steve_Brown, 06 Мая 2018

    Комментарии (22)
  10. Куча / Говнокод #24228

    −2

    1. 1
    2. 2
    Золотце
    https://lj.rossia.org/users/sadkov/103320.html?nc=55

    OpenGL - говно опенсурсное
    Попытался реализовать getPixel и putPixel на OpenGL, в результате получение одного пикселя занимает болшьшую часть времени выполнения программы. Другие люди тоже жалуются на тормознутость функций OpenGL, вроде glDrawPixels и glReadPixels

    https://stackoverflow.com/questions/39821850/why-is-glreadpixels-so-slow-and-are-there-any-alternative
    https://stackoverflow.com/questions/36534933/gldrawpixels-vs-textures-to-draw-a-2d-buffer-in-opengl

    >glDrawPixels is known to be very slow

    Зачем вообще нужно все это 3d ускорение? В DOS все было идеально:
    ((uint8_t*)(0xB8000))[y*320+x] = pixel

    почему нельзя современным программам предоставить такой 0xB8000 адрес и пару регистров вывода? Зачем все эти ритуалы? И да, MMU и protected mode значительно замедляют доступ к памяти, посему современный DOS работал бы на порядок быстрей Windows/Linux. Протекция памяти оправдана только на этапе разработки программы, а для release билда ее лучше отключить, чтобы иметь прямой доступ к реальной памяти.

    И я не одинок в негодовании:
    https://stackoverflow.com/questions/39430404/drawing-pixels-in-opengl

    >I'm using integrated GPU (Intel HD graphics 4000), as far as I know CPU and GPU share the same memory so why is it that I need to download? Why is it impossible to get a pointer?

    Начинаю думать, что Unabomber был прав во всем - надо к чертям взорвать офисы мразотных бюрократов из Khronos Group.

    j123123, 05 Мая 2018

    Комментарии (48)