1. Куча / Говнокод #24261

    −4

    1. 1
    http://www.netlore.ru/Goatse

    Тут новых гоатсекартинок прибыло.

    syoma, 13 Мая 2018

    Комментарии (2)
  2. Куча / Говнокод #24259

    −5

    1. 1
    Какие символы надо экранировать в строке помершелла?

    syoma, 13 Мая 2018

    Комментарии (5)
  3. Python / Говнокод #24255

    −2

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    secs = 0
    fsecs = 0.0
    mins = 40
    lastsecs = 0
    prevsecs = 0
    
    def getTimeStr() :
        def f ( x ) :
            if ( 10 <= x <= 19 ) : return ''
            y = x % 10
            if ( y == 1 ) : return 'а'
            if ( 2 <= y <= 4 ) : return 'ы'
            return ''
        return 'Время: %d минут%s %d секунд%s' % ( mins , f ( mins ) , secs , f ( secs ) )
    
    def updateTimer() :
        global timeString , root , secs , fsecs , lastsecs , prevsecs , mins
        if ( fin ) : return
        prevsecs , lastsecs = lastsecs , clock()
        t = secs
        if ( fsecs > 0 ) :
            fsecs -= lastsecs - prevsecs
            secs = int ( fsecs )
        elif ( mins > 0 ) :
            mins -= 1
            fsecs = 60 + fsecs - lastsecs + prevsecs
            secs = int ( fsecs )
        else :
            finish()
        if ( secs == t ) :
            timeString [ 'text' ] = getTimeStr()
        root.after ( 100 , updateTimer )

    Святая Питония и tkinter

    shit_again, 12 Мая 2018

    Комментарии (7)
  4. Куча / Говнокод #24253

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    47. 47
    48. 48
    49. 49
    50. 50
    51. 51
    52. 52
    53. 53
    54. 54
    55. 55
    56. 56
    57. 57
    58. 58
    59. 59
    60. 60
    61. 61
    62. 62
    63. 63
    64. 64
    65. 65
    66. 66
    67. 67
    68. 68
    69. 69
    70. 70
    71. 71
    72. 72
    73. 73
    74. 74
    75. 75
    76. 76
    77. 77
    78. 78
    79. 79
    80. 80
    81. 81
    82. 82
    83. 83
    84. 84
    85. 85
    86. 86
    87. 87
    88. 88
    89. 89
    90. 90
    // https://github.com/Navadvipa-Chandra-das/prabhupada_calendar/blob/master/source/Prabhupada_convert.d
    
        bool день_ли_это;
        Тип_строки вид_строки;
        
        Класс_Хитрый_накопитель Хитрый_накопитель = new Класс_Хитрый_накопитель( !Нужно_ли_удалять_пустые_дни, !Нужно_ли_удалять_пустые_дни_окончания_поста, Выходной_файл );
        // цикл не простой, а с меткой "цикл"
        цикл: while ( ( строка = Входной_файл.readln() ) !is null ) {
    
          if ( Нужно_ли_удалять_служебные_строки ) {
            if ( строка.length < 3 )
              // чудо, а не возможность! Можно делать любые переходы и вылеты из множества вложенных циклов!
              continue цикл;
            служебная_строка = matchFirst( строка, выражение_служебная_строка );
            if ( служебная_строка.captures.length > 0 )
              continue цикл;
          }
        
          день_месяца = matchFirst( строка, выражение_день );
          день_ли_это = день_месяца.captures.length > 0;
          
          if ( день_ли_это ) {
            вид_строки = Тип_строки.День;
            if ( Нужна_ли_табуляция ) {
              строка = "\t"c ~ день_месяца.captures[ 1 ] ~ "\t"c ~ день_месяца.captures[ 2 ]              ~ "\t"c ~ день_месяца.captures[ 3 ] ~
                       "\t"c ~ день_месяца.captures[ 4 ] ~ "\t"c ~ день_месяца.captures[ 6 ].stripRight() ~ "\t"c ~ день_месяца.captures[ 7 ] ~
                       "\t"c ~ день_месяца.captures[ 8 ] ~ "\t"c ~ день_месяца.captures[ 10 ];
              // обрабатываем "звездочку" поста
              if ( день_месяца.captures[ 11 ].indexOf( '*' ) != -1 )
                строка ~= "\t*"c;
              строка ~= "\n";
            }
            // Удаляем, при желании комментрий к Экадаши - подходит для поста и не додходит для поста. Все равно есть еще символ звездочка и
            // строка с именем Экадаши и явным упоминанием о посте!
            if ( Нужно_ли_удалять_комментарий_Экадаши ) {
              строка = replaceFirst( строка, выражение_для_чистки_комментария_Экадаши, ""c );
            }
          } else {
            проверка_месяца = matchFirst( строка, выражение_месяц_ли_это );
            if ( проверка_месяца.captures.length > 0 ) {
              вид_строки = Тип_строки.Месяц;
              // Просто удаляем цепочку начальных пробелов в строках месяца, если готовим табуляцию
              if ( Нужна_ли_табуляция )
                строка = replaceFirst( строка, выражение_цепочка_пробелов_в_начале_строки, ""c );
            } else {
              // Заменяем цепочку пробелов вначале строки на один единственный символ табуляции для праздников, но только если нужна табуляция
              пробелы_в_начале_строки = matchFirst( строка, выражение_цепочка_пробелов_в_начале_строки );
              if ( пробелы_в_начале_строки.captures.length > 0 ) {
                окончание_поста = matchFirst( строка, выражение_окончание_поста );
                if ( окончание_поста.captures.length > 0 )
                  вид_строки = Тип_строки.Окончание_поста;
                else
                  вид_строки = Тип_строки.Праздник;
                if ( Нужна_ли_табуляция )
                  строка = replaceFirst( строка, выражение_цепочка_пробелов_в_начале_строки, "\t"c );
              } else
                вид_строки = Тип_строки.Солнце;
            }
          }
    
          // Удаляем строки из тире и GCal, но только если нужна табуляци. В книге они не нужны.
          // Можно указать номер версии программы GCal в колонтитулах книги при желании
          if ( Нужна_ли_табуляция ) {
            if ( вид_строки == Тип_строки.Месяц )
              строка = replaceAll( строка, выражение_для_чистки_Месяца, ""c );
            if ( вид_строки == Тип_строки.Солнце )
              строка = replaceAll( строка, выражение_для_чистки_Солнца, ""c );
          }
          
          // Переводим сначала фразы. Длительная операция, так как переводятся все имеющиеся фразы, не зависимо от того, встречаются ли они в строке или нет
          foreach ( ref фраза; фразы )
            строка = replaceAll( строка, regex( фраза ), _Словарь_фраз[ фраза ] );
    
          // Переводим слова. Быстрее, так как переводятся только те слова, которые встречаются в данной конкретной строке
          слова = std.regex.split( строка, выражение_разделитель );
          // сортируем, чтобы короткие слова не позаменялись в более длинных словах внутри
          // Вдохнули поглубже! Такого чуда я еще не видел! Не иначе как mixin в действии!
          слова.sort!( "a.length > b.length" );
          foreach ( ref слово; слова )
            if ( слово.length > 0 )
              строка = replaceAll!( Чудо_слов )( строка, regex( слово ) );
          
          Хитрый_накопитель.В_копилку( строка, вид_строки );
        }
        // Пропихнем в файл последнюю строку
        Хитрый_накопитель.В_копилку( ""c, Тип_строки.День );
    
        window.showMessageBox( UIString.fromId( "ЧЕСТЬ_ИМЕЮ_ДОЛОЖИТЬ"c ),
                               UIString.fromId( "ЗАДАНИЕ_ВЫПОЛНЕНО!"c ) );
    }

    Кришнаит, пишущий на языке D в стиле 1С

    j123123, 12 Мая 2018

    Комментарии (10)
  5. Java / Говнокод #24249

    +3

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    9. 9
    if (x_sum_first_row == 3 || x_sum_second_row == 3 || x_sum_third_row == 3 ||
                x_sum_first_column == 3 || x_sum_second_column == 3 || x_sum_third_column == 3 ||
                x_sumDiagonalLR == 3 || x_sumDiagonalRL == 3 ||
                o_sum_first_row == 3 || o_sum_second_row == 3 || o_sum_third_row == 3 ||
                o_sum_first_column == 3 || o_sum_second_column == 3 || o_sum_third_column == 3 ||
                o_sumDiagonalLR == 3 || o_sumDiagonalRL == 3)
                someoneWon = true;
    
            return someoneWon;

    https://codereview.stackexchange.com/questions/125248/java-tic-tac-toe-game-implemented-through-mvc

    roskomgovno, 11 Мая 2018

    Комментарии (5)
  6. Си / Говнокод #24247

    −3

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    double m_sqrt (double p){
                 double l = 1;
                 double m = 0;
    	
           for(m  =  (l +  ( p / l )   )  / 2;          
    		m  !=  l ;  
    		m  =  (l +  ( p / l )   )  / 2){
    	 	l = m; 
    	}
    
    return m;
    }

    tyrin, 10 Мая 2018

    Комментарии (8)
  7. Java / Говнокод #24245

    +3

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    9. 9
    public static Date round(Date d) {
        try {
            SimpleDateFormat sdf = new SimpleDateFormat("ddMMyyyy");
            return sdf.parse(sdf.format(d));
        } catch (ParseException ex) {
            //This exception will never be thrown, because sdf parses what it formats
            return d;
        }
    }

    Простейший коробочный способ округления даты до дня.

    3.14159265, 10 Мая 2018

    Комментарии (9)
  8. SQL / Говнокод #24243

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    select
      x1.airport, x1.amount, x1.exempt
    from
      Taxes x1
    where
      x1.code = 'departure'
      and x1.airport in (
        select
          xx1.airport
        from
          (select
            yx1.airport
          from
            Taxes yx1
          where
            yx1.airport = x1.airport
            and yx1.code = x1.code
          group by
            yx1.airport, yx1.amount, yx1.exempt
          ) xx1
        group by xx1.airport
        having count(xx1.airport) > 1
      )
    ;

    Давно я не копался в SQL. Вот что нагородил :(

    Суть такова: у аэропортов есть departure tax, который может быть разный в зависимости от некоторых критериев (нерелевантно каких).
    А может быть и одинаковый. Но все равно аэропорт может иметь несколько рядков в БД (с одинаковым amount). А еще может быть exempt = 'X',
    что тождественно amount = 0.

    Задача: выбрать все рядки с departure tax для аэропортов у которых taxamt/exempt разный в зависимости от некоторых других критериев.

    Elvenfighter, 10 Мая 2018

    Комментарии (11)
  9. C++ / Говнокод #24241

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    https://github.com/dotnet/coreclr/blob/a589e3926a1780256fdb52376f8681fe047daf54/src/vm/i386/cgenx86.cpp#L1551-L1553
    
        PAL_TRY(Param *, pParam, &param)
        {
            unsigned char buffer[16];
            DWORD* dwBuffer = NULL;
    
            DWORD maxCpuId = getcpuid(0, buffer);
    
            if (maxCpuId < 1)
                goto lDone;
    
            dwBuffer = (DWORD*)buffer;
    
            if (dwBuffer[1] == 'uneG') {
                if (dwBuffer[3] == 'Ieni') {
                    if (dwBuffer[2] == 'letn')  {  // get SMT/multicore enumeration for Intel EM64T

    С каких пор в одинарные кавычки можно писать больше одного символа? Это какое-то MSVC или что?

    j123123, 09 Мая 2018

    Комментарии (231)
  10. 1C / Говнокод #24240

    +1

    1. 001
    2. 002
    3. 003
    4. 004
    5. 005
    6. 006
    7. 007
    8. 008
    9. 009
    10. 010
    11. 011
    12. 012
    13. 013
    14. 014
    15. 015
    16. 016
    17. 017
    18. 018
    19. 019
    20. 020
    21. 021
    22. 022
    23. 023
    24. 024
    25. 025
    26. 026
    27. 027
    28. 028
    29. 029
    30. 030
    31. 031
    32. 032
    33. 033
    34. 034
    35. 035
    36. 036
    37. 037
    38. 038
    39. 039
    40. 040
    41. 041
    42. 042
    43. 043
    44. 044
    45. 045
    46. 046
    47. 047
    48. 048
    49. 049
    50. 050
    51. 051
    52. 052
    53. 053
    54. 054
    55. 055
    56. 056
    57. 057
    58. 058
    59. 059
    60. 060
    61. 061
    62. 062
    63. 063
    64. 064
    65. 065
    66. 066
    67. 067
    68. 068
    69. 069
    70. 070
    71. 071
    72. 072
    73. 073
    74. 074
    75. 075
    76. 076
    77. 077
    78. 078
    79. 079
    80. 080
    81. 081
    82. 082
    83. 083
    84. 084
    85. 085
    86. 086
    87. 087
    88. 088
    89. 089
    90. 090
    91. 091
    92. 092
    93. 093
    94. 094
    95. 095
    96. 096
    97. 097
    98. 098
    99. 099
    100. 100
    Функция СоздатьМассив // Экспорт, 29 параметров
    (
    	Значение01 = '05710422152926',
    	Значение02 = '05710422152926',
    	Значение03 = '05710422152926',
    	Значение04 = '05710422152926',
    	Значение05 = '05710422152926',
    	Значение06 = '05710422152926',
    	Значение07 = '05710422152926',
    	Значение08 = '05710422152926',
    	Значение09 = '05710422152926',
    	Значение10 = '05710422152926',
    	Значение11 = '05710422152926',
    	Значение12 = '05710422152926',
    	Значение13 = '05710422152926',
    	Значение14 = '05710422152926',
    	Значение15 = '05710422152926',
    	Значение16 = '05710422152926',
    	Значение17 = '05710422152926',
    	Значение18 = '05710422152926',
    	Значение19 = '05710422152926',
    	Значение20 = '05710422152926',
    	Значение21 = '05710422152926',
    	Значение22 = '05710422152926',
    	Значение23 = '05710422152926',
    	Значение24 = '05710422152926',
    	Значение25 = '05710422152926',
    	Значение26 = '05710422152926',
    	Значение27 = '05710422152926',
    	Значение28 = '05710422152926',
    	Значение29 = '05710422152926'
    )
    Экспорт
    	
    	Нил_ = '05710422152926'; // Предположительная дата рождения пророка Мухаммеда
    	
    	Если Нил_ = Значение02 Тогда
    		Если Нил_ = Значение01 Тогда
    			Массив_ = Новый Массив;
    			Перейти ~Метка00;
    		Иначе
    			Массив_ = Новый Массив(1);
    			Перейти ~Метка01;
    		КонецЕсли;
    	ИначеЕсли Нил_ = Значение06 Тогда
    		Если Нил_ = Значение04 Тогда
    			Если Нил_ = Значение03 Тогда
    				Массив_ = Новый Массив(2);
    				Перейти ~Метка02;
    			Иначе
    				Массив_ = Новый Массив(3);
    				Перейти ~Метка03;
    			КонецЕсли;
    		ИначеЕсли Нил_ = Значение05 Тогда
    			Массив_ = Новый Массив(4);
    			Перейти ~Метка04;
    		Иначе
    			Массив_ = Новый Массив(5);
    			Перейти ~Метка05;
    		КонецЕсли;
    	ИначеЕсли Нил_ = Значение14 Тогда
    		Если Нил_ = Значение10 Тогда
    			Если Нил_ = Значение08 Тогда
    				Если Нил_ = Значение07 Тогда
    					Массив_ = Новый Массив(6);
    					Перейти ~Метка06;
    				Иначе
    					Массив_ = Новый Массив(7);
    					Перейти ~Метка07;
    				КонецЕсли;
    			ИначеЕсли Нил_ = Значение09 Тогда
    				Массив_ = Новый Массив(8);
    				Перейти ~Метка08;
    			Иначе
    				Массив_ = Новый Массив(9);
    				Перейти ~Метка09;
    			КонецЕсли;
    		ИначеЕсли Нил_ = Значение12 Тогда
    			Если Нил_ = Значение11 Тогда
    				Массив_ = Новый Массив(10);
    				Перейти ~Метка10;
    			Иначе
    				Массив_ = Новый Массив(11);
    				Перейти ~Метка11;
    			КонецЕсли;
    		ИначеЕсли Нил_ = Значение13 Тогда
    			Массив_ = Новый Массив(12);
    			Перейти ~Метка12;
    		Иначе
    			Массив_ = Новый Массив(13);
    			Перейти ~Метка13;
    		КонецЕсли;
    	ИначеЕсли Нил_ = Значение22 Тогда
    		Если Нил_ = Значение18 Тогда
    			Если Нил_ = Значение16 Тогда
    				Если Нил_ = Значение15 Тогда
    					Массив_ = Новый Массив(14);
    					Перейти ~Метка14;
    				Иначе
    					Массив_ = Новый Массив(15);

    1С Медицина: Больничные
    Халяль

    elizir, 09 Мая 2018

    Комментарии (6)