1. Список говнокодов пользователя sandvich

    Всего: 7

  2. 1C / Говнокод #27048

    −1

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    Функция ВнешнийОтчетВФоновомЗадании(НаимРеглОтч)
    	...
    		ИмяОбработки = ВнешниеОтчеты.Подключить(АдресВоВременномХранилище, , Ложь);
    		Возврат ВнешниеОтчеты.Создать(ИмяОбработки, Истина);
    	...
    КонецФункции

    В фоновом задании создаем внешний отчет с БезопасныйРежим=Истина. Вопрос, типа, "предупреждение безопасности, разрешить открывать данный файл?", конечно, никому не выходит. Итог для пользователя - ошибка. Что за звездец! Как можно задавать вопрос в фоновом? Зачем? ЗУП 3.1 типовая

    sandvich, 22 Октября 2020

    Комментарии (8)
  3. 1C / Говнокод #27024

    0

    1. 1
    2. 2
    3. 3
    Если Ложь Тогда
    	Объ = Документы.ПоступлениеТоваровУслуг.СоздатьДокумент();	
    КонецЕсли;

    Умиляет

    sandvich, 13 Октября 2020

    Комментарии (20)
  4. 1C / Говнокод #26998

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    ДанныеКальлулятора = ПолучитьДанныеКалькулятораПоЗаявке(Заявка);
    	Расчет = ДанныеКальлулятора["ТЧ.Расчет"].Скопировать();
    	
    	ОстаточнаяПроцент = ДанныеКальлулятора["впОстаточнаяСтоимость"];
    	ПроцентнаяСтавка = ПолучитьДанныеКалькулятораПоЗаявке(Заявка)["рпСтоимостьКапитала"];
    	СрокЛизингаСтарыйИзКалькулятора = ПолучитьДанныеКалькулятораПоЗаявке(Заявка)["впСрокЛизинга"];
    	
    	ГибридСтавкаФинансированияКапитальнаяЧасть = ПолучитьДанныеКалькулятораПоЗаявке(Заявка)["ГибридСтавкаФинансированияКапитальнаяЧасть"];
    	ГибридСтавкаФинансированияОстаточнаяЧасть = ПолучитьДанныеКалькулятораПоЗаявке(Заявка)["ГибридСтавкаФинансированияОстаточнаяЧасть"];
    	ГибридФианансоваяМаржаКапитальнаяЧасть = ПолучитьДанныеКалькулятораПоЗаявке(Заявка)["ГибридФианансоваяМаржаКапитальнаяЧасть"];
    	ГибридФианансоваяМаржаОстаточнаяЧасть = ПолучитьДанныеКалькулятораПоЗаявке(Заявка)["ГибридФианансоваяМаржаОстаточнаяЧасть"];

    Как ж бомбит. Отраслёвка лизинговая

    sandvich, 02 Октября 2020

    Комментарии (7)
  5. 1C / Говнокод #26484

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    Запрос = Новый Запрос;
    	Запрос.Текст = 
    	"ВЫБРАТЬ
    	|	КадроваяИсторияСотрудников.Должность КАК Должность,
    	|	КадроваяИсторияСотрудников.Подразделение КАК Подразделение
    	|ИЗ
    	|	РегистрСведений.КадроваяИсторияСотрудников КАК КадроваяИсторияСотрудников
    	|ГДЕ
    	|	КадроваяИсторияСотрудников.Период < &Период
    	|	И КадроваяИсторияСотрудников.Сотрудник = &Сотрудник";
    	
    	Запрос.УстановитьПараметр("Период", СсылкаНаОбъект.Дата);
    	Запрос.УстановитьПараметр("Сотрудник", СсылкаНаОбъект.Сотрудник);
    	
    	ТзДолжность = Запрос.Выполнить().Выгрузить();
    	Поз = ТзДолжность.Количество() - 1;
    	
    	Структура = Новый Структура();
    	
    	...
    	
    	Структура.Вставить("ПодразделениеОрганизацииКаз", ТзДолжность[Поз].Подразделение._НаименованиеКаз);

    Когда джуны на проекте по ЕРП

    sandvich, 09 Марта 2020

    Комментарии (3)
  6. 1C / Говнокод #26004

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    Функция УбратьПробел(стрЧисло)
    	//убирает пустой пробел
    	нСтр = "";
    	Для п=1 По СтрДлина(стрЧисло) Цикл
    		р = Сред(стрЧисло,п,1);
    		Если р = "1" ИЛИ р = "2" ИЛИ р = "3" ИЛИ р = "4" ИЛИ р = "5" ИЛИ р = "6" ИЛИ р = "7" ИЛИ р = "8" ИЛИ р = "9" ИЛИ р = "0" ИЛИ р = "," Тогда
    			нСтр = нСтр+р;
    		КонецЕсли;
    	КонецЦикла;
    	Возврат нСтр;
    КонецФункции

    Senior

    sandvich, 30 Октября 2019

    Комментарии (37)
  7. 1C / Говнокод #25660

    +2

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    ПроизведенаРабота = Истина;
    	
    Если ЗапрашиватьТрудозатраты И Не ВыполняетсяПеренаправление Тогда
    	ПроизведенаРабота = Истина;
    КонецЕсли;

    Типично

    sandvich, 04 Июня 2019

    Комментарии (78)
  8. 1C / Говнокод #25568

    +2

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    Функция ПолучитьСтавкуНДС(СуммаСНДС, НДС)
    	Если НДС = 0  Тогда
    		Возврат Перечисления.СтавкиНДС.БезНДС;
    	ИначеЕсли СуммаСНДС = 0 Тогда //некорректные данные
    		Возврат Перечисления.СтавкиНДС.БезНДС;
    	ИначеЕсли НДС / СуммаСНДС <= 0.152+0.0152 и НДС / СуммаСНДС >= 0.152-0.0152 Тогда
    		Возврат Перечисления.СтавкиНДС.НДС18;
    	ИначеЕсли НДС / СуммаСНДС <= 0.091+0.0091 и НДС / СуммаСНДС >= 0.091-0.0091 Тогда
    		Возврат Перечисления.СтавкиНДС.НДС10;
    	КонецЕсли;
    КонецФункции

    Костыль костыльный

    sandvich, 24 Апреля 2019

    Комментарии (31)